public
Created

Codebrawl on rbx

  • Download Gist
gistfile1.txt
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199
$ bundle exec rspec spec/
No DRb server is running. Running in local process instead ...
An exception occurred at_exit handler
Could not open library /Users/jeff/.rvm/gems/rbx-master/gems/ffi-1.0.9/lib/ffi_c.bundle - dlopen(/Users/jeff/.rvm/gems/rbx-master/gems/ffi-1.0.9/lib/ffi_c.bundle, 10): Symbol not found: _rb_class_inherited_p (LoadError::InvalidExtensionError)
 
Backtrace:
Rubinius::NativeMethod.load_extension at kernel/common/native_method.rb:26
Rubinius::CodeLoader#load_library at kernel/delta/codeloader.rb:163
Rubinius::CodeLoader#require at kernel/common/codeloader.rb:41
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:143
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems/ffi-1.0.9
/lib/ffi.rb:8
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems
/rubypython-0.5.1/lib
/rubypython/python.rb:1
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems
/rubypython-0.5.1/lib
/rubypython.rb:33
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems
/pygments.rb-0.1.2/lib
/pygments/ffi.rb:1
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems
/pygments.rb-0.1.2/lib
/pygments.rb:2
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems/gust-0.2.2
/lib/gust.rb:1
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel.require at kernel/common/kernel.rb:783
{ } in Bundler::Runtime#require at /Users/jeff/.rvm/gems/rbx-master/gems
/bundler-1.0.15/lib/bundler
/runtime.rb:68
Array#each at kernel/bootstrap/array.rb:76
{ } in Bundler::Runtime#require at /Users/jeff/.rvm/gems/rbx-master/gems
/bundler-1.0.15/lib/bundler
/runtime.rb:66
Array#each at kernel/bootstrap/array.rb:76
Bundler::Runtime#require at /Users/jeff/.rvm/gems/rbx-master/gems
/bundler-1.0.15/lib/bundler
/runtime.rb:55
Bundler.require at /Users/jeff/.rvm/gems/rbx-master/gems
/bundler-1.0.15/lib/bundler.rb:120
Object#__script__ at config/application.rb:10
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at config/environment.rb:2
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
{ } in Object#__script__ at spec/spec_helper.rb:6
Spork.prefork at /Users/jeff/.rvm/gems/rbx-master/gems
/spork-0.9.0.rc7/lib/spork.rb:24
Object#__script__ at spec/spec_helper.rb:3
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at spec/acceptance
/acceptance_helper.rb:1
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at spec/acceptance
/articles_spec.rb:1
Kernel(RSpec::Core::Configuration)#load at kernel/common/kernel.rb:732
{ } in RSpec::Core::Configuration#load_spec_files at /Users/jeff/.rvm/gems
/rbx-master/gems
/rspec-core-2.6.4/lib
/rspec/core
/configuration.rb:419
Array#map at kernel/bootstrap/array.rb:97
RSpec::Core::Configuration#load_spec_files at /Users/jeff/.rvm/gems/rbx-master
/gems/rspec-core-2.6.4/lib/rspec
/core/configuration.rb:419
RSpec::Core::CommandLine#run at /Users/jeff/.rvm/gems/rbx-master/gems
/rspec-core-2.6.4/lib/rspec/core
/command_line.rb:18
RSpec::Core::Runner.run_in_process at /Users/jeff/.rvm/gems/rbx-master/gems
/rspec-core-2.6.4/lib/rspec/core
/runner.rb:80
RSpec::Core::Runner.run at /Users/jeff/.rvm/gems/rbx-master/gems
/rspec-core-2.6.4/lib/rspec/core
/runner.rb:66
{ } in RSpec::Core::Runner.autorun at /Users/jeff/.rvm/gems/rbx-master/gems
/rspec-core-2.6.4/lib/rspec/core
/runner.rb:11
Rubinius::Loader#epilogue at kernel/loader.rb:660
Rubinius::Loader#main at kernel/loader.rb:791
 
Caused by: Could not open library /Users/jeff/.rvm/gems/rbx-master/gems/ffi-1.0.9/lib/ffi_c.bundle - dlopen(/Users/jeff/.rvm/gems/rbx-master/gems/ffi-1.0.9/lib/ffi_c.bundle, 10): Symbol not found: _rb_class_inherited_p (LoadError)
 
Backtrace:
FFI::DynamicLibrary#initialize at kernel/platform/library.rb:229
Rubinius::NativeMethod.load_extension at kernel/common/native_method.rb:24
Rubinius::CodeLoader#load_library at kernel/delta/codeloader.rb:163
Rubinius::CodeLoader#require at kernel/common/codeloader.rb:41
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:143
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems/ffi-1.0.9
/lib/ffi.rb:8
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems
/rubypython-0.5.1/lib
/rubypython/python.rb:1
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems
/rubypython-0.5.1/lib
/rubypython.rb:33
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems
/pygments.rb-0.1.2/lib
/pygments/ffi.rb:1
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems
/pygments.rb-0.1.2/lib
/pygments.rb:2
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at /Users/jeff/.rvm/gems
/rbx-master/gems/gust-0.2.2
/lib/gust.rb:1
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel.require at kernel/common/kernel.rb:783
{ } in Bundler::Runtime#require at /Users/jeff/.rvm/gems/rbx-master/gems
/bundler-1.0.15/lib/bundler
/runtime.rb:68
Array#each at kernel/bootstrap/array.rb:76
{ } in Bundler::Runtime#require at /Users/jeff/.rvm/gems/rbx-master/gems
/bundler-1.0.15/lib/bundler
/runtime.rb:66
Array#each at kernel/bootstrap/array.rb:76
Bundler::Runtime#require at /Users/jeff/.rvm/gems/rbx-master/gems
/bundler-1.0.15/lib/bundler
/runtime.rb:55
Bundler.require at /Users/jeff/.rvm/gems/rbx-master/gems
/bundler-1.0.15/lib/bundler.rb:120
Object#__script__ at config/application.rb:10
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at config/environment.rb:2
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
{ } in Object#__script__ at spec/spec_helper.rb:6
Spork.prefork at /Users/jeff/.rvm/gems/rbx-master/gems
/spork-0.9.0.rc7/lib/spork.rb:24
Object#__script__ at spec/spec_helper.rb:3
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at spec/acceptance
/acceptance_helper.rb:1
Rubinius::CodeLoader.require at kernel/common/codeloader.rb:147
Kernel(Object)#require at kernel/common/kernel.rb:783
Object#__script__ at spec/acceptance
/articles_spec.rb:1
Kernel(RSpec::Core::Configuration)#load at kernel/common/kernel.rb:732
{ } in RSpec::Core::Configuration#load_spec_files at /Users/jeff/.rvm/gems
/rbx-master/gems
/rspec-core-2.6.4/lib
/rspec/core
/configuration.rb:419
Array#map at kernel/bootstrap/array.rb:97
RSpec::Core::Configuration#load_spec_files at /Users/jeff/.rvm/gems/rbx-master
/gems/rspec-core-2.6.4/lib/rspec
/core/configuration.rb:419
RSpec::Core::CommandLine#run at /Users/jeff/.rvm/gems/rbx-master/gems
/rspec-core-2.6.4/lib/rspec/core
/command_line.rb:18
RSpec::Core::Runner.run_in_process at /Users/jeff/.rvm/gems/rbx-master/gems
/rspec-core-2.6.4/lib/rspec/core
/runner.rb:80
RSpec::Core::Runner.run at /Users/jeff/.rvm/gems/rbx-master/gems
/rspec-core-2.6.4/lib/rspec/core
/runner.rb:66
{ } in RSpec::Core::Runner.autorun at /Users/jeff/.rvm/gems/rbx-master/gems
/rspec-core-2.6.4/lib/rspec/core
/runner.rb:11
Rubinius::Loader#epilogue at kernel/loader.rb:660
Rubinius::Loader#main at kernel/loader.rb:791

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.