Skip to content

Instantly share code, notes, and snippets.

Show Gist options
  • Select an option

  • Save CarissaDurko/62d09bdef7c7189897cf04658cdfa856 to your computer and use it in GitHub Desktop.

Select an option

Save CarissaDurko/62d09bdef7c7189897cf04658cdfa856 to your computer and use it in GitHub Desktop.
KQL Password File Query
DeviceFileEvents
| where FileName has_any("password", "credentials", "logins", "log in")
| where not(FileName endswith ".svg" or FileName endswith ".gif" or FileName endswith ".css" or FileName endswith ".png" or FileName endswith ".js" or FileName contains "Keeper" or FileName endswith ".dll" or FileName endswith ".sh" or FileName contains "reprompt"
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment