Skip to content

Instantly share code, notes, and snippets.

Show Gist options
  • Select an option

  • Save CarissaDurko/f542c89ac39d946b26b1c8567574f4d9 to your computer and use it in GitHub Desktop.

Select an option

Save CarissaDurko/f542c89ac39d946b26b1c8567574f4d9 to your computer and use it in GitHub Desktop.
KQL Malicious IP Blocks by Domain
AADSignInEventsBeta
| where ErrorCode == 50053
| where TimeStamp > ago(30d)
| where AccountUPN has "enterdomainhere.com"
| project AccountDisplayName, AccountUPN, AccountObjectId, DeviceName, UserAgent, ClientAppUsed, Browser, Country
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment