Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

mpd fails to compile on 10.6.8 #6709

Closed
frub3nz opened this Issue · 1 comment

1 participant

@frub3nz

I am trying to install mpd along with ncmpcpp but when I try to install mpd I get the error "Error: Failed executing make install".
Here's the full output:

brew install mpd
Password:
==> Downloading http://downloads.sourceforge.net/project/musicpd/mpd/0.16.2/mpd-
######################################################################## 100.0%
==> ./configure --disable-debug --disable-dependency-tracking --prefix=/usr/loca
==> make install
does everything normally, too much text, then...
src/decoder/ffmpeg_decoder_plugin.c: In function ‘ffmpeg_find_audio_stream’:
src/decoder/ffmpeg_decoder_plugin.c:159: error: ‘CODEC_TYPE_AUDIO’ undeclared (first use in this function)
src/decoder/ffmpeg_decoder_plugin.c:159: error: (Each undeclared identifier is reported only once
src/decoder/ffmpeg_decoder_plugin.c:159: error: for each function it appears in.)
make: *** [src/decoder/src_mpd-ffmpeg_decoder_plugin.o] Error 1
make: *** Waiting for unfinished jobs....
==> Exit Status: 2
http://github.com/mxcl/homebrew/blob/master/Library/Formula/mpd.rb#L42
==> Environment
HOMEBREW_VERSION: 0.8
HEAD: 64bcd8c
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
HOMEBREW_REPOSITORY: /usr/local
HOMEBREW_LIBRARY_PATH: /usr/local/Library/Homebrew
Hardware: dual-core 64-bit penryn
OS X: 10.6.8
Kernel Architecture: i386
Ruby: 1.8.7-174
/usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
Xcode: 3.2.5
GCC-4.0: build 5494
GCC-4.2: build 5664
LLVM: build 2333
MacPorts or Fink? false
X11 installed? true
==> Build Flags
CC: /usr/bin/cc => /usr/bin/gcc-4.2
CXX: /usr/bin/c++ => /usr/bin/c++-4.2
LD: /usr/bin/cc => /usr/bin/gcc-4.2
CFLAGS: -O3 -march=core2 -msse4.1 -w -pipe -I/usr/local/include
CXXFLAGS: -O3 -march=core2 -msse4.1 -w -pipe
MAKEFLAGS: -j2

Error: Failed executing: make install
Please report this bug: https://github.com/mxcl/homebrew/wiki/Checklist-before-filing-a-new-issue
These existing issues may help you:
https://github.com/mxcl/homebrew/issues/#issue/6517

Also try:
brew doctor to check your setup for common problems.
brew missing to check installed packages for missing deps.

@frub3nz

Issue seemed to be with attempting to compile whilst ffmpeg was installed, after uninstalling ffmpeg, mpd and ncmpcpp installed fine. I do not recommend installing with ffmpeg, ALAC support is not worth the trouble.

@frub3nz frub3nz closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.