Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Errors when running nix-shell
(imported from Control.Monad.Trans.Error):
Deprecated: "Use Control.Monad.Trans.Except instead"
|
242 | x <- E.runErrorT (f (E.runErrorT m))
| ^^^^^^^^^^^
src/Control/Monad/Morph.hs:242:30: warning: [-Wdeprecations]
In the use of ‘runErrorT’
(imported from Control.Monad.Trans.Error):
Deprecated: "Use Control.Monad.Trans.Except instead"
|
242 | x <- E.runErrorT (f (E.runErrorT m))
| ^^^^^^^^^^^
src/Control/Monad/Morph.hs:259:17: warning: [-Wdeprecations]
In the use of type constructor or class ‘ListT’
(imported from Control.Monad.Trans.List):
Deprecated: "This transformer is invalid on most monads"
|
259 | instance MMonad L.ListT where
| ^^^^^^^
src/Control/Monad/Morph.hs:260:17: warning: [-Wdeprecations]
In the use of data constructor ‘ListT’
(imported from Control.Monad.Trans.List):
Deprecated: "This transformer is invalid on most monads"
|
260 | embed f m = L.ListT (do
| ^^^^^^^
src/Control/Monad/Morph.hs:261:14: warning: [-Wdeprecations]
In the use of ‘runListT’ (imported from Control.Monad.Trans.List):
Deprecated: "This transformer is invalid on most monads"
|
261 | x <- L.runListT (f (L.runListT m))
| ^^^^^^^^^^
src/Control/Monad/Morph.hs:261:29: warning: [-Wdeprecations]
In the use of ‘runListT’ (imported from Control.Monad.Trans.List):
Deprecated: "This transformer is invalid on most monads"
|
261 | x <- L.runListT (f (L.runListT m))
| ^^^^^^^^^^
Using Parsec parser
Configuring unordered-containers-0.2.10.0...
Flags chosen: debug=False
Dependency base >=4.7 && <5: using base-4.12.0.0
Dependency deepseq >=1.1: using deepseq-1.4.4.0
Dependency hashable >=1.0.1.1 && <1.4: using hashable-1.3.0.0
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
[2 of 2] Compiling Control.Monad.Trans.Compose ( src/Control/Monad/Trans/Compose.hs, dist/build/Control/Monad/Trans/Compose.o )
Source component graph: component lib
Configured component graph:
component unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid
include base-4.12.0.0
include deepseq-1.4.4.0
include hashable-1.3.0.0-LeQnUwunJyKHYytZJVGuTk
Linked component graph:
unit unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid
include base-4.12.0.0
include deepseq-1.4.4.0
include hashable-1.3.0.0-LeQnUwunJyKHYytZJVGuTk
Data.HashMap.Lazy=unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid:Data.HashMap.Lazy,Data.HashMap.Strict=unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid:Data.HashMap.Strict,Data.HashSet=unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid:Data.HashSet
Ready component graph:
definite unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid
depends base-4.12.0.0
depends deepseq-1.4.4.0
depends hashable-1.3.0.0-LeQnUwunJyKHYytZJVGuTk
Using Cabal-2.4.0.1 compiled by ghc-8.6
Using compiler: ghc-8.6.5
Using install prefix:
/nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0
Executables installed in:
/nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/bin
Libraries installed in:
/nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/lib/ghc-8.6.5/x86_64-linux-ghc-8.6.5/unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid
Dynamic Libraries installed in:
/nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/lib/ghc-8.6.5/x86_64-linux-ghc-8.6.5
Private executables installed in:
/nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/libexec/x86_64-linux-ghc-8.6.5/unordered-containers-0.2.10.0
Data files installed in:
/nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/share/x86_64-linux-ghc-8.6.5/unordered-containers-0.2.10.0
Documentation installed in:
/nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/share/doc/x86_64-linux-ghc-8.6.5/unordered-containers-0.2.10.0
Configuration files installed in:
/nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/etc
No alex found
Using ar found on system at:
/nix/store/a57856fs4m8ir6vlv14h3gq3sv9aq2lb-binutils-2.31.1/bin/ar
No c2hs found
No cpphs found
No doctest found
Using gcc version 9.3.0 given by user at:
/nix/store/2ddwl0cyff2cd4dkb2nqf1xich7halj0-gcc-wrapper-9.3.0/bin/gcc
Using ghc version 8.6.5 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/ghc
Using ghc-pkg version 8.6.5 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/ghc-pkg
No ghcjs found
No ghcjs-pkg found
No greencard found
Using haddock version 2.22.0 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/haddock
No happy found
Using haskell-suite found on system at: haskell-suite-dummy-location
Using haskell-suite-pkg found on system at: haskell-suite-pkg-dummy-location
No hmake found
Using hpc version 0.67 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/hpc
Using hsc2hs version 0.68.5 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/hsc2hs
Using hscolour version 1.24 found on system at:
/nix/store/1bifrw9qxidhxsjwc1ywflb60s92m0dc-hscolour-1.24.4/bin/HsColour
No jhc found
Using ld found on system at:
/nix/store/2ddwl0cyff2cd4dkb2nqf1xich7halj0-gcc-wrapper-9.3.0/bin/ld
No pkg-config found
Using runghc version 8.6.5 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/runghc
Using strip version 2.31 found on system at:
/nix/store/a57856fs4m8ir6vlv14h3gq3sv9aq2lb-binutils-2.31.1/bin/strip
Using tar found on system at:
/nix/store/kvdl1dd9q9mdwp2gipyvwrs16i4w75lq-gnutar-1.32/bin/tar
No uhc found
building
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
Preprocessing library for unordered-containers-0.2.10.0..
Building library for unordered-containers-0.2.10.0..
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
[ 1 of 10] Compiling Data.HashMap.List ( Data/HashMap/List.hs, dist/build/Data/HashMap/List.o )
[ 2 of 10] Compiling Data.HashMap.Unsafe ( Data/HashMap/Unsafe.hs, dist/build/Data/HashMap/Unsafe.o )
[ 3 of 10] Compiling Data.HashMap.Array ( Data/HashMap/Array.hs, dist/build/Data/HashMap/Array.o )
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
haddockPhase
installing
Installing library in /nix/store/nszfn1l5i2rdia95hg8mbxm3j9vl7nb5-mmorph-1.1.3/lib/ghc-8.6.5/x86_64-linux-ghc-8.6.5/mmorph-1.1.3-FfwptCv2VaAjI2vq7vsWW
post-installation fixup
shrinking RPATHs of ELF executables and libraries in /nix/store/nszfn1l5i2rdia95hg8mbxm3j9vl7nb5-mmorph-1.1.3
strip is /nix/store/a57856fs4m8ir6vlv14h3gq3sv9aq2lb-binutils-2.31.1/bin/strip
stripping (with command strip and flags -S) in /nix/store/nszfn1l5i2rdia95hg8mbxm3j9vl7nb5-mmorph-1.1.3/lib
patching script interpreter paths in /nix/store/nszfn1l5i2rdia95hg8mbxm3j9vl7nb5-mmorph-1.1.3
checking for references to /build/ in /nix/store/nszfn1l5i2rdia95hg8mbxm3j9vl7nb5-mmorph-1.1.3...
[ 4 of 10] Compiling Data.HashMap.UnsafeShift ( Data/HashMap/UnsafeShift.hs, dist/build/Data/HashMap/UnsafeShift.o )
[ 5 of 10] Compiling Data.HashMap.Base ( Data/HashMap/Base.hs, dist/build/Data/HashMap/Base.o )
[ 6 of 10] Compiling Data.HashMap.Strict.Base ( Data/HashMap/Strict/Base.hs, dist/build/Data/HashMap/Strict/Base.o )
[ 7 of 10] Compiling Data.HashSet.Base ( Data/HashSet/Base.hs, dist/build/Data/HashSet/Base.o )
[ 8 of 10] Compiling Data.HashSet ( Data/HashSet.hs, dist/build/Data/HashSet.o )
[ 9 of 10] Compiling Data.HashMap.Strict ( Data/HashMap/Strict.hs, dist/build/Data/HashMap/Strict.o )
[10 of 10] Compiling Data.HashMap.Lazy ( Data/HashMap/Lazy.hs, dist/build/Data/HashMap/Lazy.o )
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
haddockPhase
installing
Installing library in /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/lib/ghc-8.6.5/x86_64-linux-ghc-8.6.5/unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid
post-installation fixup
shrinking RPATHs of ELF executables and libraries in /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0
strip is /nix/store/a57856fs4m8ir6vlv14h3gq3sv9aq2lb-binutils-2.31.1/bin/strip
stripping (with command strip and flags -S) in /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/lib
patching script interpreter paths in /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0
checking for references to /build/ in /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0...
building '/nix/store/cj5kmb6p0pimfbraafzz41hm8kka7krf-lucid-2.9.12.drv'...
setupCompilerEnvironmentPhase
Build with /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary.
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
unpacking sources
unpacking source archive /nix/store/an0p2mp04hs60kln73wv54scrq0rm54s-lucid-2.9.12.tar.gz
source root is lucid-2.9.12
setting SOURCE_DATE_EPOCH to timestamp 1572783682 of file lucid-2.9.12/lucid.cabal
patching sources
Replace Cabal file with edited version from mirror://hackage/lucid-2.9.12/revision/1.cabal.
compileBuildDriverPhase
setupCompileFlags: -package-db=/build/setup-package.conf.d -j8 +RTS -A64M -RTS -threaded -rtsopts
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
[1 of 1] Compiling Main ( Setup.hs, /build/Main.o )
Linking Setup ...
configuring
configureFlags: --verbose --prefix=/nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12 --libdir=$prefix/lib/$compiler --libsubdir=$abi/$libname --with-gcc=gcc --package-db=/build/package.conf.d --ghc-options=-j8 +RTS -A64M -RTS --disable-split-objs --disable-library-profiling --disable-profiling --disable-shared --disable-coverage --enable-static --disable-executable-dynamic --disable-tests --disable-benchmarks --enable-library-vanilla --disable-library-for-ghci --ghc-option=-split-sections
Using Parsec parser
Configuring lucid-2.9.12...
Dependency base >=4.8 && <4.15: using base-4.12.0.0
Dependency blaze-builder >=0.4.0.0: using blaze-builder-0.4.1.0
Dependency bytestring >=0.10.6.0: using bytestring-0.10.8.2
Dependency containers >=0.5.6.2: using containers-0.6.0.1
Dependency hashable >=1.2.3.2: using hashable-1.3.0.0
Dependency mmorph >=1.0.3: using mmorph-1.1.3
Dependency mtl >=2.2: using mtl-2.2.2
Dependency text >=1.2.0.2: using text-1.2.3.1
Dependency transformers >=0.4.2.0: using transformers-0.5.6.2
Dependency unordered-containers >=0.2.5.1: using unordered-containers-0.2.10.0
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
Source component graph: component lib
Configured component graph:
component lucid-2.9.12-Fq6nuzGRbgl2i4FuikeBp9
include base-4.12.0.0
include blaze-builder-0.4.1.0-KrFxFv3kgua3BTNMsMBadC
include bytestring-0.10.8.2
include containers-0.6.0.1
include hashable-1.3.0.0-LeQnUwunJyKHYytZJVGuTk
include mmorph-1.1.3-FfwptCv2VaAjI2vq7vsWW
include mtl-2.2.2
include text-1.2.3.1
include transformers-0.5.6.2
include unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid
Linked component graph:
unit lucid-2.9.12-Fq6nuzGRbgl2i4FuikeBp9
include base-4.12.0.0
include blaze-builder-0.4.1.0-KrFxFv3kgua3BTNMsMBadC
include bytestring-0.10.8.2
include containers-0.6.0.1
include hashable-1.3.0.0-LeQnUwunJyKHYytZJVGuTk
include mmorph-1.1.3-FfwptCv2VaAjI2vq7vsWW
include mtl-2.2.2
include text-1.2.3.1
include transformers-0.5.6.2
include unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid
Lucid=lucid-2.9.12-Fq6nuzGRbgl2i4FuikeBp9:Lucid,Lucid.Base=lucid-2.9.12-Fq6nuzGRbgl2i4FuikeBp9:Lucid.Base,Lucid.Bootstrap=lucid-2.9.12-Fq6nuzGRbgl2i4FuikeBp9:Lucid.Bootstrap,Lucid.Html5=lucid-2.9.12-Fq6nuzGRbgl2i4FuikeBp9:Lucid.Html5
Ready component graph:
definite lucid-2.9.12-Fq6nuzGRbgl2i4FuikeBp9
depends base-4.12.0.0
depends blaze-builder-0.4.1.0-KrFxFv3kgua3BTNMsMBadC
depends bytestring-0.10.8.2
depends containers-0.6.0.1
depends hashable-1.3.0.0-LeQnUwunJyKHYytZJVGuTk
depends mmorph-1.1.3-FfwptCv2VaAjI2vq7vsWW
depends mtl-2.2.2
depends text-1.2.3.1
depends transformers-0.5.6.2
depends unordered-containers-0.2.10.0-586H6DJgI9B8G4cMp2yOid
Using Cabal-2.4.0.1 compiled by ghc-8.6
Using compiler: ghc-8.6.5
Using install prefix: /nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12
Executables installed in:
/nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/bin
Libraries installed in:
/nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/lib/ghc-8.6.5/x86_64-linux-ghc-8.6.5/lucid-2.9.12-Fq6nuzGRbgl2i4FuikeBp9
Dynamic Libraries installed in:
/nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/lib/ghc-8.6.5/x86_64-linux-ghc-8.6.5
Private executables installed in:
/nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/libexec/x86_64-linux-ghc-8.6.5/lucid-2.9.12
Data files installed in:
/nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/share/x86_64-linux-ghc-8.6.5/lucid-2.9.12
Documentation installed in:
/nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/share/doc/x86_64-linux-ghc-8.6.5/lucid-2.9.12
Configuration files installed in:
/nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/etc
No alex found
Using ar found on system at:
/nix/store/a57856fs4m8ir6vlv14h3gq3sv9aq2lb-binutils-2.31.1/bin/ar
No c2hs found
No cpphs found
No doctest found
Using gcc version 9.3.0 given by user at:
/nix/store/2ddwl0cyff2cd4dkb2nqf1xich7halj0-gcc-wrapper-9.3.0/bin/gcc
Using ghc version 8.6.5 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/ghc
Using ghc-pkg version 8.6.5 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/ghc-pkg
No ghcjs found
No ghcjs-pkg found
No greencard found
Using haddock version 2.22.0 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/haddock
No happy found
Using haskell-suite found on system at: haskell-suite-dummy-location
Using haskell-suite-pkg found on system at: haskell-suite-pkg-dummy-location
No hmake found
Using hpc version 0.67 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/hpc
Using hsc2hs version 0.68.5 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/hsc2hs
Using hscolour version 1.24 found on system at:
/nix/store/1bifrw9qxidhxsjwc1ywflb60s92m0dc-hscolour-1.24.4/bin/HsColour
No jhc found
Using ld found on system at:
/nix/store/2ddwl0cyff2cd4dkb2nqf1xich7halj0-gcc-wrapper-9.3.0/bin/ld
No pkg-config found
Using runghc version 8.6.5 found on system at:
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/bin/runghc
Using strip version 2.31 found on system at:
/nix/store/a57856fs4m8ir6vlv14h3gq3sv9aq2lb-binutils-2.31.1/bin/strip
Using tar found on system at:
/nix/store/kvdl1dd9q9mdwp2gipyvwrs16i4w75lq-gnutar-1.32/bin/tar
No uhc found
building
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
Preprocessing library for lucid-2.9.12..
Building library for lucid-2.9.12..
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
[1 of 4] Compiling Lucid.Base ( src/Lucid/Base.hs, dist/build/Lucid/Base.o )
[2 of 4] Compiling Lucid.Html5 ( src/Lucid/Html5.hs, dist/build/Lucid/Html5.o )
src/Lucid/Html5.hs:11:1: warning: [-Wunused-imports]
The import of ‘Data.Monoid’ is redundant
except perhaps to import instances from ‘Data.Monoid’
To import instances alone, use: import Data.Monoid()
|
11 | import Data.Monoid
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
[3 of 4] Compiling Lucid.Bootstrap ( src/Lucid/Bootstrap.hs, dist/build/Lucid/Bootstrap.o )
[4 of 4] Compiling Lucid ( src/Lucid.hs, dist/build/Lucid.o )
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../haskeline-0.7.4.3/libHShaskeline-0.7.4.3-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../ghc-8.6.5/libHSghc-8.6.5-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg)
/nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/ghc-pkg: /nix/store/apm48xz7rsqm6svaar28yrrpgna9ry7v-ncurses-6.2-abi5-compat/lib/libtinfo.so.5: no version information available (required by /nix/store/4v62x62wr4h225p9y8mqpzrw86i33sj6-ghc-8.6.5-binary/lib/ghc-8.6.5/bin/../terminfo-0.4.1.2/libHSterminfo-0.4.1.2-ghc8.6.5.so)
haddockPhase
installing
Installing library in /nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/lib/ghc-8.6.5/x86_64-linux-ghc-8.6.5/lucid-2.9.12-Fq6nuzGRbgl2i4FuikeBp9
post-installation fixup
shrinking RPATHs of ELF executables and libraries in /nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12
strip is /nix/store/a57856fs4m8ir6vlv14h3gq3sv9aq2lb-binutils-2.31.1/bin/strip
stripping (with command strip and flags -S) in /nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/lib
patching script interpreter paths in /nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12
checking for references to /build/ in /nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12...
building '/nix/store/s0fz0p9i4hgf6zcbm5yk2gjzmljp4ji2-ghc-8.6.5-binary-with-packages.drv'...
/nix/store/18k7khc7w8qci05cwlsbl6xzyz824zvm-transformers-compat-0.6.5/nix-support:
propagated-build-inputs: /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/nix-support/propagated-build-inputs
/nix/store/nszfn1l5i2rdia95hg8mbxm3j9vl7nb5-mmorph-1.1.3/nix-support:
propagated-build-inputs: /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/nix-support/propagated-build-inputs
/nix/store/cigk9nissplwzyz08c4zczwd0jb1zyck-hashable-1.3.0.0/nix-support:
propagated-build-inputs: /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/nix-support/propagated-build-inputs
/nix/store/zf3dzn9m62pjv7b48w7lxcc8j7bnzbk0-blaze-builder-0.4.1.0/nix-support:
propagated-build-inputs: /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/nix-support/propagated-build-inputs
/nix/store/fx28xmcif44dx268qw05jhrr79wimgw9-lucid-2.9.12/nix-support:
propagated-build-inputs: /nix/store/l57j6a436p81jdsjq2af8hc22adjngwz-unordered-containers-0.2.10.0/nix-support/propagated-build-inputs
rm: cannot remove '/nix/store/h8dsam2gq8g8bd98yhar3y490wkldvcq-ghc-8.6.5-binary-with-packages/lib/ghc-8.6.5-binary/package.conf.d/package.cache.lock': No such file or directory
builder for '/nix/store/s0fz0p9i4hgf6zcbm5yk2gjzmljp4ji2-ghc-8.6.5-binary-with-packages.drv' failed with exit code 1
error: build of '/nix/store/s0fz0p9i4hgf6zcbm5yk2gjzmljp4ji2-ghc-8.6.5-binary-with-packages.drv' failed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment