Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
sys-libs/ncurses-6.1-r3:0/6::gentoo[+tinfo] breaks system if tinfo is removed after on system that didn't have +tinfo before.

On Bedrock Linux Gentoo strata breaks sys-libs/ncurses-6.1-r3:0/6::gentoo[-tinfo] system when sys-libs/ncurses-6.1-r3:0/6::gentoo[+tinfo] and sys-libs/ncurses-6.1-r3:0/6::gentoo[-tinfo] is merged.

results in:

/bin/sh: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directory
Failed to validate a sane '/dev'.
bash process substitution doesn't work; this may be an indication of a broken '/dev/fd'.

System didn't have ncurses with tinfo before, was installed as part of games-util/steam-launcher::steam-overlay[-steamruntime].

emerge --info = http://ix.io/1FNN

HOTFIX:

To fix libtinfo.so.6 has to be exported manually in /ust/[lib64,lib32]/libtinfo.so.6. sys-libs/ncurses-6.1-r3:0/6::gentoo[-tinfo] should then be merged and manuall export of libtinfo.so.6 removed.

STEPS TO REPRODUCE

on sys-libs/ncurses-6.1-r3:0/6::gentoo[-tinfo] merge sys-libs/ncurses-6.1-r3:0/6::gentoo[+tinfo] followed by sys-libs/ncurses-6.1-r3:0/6::gentoo[-tinfo].

CONCLUSION:

Looks like Gentoo issue where sys-libs/ncurses is missing warning about removing tinfo useflag.

Excluded bedrock issue

<paradigm> kreyren: At the moment I don't see any way it would be.  Bedrock does not make libraries work across strata; each sees its own.  If the issue occurs without `strat`, but does not occur with `strat -r`, it's probably a Bedrock issue in some way I'm currently missing.  Otherwise, I would guess it's not a Bedrock issue.
<kreyren> was present with `strat -r`, `strat -r debian` worked no issue.
...
<paradigm> You're certainly welcome to mention that while not impossible, it seems unlikely it is a Bedrock issue

strat -r is used as equvivalent of chroot /mnt/gentoo <command>. Bedrock Linux is using strata to sandbox other distros.

paradigm is maintainer of Bedrock Linux.

@sanitariu

This comment has been minimized.

Copy link

sanitariu commented Sep 20, 2019

Any manual fixes for that bug ?

@Kreyren

This comment has been minimized.

Copy link
Owner Author

Kreyren commented Sep 20, 2019

@sanitariu

Looks like Gentoo issue where sys-libs/ncurses is missing warning about removing tinfo useflag.

Referencing https://bugs.gentoo.org/457530

If you need more assistance then elaborate on the issue or contact kreyren on freenode.net or Krey#6178 or join https://discord.gg/3Fz6EP on discord assuming that not removing tinfo useflag should be sufficient fix.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.