Skip to content

Instantly share code, notes, and snippets.

🎯
Focusing

Mrityunjai Kumar MrityunjaiKumar

🎯
Focusing
Block or report user

Report or block MrityunjaiKumar

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
@MrityunjaiKumar
MrityunjaiKumar / otaWebserver.ino
Created Jan 12, 2019
esp8266 ota web server page
View otaWebserver.ino
/*
To upload through terminal you can use: curl -F "image=@firmware.bin" esp8266-webupdate.local/update
*/
#include <ESP8266WiFi.h>
#include <WiFiClient.h>
#include <ESP8266WebServer.h>
#include <ESP8266mDNS.h>
#ifndef STASSID
View gist:f3f72b0658b26eb7eb01774371648c2e
sudo apt-get install -y samba samba-common python-glade2 system-config-samba
whereis samba
sudo cp -pf /etc/samba/smb.conf /etc/samba/smb.conf.bak
[sambashare]
path = /samba/sambashare
browsable = yes
writable = yes
View cfg
/*
* Copyright (c) 2015-2017, Texas Instruments Incorporated
* All rights reserved.
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions
* are met:
*
* * Redistributions of source code must retain the above copyright
* notice, this list of conditions and the following disclaimer.
View websrapping.py
###cpcb.py ===> its library, save this as cpcb.py
#!/usr/bin/env python
'''
Copyright 2017 Mrityunjai Kumar
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
View Kali printer
lpadmin
sudo usermod -a -G lpadmin DXer
apt-get install cups cups-client hplip
View Bonescript_bbb.sh
sudo apt-get install -y build-essential g++ curl libssl-dev apache2-utils git libxml2-dev
wget http://nodejs.org/dist/v0.10.21/node-v0.10.21.tar.gz
tar -xf node*
./configure
make
sudo make install
node -v
npm list -g
git clone https://github.com/jadonk/bonescript.git
View cuda_kera_Nvidia_setup.sh
apt-get update
apt-get dist-upgrade
apt-get install -y linux-headers-$(uname -r)
#get Nvidia driver
http://us.download.nvidia.com/XFree86/Linux-x86_64/375.39/NVIDIA-Linux-x86_64-375.39.run
###Error
Installing the NVIDIA display driver...
Error: unsupported compiler: 6.3.0. Use --override to override this check.
@MrityunjaiKumar
MrityunjaiKumar / cuda_gcc_g++.txt
Last active Mar 20, 2017
Installing cuda 8.0 toolkit error resolution, Kali
View cuda_gcc_g++.txt
new version of gcc 6 and Cuda 8 are incompatibile
It fails when we are trying to do the #python setup.py build/install with the following error:
ERROR: No supported gcc/g++ host compiler found, but clang-3.8 is available.
Use ‘nvcc -ccbin clang-3.8’ to use that instead.
Traceback (most recent call last):
*************************************************
Example:-
View zsh_install.sh
Prereq:
apt-get install zsh
apt-get install git-core
Getting zsh to work in ubuntu is weird, since sh does not understand the source command. So, you do this to install zsh
wget https://github.com/robbyrussell/oh-my-zsh/raw/master/tools/install.sh -O - | zsh
and then you change your shell to zsh
chsh -s `which zsh`
curl -L http://install.ohmyz.sh > install.sh
sh install.sh
You can’t perform that action at this time.