Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
with this modification we could still build groovy with java 5/6 and add the nio support (https://github.com/groovy/groovy-core/pull/260)
def subprojects = ['groovy-ant',
'groovy-bsf',
'groovy-console',
'groovy-docgenerator',
'groovy-groovydoc',
'groovy-groovysh',
'groovy-jmx',
'groovy-json',
'groovy-jsr223',
'groovy-servlet',
'groovy-sql',
'groovy-swing',
'groovy-templates',
'groovy-test',
'groovy-testng',
'groovy-xml']
if(!System.properties['java.version'].contains('1.5') && !System.properties['java.version'].contains('1.6')) {
subprojects << 'groovy-nio'
}
include(subprojects as String[])
rootProject.children.each { prj ->
prj.projectDir = new File("$rootDir/subprojects/$prj.name")
}
rootProject.name = 'groovy' // TODO should this be groovy-core?
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment