Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Error install puppet
Selecting previously unselected package pe-ruby-shadow.
Unpacking pe-ruby-shadow (from .../pe-ruby-shadow_2.2.0-1puppet3_amd64.deb) ...
Selecting previously unselected package pe-puppet.
Unpacking pe-puppet (from .../pe-puppet_3.2.4.pe1-1puppet1_all.deb) ...
Selecting previously unselected package pe-rubygem-guid.
Unpacking pe-rubygem-guid (from .../pe-rubygem-guid_0.1.1-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-builder.
Unpacking pe-rubygem-builder (from .../pe-rubygem-builder_3.0.0-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-excon.
Unpacking pe-rubygem-excon (from .../pe-rubygem-excon_0.14.1-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-formatador.
Unpacking pe-rubygem-formatador (from .../pe-rubygem-formatador_0.2.0-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-mime-types.
Unpacking pe-rubygem-mime-types (from .../pe-rubygem-mime-types_1.16-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-multi-json.
Unpacking pe-rubygem-multi-json (from .../pe-rubygem-multi-json_1.0.3-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-net-ssh.
Unpacking pe-rubygem-net-ssh (from .../pe-rubygem-net-ssh_2.1.4-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-net-scp.
Unpacking pe-rubygem-net-scp (from .../pe-rubygem-net-scp_1.0.4-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-nokogiri.
Unpacking pe-rubygem-nokogiri (from .../pe-rubygem-nokogiri_1.5.0-1puppet4_amd64.deb) ...
Selecting previously unselected package pe-rubygem-ruby-hmac.
Unpacking pe-rubygem-ruby-hmac (from .../pe-rubygem-ruby-hmac_0.4.0-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-fog.
Unpacking pe-rubygem-fog (from .../pe-rubygem-fog_1.5.0-1puppet3_all.deb) ...
Selecting previously unselected package pe-rubygem-rbvmomi.
Unpacking pe-rubygem-rbvmomi (from .../pe-rubygem-rbvmomi_1.3.0-1puppet2_all.deb) ...
Selecting previously unselected package pe-rubygem-trollop.
Unpacking pe-rubygem-trollop (from .../pe-rubygem-trollop_1.16.2-1puppet2_all.deb) ...
Selecting previously unselected package pe-cloud-provisioner.
Unpacking pe-cloud-provisioner (from .../pe-cloud-provisioner_1.0.10-puppet1_all.deb) ...
Selecting previously unselected package pe-console-auth.
Unpacking pe-console-auth (from .../pe-console-auth_1.2.15-1puppet1_all.deb) ...
Selecting previously unselected package pe-httpd.
Unpacking pe-httpd (from .../pe-httpd_2.2.25-1puppet1_amd64.deb) ...
Selecting previously unselected package pe-libevent.
Unpacking pe-libevent (from .../pe-libevent_2.0.13-1puppet3_amd64.deb) ...
Selecting previously unselected package pe-memcached.
Unpacking pe-memcached (from .../pe-memcached_1.4.7-1puppet4_amd64.deb) ...
Selecting previously unselected package pe-live-management.
Unpacking pe-live-management (from .../pe-live-management_1.2.13-1puppet1_all.deb) ...
Selecting previously unselected package pe-ruby-stomp.
Unpacking pe-ruby-stomp (from .../pe-ruby-stomp_1.2.9-1puppet2_all.deb) ...
Selecting previously unselected package pe-mcollective-common.
Unpacking pe-mcollective-common (from .../pe-mcollective-common_2.2.4-1puppet2_all.deb) ...
Selecting previously unselected package pe-mcollective.
Unpacking pe-mcollective (from .../pe-mcollective_2.2.4-1puppet2_all.deb) ...
Selecting previously unselected package pe-mcollective-client.
Unpacking pe-mcollective-client (from .../pe-mcollective-client_2.2.4-1puppet2_all.deb) ...
Selecting previously unselected package pe-postgresql-server.
Unpacking pe-postgresql-server (from .../pe-postgresql-server_9.2.4-2puppet5_amd64.deb) ...
Selecting previously unselected package pe-puppet-server.
Unpacking pe-puppet-server (from .../pe-puppet-server_3.2.4.pe1-1puppet1_all.deb) ...
Selecting previously unselected package pe-ruby-augeas.
Unpacking pe-ruby-augeas (from .../pe-ruby-augeas_0.5.0-1puppet2_amd64.deb) ...
Selecting previously unselected package pe-ruby-ldap.
Unpacking pe-ruby-ldap (from .../pe-ruby-ldap_0.9.12-1puppet2_amd64.deb) ...
Selecting previously unselected package pe-rubycas-server.
Unpacking pe-rubycas-server (from .../pe-rubycas-server_1.1.10-1puppet1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for doc-base ...
Processing 1 added doc-base file...
Processing triggers for ureadahead ...
Processing triggers for ufw ...
Setting up pe-puppet-enterprise-release (3.0.1-1puppet1) ...
Setting up pe-postgresql (9.2.4-2puppet5) ...
Setting up pe-libyaml (0.1.4-1puppet2) ...
Setting up pe-ruby (1.9.3.448-1puppet1) ...
Setting up pe-rubygem-rack (1.4.5-1puppet2) ...
Setting up pe-httpd-bin (2.2.25-1puppet1) ...
Setting up pe-httpd-utils (2.2.25-1puppet1) ...
Setting up pe-httpd-common (2.2.25-1puppet1) ...
Enabling module alias.
Enabling module autoindex.
Enabling module dir.
Enabling module env.
Enabling module mime.
Enabling module negotiation.
Enabling module setenvif.
Enabling module status.
Enabling module auth_basic.
Enabling module deflate.
Enabling module ssl.
Enabling module headers.
Enabling module authz_default.
Enabling module authz_user.
Enabling module authz_groupfile.
Enabling module authn_file.
Enabling module authz_host.
Enabling module reqtimeout.
Setting up pe-httpd-mpm-worker (2.2.25-1puppet1) ...
Setting up pe-passenger (4.0.10-1puppet5) ...
Setting up pe-bundler (1.3.5-1puppet2) ...
Setting up pe-puppet-dashboard (2.0.1.pe-1puppet1) ...
* Starting PE Puppet Dashboard Workers [ OK ]
Setting up pe-java (1.7.0.19-1puppet1) ...
Setting up pe-tanukiwrapper (3.5.9-1puppet5) ...
Setting up pe-activemq (5.8.0-1puppet5) ...
Setting up pe-augeas (1.0.0-1puppet4) ...
Setting up pe-console (0.3.8-1puppet1) ...
Setting up pe-certificate-manager (0.4.6-1puppet1) ...
Setting up pe-facter (1.7.1-1puppet2) ...
Setting up pe-rubygem-deep-merge (1.0.0-1puppet1) ...
Setting up pe-hiera (1.2.1-1puppet4) ...
Setting up pe-ruby-rgen (0.6.2-1puppet1) ...
Setting up pe-ruby-shadow (2.2.0-1puppet3) ...
Setting up pe-puppet (3.2.4.pe1-1puppet1) ...
adduser: Warning: The home directory `/var/opt/lib/pe-puppet' does not belong to the user you are currently creating.
* Starting PE puppet agent
puppet not configured to start, please edit /etc/default/pe-puppet to enable
[ OK ]
Setting up pe-rubygem-guid (0.1.1-1puppet2) ...
Setting up pe-rubygem-builder (3.0.0-1puppet2) ...
Setting up pe-rubygem-excon (0.14.1-1puppet2) ...
Setting up pe-rubygem-formatador (0.2.0-1puppet2) ...
Setting up pe-rubygem-mime-types (1.16-1puppet2) ...
Setting up pe-rubygem-multi-json (1.0.3-1puppet2) ...
Setting up pe-rubygem-net-ssh (2.1.4-1puppet2) ...
Setting up pe-rubygem-net-scp (1.0.4-1puppet2) ...
Setting up pe-rubygem-nokogiri (1.5.0-1puppet4) ...
Setting up pe-rubygem-ruby-hmac (0.4.0-1puppet2) ...
Setting up pe-rubygem-fog (1.5.0-1puppet3) ...
Setting up pe-rubygem-rbvmomi (1.3.0-1puppet2) ...
Setting up pe-rubygem-trollop (1.16.2-1puppet2) ...
Setting up pe-cloud-provisioner (1.0.10-puppet1) ...
Setting up pe-console-auth (1.2.15-1puppet1) ...
Setting up pe-httpd (2.2.25-1puppet1) ...
Setting up pe-libevent (2.0.13-1puppet3) ...
Setting up pe-memcached (1.4.7-1puppet4) ...
* Starting pe-memcached: * pe-memcached started
Setting up pe-live-management (1.2.13-1puppet1) ...
Setting up pe-ruby-stomp (1.2.9-1puppet2) ...
Setting up pe-mcollective-common (2.2.4-1puppet2) ...
Setting up pe-mcollective (2.2.4-1puppet2) ...
* Starting Puppet Enterprise MCollective daemon mcollectived... * started
Setting up pe-mcollective-client (2.2.4-1puppet2) ...
Setting up pe-postgresql-server (9.2.4-2puppet5) ...
Setting up pe-puppet-server (3.2.4.pe1-1puppet1) ...
Setting up pe-ruby-augeas (0.5.0-1puppet2) ...
Setting up pe-ruby-ldap (0.9.12-1puppet2) ...
Setting up pe-rubycas-server (1.1.10-1puppet1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
** rm -f /etc/apt/sources.list.d/puppet-enterprise-installer.list
** rm -f /etc/apt/sources.list.d/puppet-enterprise-installer.list
** apt-get update -qq
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/puppet.conf.erb' > '/etc/puppetlabs/puppet/puppet.conf'
## Preserving existing auth.conf
## Setting up puppet master...
** mkdir -p /var/opt/lib/pe-puppetmaster/public/ /var/opt/lib/pe-puppetmaster/public/tmp /var/opt/lib/pe-puppet
** chown -R pe-puppet:pe-puppet /var/opt/lib/pe-puppet /var/log/pe-puppet/
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/puppetmaster.conf.erb' > '/etc/puppetlabs/httpd/conf.d/puppetmaster.conf'
** /opt/puppet/bin/puppet cert --generate ubuntu.maplenic.com --dns_alt_names 'puppet,puppet.maplenic.com,ubuntu,ubuntu.maplenic.com' --verbose --color=false|| true
Info: Creating a new SSL key for ca
Info: Creating a new SSL certificate request for ca
Info: Certificate Request fingerprint (SHA256): 9B:0D:AB:98:DA:E6:51:2E:B4:4F:32:C5:0D:89:CE:B4:38:AB:3D:04:85:5A:4D:18:7E:A9:22:3A:B9:81:B9:25
Notice: Signed certificate request for ca
Notice: Rebuilding inventory file
Notice:
Notice: You have no active and no inactive nodes.
Notice: You are currently licensed for 10 active nodes.
Notice:
Notice: This Puppet Enterprise distribution is licensed to:
Notice: N/A
You are using a complimentary ten node license provided free by Puppet Labs.
Notice:
Notice: Your complimentary license does not include Support & Maintenance. If you
Notice: would like to obtain official Support & Maintenance, please contact us
Notice: for pricing, and to find out about volume discounts.
Info: Creating a new certificate revocation list
Info: Creating a new SSL key for ubuntu.maplenic.com
Info: Creating a new SSL certificate request for ubuntu.maplenic.com
Info: Certificate Request fingerprint (SHA256): 25:0D:D7:5D:38:CF:F9:9F:ED:54:EE:B5:43:35:FE:5E:33:01:99:3A:88:C8:36:39:4F:90:2C:AD:96:24:4B:E2
Notice: ubuntu.maplenic.com has a waiting certificate request
Notice: Signed certificate request for ubuntu.maplenic.com
Notice: Removing file Puppet::SSL::CertificateRequest ubuntu.maplenic.com at '/etc/puppetlabs/puppet/ssl/ca/requests/ubuntu.maplenic.com.pem'
Notice: Removing file Puppet::SSL::CertificateRequest ubuntu.maplenic.com at '/etc/puppetlabs/puppet/ssl/certificate_requests/ubuntu.maplenic.com.pem'
Notice:
Notice: You have 1 active and no inactive nodes.
Notice: You are currently licensed for 10 active nodes.
Notice:
Notice: This Puppet Enterprise distribution is licensed to:
Notice: N/A
You are using a complimentary ten node license provided free by Puppet Labs.
Notice:
Notice: Your complimentary license does not include Support & Maintenance. If you
Notice: would like to obtain official Support & Maintenance, please contact us
Notice: for pricing, and to find out about volume discounts.
## Generated file "/etc/puppetlabs/httpd/conf.d/headers.conf" with contents:
RequestHeader unset X-Forwarded-For
** mkdir -p '/etc/puppetlabs/puppet-dashboard'
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/external_node.erb' > '/etc/puppetlabs/puppet-dashboard/external_node'
** chmod a+rx /etc/puppetlabs/puppet-dashboard/external_node
** chmod a+rX /etc/puppetlabs/puppet-dashboard
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/site.pp.erb' > '/etc/puppetlabs/puppet/manifests/site.pp'
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/config.ru.erb' > '/var/opt/lib/pe-puppetmaster/config.ru'
** chown -R ${PLATFORM_PUPPET_USER}:${PLATFORM_PUPPET_GROUP} ${PLATFORM_PUPPET_HOME?} /var/opt/lib/pe-puppetmaster/ /var/log/pe-puppet/
** rm -f /etc/puppetlabs/httpd/mods-enabled/pe-httpd-passenger.*
## Checking the agent certificate name detection...
** /opt/puppet/bin/puppet agent --configprint certname --color=false
ubuntu.maplenic.com
** printf "START=true
DAEMON_OPTS=''
" > /etc/default/pe-puppet
** service pe-puppet start
* Starting PE puppet agent
...done.
** update-rc.d pe-puppet defaults 80 20
System start/stop links for /etc/init.d/pe-puppet already exist.
** mkdir -p /opt/puppet/share/puppet/modules/modules.upgrade.backup
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-pe_accounts-2.0.1.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-pe_accounts (v2.0.1)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-pe_mcollective-0.1.13.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-pe_mcollective (v0.1.13)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-stdlib-3.2.0.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-stdlib (v3.2.0)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-request_manager-0.0.9.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-request_manager (v0.0.9)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-auth_conf-0.1.6.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-auth_conf (v0.1.6)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-java_ks-1.1.0.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-java_ks (v1.1.0)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/ripienaar-concat-0.2.0.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── ripienaar-concat (v0.2.0)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-pe_postgresql-0.0.4.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-pe_postgresql (v0.0.4)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-pe_puppetdb-0.0.9.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-pe_puppetdb (v0.0.9)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-postgresql-2.3.0.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-postgresql (v2.3.0)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-puppetdb-1.5.1.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-puppetdb (v1.5.1)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/cprice404-inifile-0.10.3.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── cprice404-inifile (v0.10.3)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-pe_common-0.1.0.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-pe_common (v0.1.0)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-apt-1.1.0.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-apt (v1.1.0)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-firewall-0.3.0.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-firewall (v0.3.0)
** rm -f /usr/local/bin/puppet-module
** /opt/puppet/bin/puppet module install "/home/sharking/Downloads/puppetInstall/modules/puppetlabs-puppet_enterprise-3.0.1.tar.gz" --force --ignore-dependencies --modulepath /opt/puppet/share/puppet/modules
Notice: Preparing to install into /opt/puppet/share/puppet/modules ...
Notice: Installing -- do not interrupt ...
/opt/puppet/share/puppet/modules
└── puppetlabs-puppet_enterprise (v3.0.1)
** rm -f /usr/local/bin/puppet-module
** chown pe-puppet:pe-puppet -R /opt/puppet/share/puppet/modules
## Setting up the database...
Configuring postgresql server...
** mkdir -p /opt/puppet/var/lib/pgsql/9.2
** /opt/puppet/bin/puppet apply --no-report --modulepath /opt/puppet/share/puppet/modules -v --exec "class { pe_postgresql: version => '9.2', config_hash => { listen_addresses => 'localhost', ip_mask_allow_all_users => '0.0.0.0/0' } }"
Info: Loading facts in /opt/puppet/share/puppet/modules/auth_conf/lib/facter/custom_auth_conf.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/concat/lib/facter/concat_basedir.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/facter_dot_d.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/pe_version.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/puppet_vardir.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/root_home.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/pe_puppetdb/lib/facter/puppetdb_server_status.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/pe_common/lib/facter/windows.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/firewall/lib/facter/iptables_persistent_version.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/firewall/lib/facter/iptables_version.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/firewall/lib/facter/ip6tables_version.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/postgresql/lib/facter/postgres_default_version.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/auth_conf/lib/facter/custom_auth_conf.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/concat/lib/facter/concat_basedir.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/facter_dot_d.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/pe_version.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/puppet_vardir.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/root_home.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/pe_puppetdb/lib/facter/puppetdb_server_status.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/pe_common/lib/facter/windows.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/firewall/lib/facter/iptables_persistent_version.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/firewall/lib/facter/iptables_version.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/firewall/lib/facter/ip6tables_version.rb
Info: Loading facts in /opt/puppet/share/puppet/modules/postgresql/lib/facter/postgres_default_version.rb
Info: Applying configuration version '1379374360'
Notice: /Stage[main]/Concat::Setup/File[/var/opt/lib/pe-puppet/concat]/ensure: created
Notice: /Stage[main]/Concat::Setup/File[/var/opt/lib/pe-puppet/concat/bin]/ensure: created
Notice: /Stage[main]/Concat::Setup/File[/var/opt/lib/pe-puppet/concat/bin/concatfragments.sh]/ensure: defined content as '{md5}256169ee61115a6b717b2844d2ea3128'
Notice: /Stage[main]/Postgresql::Initdb/Exec[postgresql_initdb]/returns: executed successfully
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Exec[create_postgresql_conf_path]/returns: executed successfully
Notice: /Stage[main]/Postgresql::Config::Beforeservice/File_line[postgresql.conf#include]/ensure: created
Info: /Stage[main]/Postgresql::Config::Beforeservice/File_line[postgresql.conf#include]: Scheduling refresh of Service[postgresqld]
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf]/ensure: created
Info: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf]: Scheduling refresh of Exec[concat_/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments.concat.out]/ensure: created
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments.concat]/ensure: created
Notice: /Stage[main]/Postgresql::Config::Beforeservice/File_line[postgresql.conf#listen_addresses]/ensure: created
Info: /Stage[main]/Postgresql::Config::Beforeservice/File_line[postgresql.conf#listen_addresses]: Scheduling refresh of Service[postgresqld]
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments]/ensure: created
Info: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments]: Scheduling refresh of Exec[concat_/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[allow access to all users]/Concat::Fragment[pg_hba_rule_allow access to all users]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/100_pg_hba_rule_allow access to all users]/ensure: created
Info: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[allow access to all users]/Concat::Fragment[pg_hba_rule_allow access to all users]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/100_pg_hba_rule_allow access to all users]: Scheduling refresh of Exec[concat_/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[deny access to postgresql user]/Concat::Fragment[pg_hba_rule_deny access to postgresql user]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/003_pg_hba_rule_deny access to postgresql user]/ensure: created
Info: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[deny access to postgresql user]/Concat::Fragment[pg_hba_rule_deny access to postgresql user]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/003_pg_hba_rule_deny access to postgresql user]: Scheduling refresh of Exec[concat_/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[local access to database with same name]/Concat::Fragment[pg_hba_rule_local access to database with same name]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/002_pg_hba_rule_local access to database with same name]/ensure: created
Info: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[local access to database with same name]/Concat::Fragment[pg_hba_rule_local access to database with same name]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/002_pg_hba_rule_local access to database with same name]: Scheduling refresh of Exec[concat_/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[local access as postgres user]/Concat::Fragment[pg_hba_rule_local access as postgres user]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/001_pg_hba_rule_local access as postgres user]/ensure: created
Info: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[local access as postgres user]/Concat::Fragment[pg_hba_rule_local access as postgres user]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/001_pg_hba_rule_local access as postgres user]: Scheduling refresh of Exec[concat_/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[allow access to ipv6 localhost]/Concat::Fragment[pg_hba_rule_allow access to ipv6 localhost]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/101_pg_hba_rule_allow access to ipv6 localhost]/ensure: created
Info: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba_rule[allow access to ipv6 localhost]/Concat::Fragment[pg_hba_rule_allow access to ipv6 localhost]/File[/var/opt/lib/pe-puppet/concat/_opt_puppet_var_lib_pgsql_9.2_data_pg_hba.conf/fragments/101_pg_hba_rule_allow access to ipv6 localhost]: Scheduling refresh of Exec[concat_/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/Exec[concat_/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/returns: executed successfully
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/Exec[concat_/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]: Triggered 'refresh' from 7 events
Info: FileBucket adding {md5}ad775a0c21b24d38f2d15f4ee7b9e1b3
Info: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]: Filebucketed /opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf to puppet with sum ad775a0c21b24d38f2d15f4ee7b9e1b3
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/content: content changed '{md5}ad775a0c21b24d38f2d15f4ee7b9e1b3' to '{md5}1bbb9b0c1974c5b14ac3d3839e926350'
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/owner: owner changed 'pe-postgres' to 'root'
Notice: /Stage[main]/Postgresql::Config::Beforeservice/Postgresql::Pg_hba[main]/Concat[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/File[/opt/puppet/var/lib/pgsql/9.2/data/pg_hba.conf]/mode: mode changed '0600' to '0640'
Info: Postgresql::Pg_hba[main]: Scheduling refresh of Exec[reload_postgresql]
Notice: /Stage[main]/Postgresql::Server/Exec[reload_postgresql]: Triggered 'refresh' from 1 events
Notice: /Stage[main]/Postgresql::Server/Service[postgresqld]/ensure: ensure changed 'stopped' to 'running'
Info: /Stage[main]/Postgresql::Server/Service[postgresqld]: Unscheduling refresh on Service[postgresqld]
Info: Creating state file /var/opt/lib/pe-puppet/state/state.yaml
Notice: Finished catalog run in 17.93 seconds
PostgreSQL server configured.
** mkdir -p /opt/puppet/var/lib/pgsql/9.2/console
** chown pe-postgres:pe-postgres /opt/puppet/var/lib/pgsql/9.2/console
** chmod 700 /opt/puppet/var/lib/pgsql/9.2/console
** mkdir -p /opt/puppet/var/lib/pgsql/9.2/puppetdb
** chown pe-postgres:pe-postgres /opt/puppet/var/lib/pgsql/9.2/puppetdb
** chmod 700 /opt/puppet/var/lib/pgsql/9.2/puppetdb
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/databases.erb' | su - pe-postgres -c /opt/puppet/bin/psql -s /bin/bash
CREATE TABLESPACE
CREATE ROLE
CREATE DATABASE
CREATE ROLE
CREATE DATABASE
CREATE TABLESPACE
CREATE ROLE
CREATE DATABASE
## Setting up the console...
** cp -a /etc/puppetlabs/puppet-dashboard/database.yml /etc/puppetlabs/puppet-dashboard/database.yml.20130917T073308.bak
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/database.yml.erb' > '/etc/puppetlabs/puppet-dashboard/database.yml'
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/settings.yml.erb' > '/etc/puppetlabs/puppet-dashboard/settings.yml'
** cp -a /etc/puppetlabs/console-auth/database.yml /etc/puppetlabs/console-auth/database.yml.20130917T073308.bak
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/console_auth_db_config.yml.erb' > '/etc/puppetlabs/console-auth/database.yml'
** chmod 440 /etc/puppetlabs/console-auth/database.yml
** chown pe-auth:puppet-dashboard /etc/puppetlabs/console-auth/database.yml
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/console_auth_config.yml.erb' > '/etc/puppetlabs/console-auth/config.yml'
** cat '/home/sharking/Downloads/puppetInstall/erb/console_auth_log_config.yml' >> '/etc/puppetlabs/console-auth/config.yml'
** chmod 640 /etc/puppetlabs/console-auth/config.yml
** chown pe-auth:puppet-dashboard /etc/puppetlabs/console-auth/config.yml
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/rubycas_config.yml.erb' > '/etc/puppetlabs/rubycas-server/config.yml'
** chmod 600 /etc/puppetlabs/rubycas-server/config.yml
** chown pe-auth:pe-auth /etc/puppetlabs/rubycas-server/config.yml
** /opt/puppet/bin/erb -T - '/home/sharking/Downloads/puppetInstall/erb/cas_client_config.yml.erb' > '/etc/puppetlabs/console-auth/cas_client_config.yml'
** chmod 640 '/etc/puppetlabs/console-auth/cas_client_config.yml'
** chown pe-auth:puppet-dashboard /etc/puppetlabs/console-auth/cas_client_config.yml
** mkdir -p /var/log/pe-console-auth
** touch /var/log/pe-console-auth/cas.log
** touch /var/log/pe-console-auth/auth.log
** chmod 770 /var/log/pe-console-auth
** chmod 660 /var/log/pe-console-auth/auth.log
** touch /var/log/pe-console-auth/cas_client.log
** chmod 660 /var/log/pe-console-auth/cas_client.log
** chown -R pe-auth:puppet-dashboard /var/log/pe-console-auth
** chown puppet-dashboard:puppet-dashboard /opt/puppet/share/live-management/config.ru
** chown pe-auth:pe-auth /opt/puppet/share/console-auth/config.ru
** chown pe-auth:pe-auth /opt/puppet/share/rubycas-server/config.ru
** service pe-httpd start
* Starting web server pe-httpd
...done.
** chown root:root /var/opt/lib/pe-puppet/lib
** cd /opt/puppet/share/puppet-dashboard; /opt/puppet/bin/bundle exec /opt/puppet/bin/rake -s -f /opt/puppet/share/puppet-dashboard/Rakefile cert:create_key_pair RAILS_ENV=production
** /opt/puppet/bin/passenger-status
Version : 4.0.10
Date : 2013-09-17 07:33:14 +0800
Instance: 11115
----------- General information -----------
Max pool size : 6
Processes : 0
Requests in top-level queue : 0
----------- Application groups -----------
** cd /opt/puppet/share/puppet-dashboard; /opt/puppet/bin/bundle exec /opt/puppet/bin/rake -s -f /opt/puppet/share/puppet-dashboard/Rakefile cert:request RAILS_ENV=production
rake aborted!
Connection refused - connect(2)
Tasks: TOP => cert:request
(See full trace by running task with --trace)
** /opt/puppet/bin/puppet cert --sign pe-internal-dashboard --color=false
Error: Could not find certificate request for pe-internal-dashboard
** cd /opt/puppet/share/puppet-dashboard; /opt/puppet/bin/bundle exec /opt/puppet/bin/rake -s -f /opt/puppet/share/puppet-dashboard/Rakefile cert:retrieve RAILS_ENV=production
rake aborted!
Connection refused - connect(2)
Tasks: TOP => cert:retrieve
(See full trace by running task with --trace)
==========================================================================================================================================================================
There was an error running the installation. Please see the last few lines of output for more info.
The Puppet Enterprise Installer can remove any Puppet Enterprise components and configuration files installed prior to this error.
(Note: this does not include removal of any system packages installed and/or installed remote databases/users.)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.