Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
ROS Kinetic installation on Raspberry Pi Zero/Raspberry Pi Zero W
sudo apt-get update
sudo apt-get install -y build-essential gdebi
mkdir -p ~/tmp
wget https://github.com/nomumu/Kinetic4RPiZero/releases/download/v_2017-10-15/rpi-zerow-kinetic_1.0.0-1_armhf.zip
unzip rpi-zerow-kinetic_1.0.0-1_armhf.zip
sudo gdebi rpi-zerow-kinetic_1.0.0-1_armhf.deb
sudo /opt/ros/kinetic/initialize.sh
@Privilger

This comment has been minimized.

Copy link

@Privilger Privilger commented Sep 1, 2018

Works well on my Raspberry Pi Zero W, thanks!

@ustyui361

This comment has been minimized.

Copy link

@ustyui361 ustyui361 commented Oct 11, 2018

Works very well on Raspberry Pi Zero W, no any dependency problems, thanks!

@JBmiog

This comment has been minimized.

Copy link

@JBmiog JBmiog commented Apr 2, 2019

Works like charm, thanks!

@hyansuper

This comment has been minimized.

Copy link

@hyansuper hyansuper commented Apr 2, 2019

What ROS packages are included?

@HenrickRamalho

This comment has been minimized.

Copy link

@HenrickRamalho HenrickRamalho commented Oct 9, 2019

Hello, I am using Raspberry Pi Zero W, but so far I have not been successful in installing ROS Kinetic, which version of Raspibian did you use? After following the guidelines Roscore went into a strar and restart loop. Thank you!

@nbelanger99

This comment has been minimized.

Copy link

@nbelanger99 nbelanger99 commented Oct 9, 2019

Hi, thanks for your contribution. I've been trying to get up and running on a Zero W1.1, but have had issues with a number of packages missing/wrong version. What OS version were you running to get this working?

@Tiryoh

This comment has been minimized.

Copy link
Owner Author

@Tiryoh Tiryoh commented Oct 10, 2019

Hi, @HenrickRamalho, @nbelanger99,

This script is tested only on Raspberry Pi Zero W 1.1 with Raspbian Stretch.

  • 2017-11-29-raspbian-stretch
  • 2018-04-19-raspbian-stretch

I tested ROS Melodic on Raspbian Buster(the current version) on Raspberry Pi Zero W 1.1/1.3 with this script: https://github.com/Tiryoh/ros_melodic_raspizero

@HenrickRamalho

This comment has been minimized.

Copy link

@HenrickRamalho HenrickRamalho commented Oct 10, 2019

Hi @Tiryoh, thank you very much for your help, I will make the modifications and then tell you if everything went well.

@elgarbe

This comment has been minimized.

Copy link

@elgarbe elgarbe commented Nov 14, 2020

hi, I would like to install raspicam_node to the pi zero, but cloning and catkin_make gives an error on image_transport_pluging. How can I add those package?

@amcleodUNH

This comment has been minimized.

Copy link

@amcleodUNH amcleodUNH commented Dec 10, 2020

Hi Tiryoh, I have an install error:

E: Package 'python-imaging' has no installation candidate
ERROR: the following rosdeps failed to install
apt: command [sudo -H apt-get install -y python-imaging] failed

Any idea where the install stands? Is this recoverable?

@martinkburns

This comment has been minimized.

Copy link

@martinkburns martinkburns commented Feb 21, 2021

Hi Tiryoh, I have an install error:

E: Package 'python-imaging' has no installation candidate
ERROR: the following rosdeps failed to install
apt: command [sudo -H apt-get install -y python-imaging] failed

Any idea where the install stands? Is this recoverable?

@amcleodUNH I ran into this issue as well. My install failed at the last step
sudo /opt/ros/kinetic/initialize.sh
with the same python-imaging error.

In case anyone else runs into this, I fixed it by updating my installed OS in /opt/ros/kinetic/initialize.sh. For me, I was running Raspbian 10 (Buster) so I updated:
...--os=debian:jessie...
to
...--os=debian:buster...

and it worked. Thanks @Tiryoh, I had absolutely no issues otherwise.

@TheProfessorsLab

This comment has been minimized.

Copy link

@TheProfessorsLab TheProfessorsLab commented Mar 25, 2021

I did everything stated above including updating installed OS (@martinkburns) and then i also updated rosdep. but i get this error when i start roscore:
process[rosout-1]: started with pid [1218]
[rosout-1] process has died [pid 1218, exit code 127, cmd /opt/ros/kinetic/lib/r osout/rosout __name:=rosout __log:=/home/pi/.ros/log/8d007224-8db1-11eb-9a00-b82 7ebcbc04a/rosout-1.log].
log file: /home/pi/.ros/log/8d007224-8db1-11eb-9a00-b827ebcbc04a/rosout-1*.log
^C[rosout-1] restarting process
I have a Raspberry PI 0W with Raspbian Lite.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment