Skip to content

Instantly share code, notes, and snippets.

😂
Autistic Bot

Xuanliang Cui Yaoshicn

😂
Autistic Bot
Block or report user

Report or block Yaoshicn

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
View keybase.md

Keybase proof

I hereby claim:

  • I am Yaoshicn on github.
  • I am yaoshi (https://keybase.io/yaoshi) on keybase.
  • I have a public key whose fingerprint is 8638 16A6 AC61 4E6E 0284 A117 C329 1BAC 3990 F8EE

To claim this, I am signing this object:

@Yaoshicn
Yaoshicn / ngrok-selfhosting-setup.md
Created Feb 27, 2017 — forked from lyoshenka/ngrok-selfhosting-setup.md
How to setup Ngrok with a self-signed SSL cert
View ngrok-selfhosting-setup.md

Intro

The plan is to create a pair of executables (ngrok and ngrokd) that are connected with a self-signed SSL cert. Since the client and server executables are paired, you won't be able to use any other ngrok to connect to this ngrokd, and vice versa.

DNS

Add two DNS records: one for the base domain and one for the wildcard domain. For example, if your base domain is domain.com, you'll need a record for that and for *.domain.com.

Different Operating Systems

@Yaoshicn
Yaoshicn / Hash_sum_mismatch.md
Created May 1, 2018
How to solve hash sum mismatch problem on Raspberry Pi.
View Hash_sum_mismatch.md
sudo apt-get clean
sudo rm /var/lib/apt/lists/partial/*
sudo vim /etc/apt/sources.list
deb http://archive.raspbian.org/raspbian stretch main contrib non-free
deb-src http://archive.raspbian.org/raspbian stretch main contrib non-free
@Yaoshicn
Yaoshicn / install-erlang-on-raspberry-pi-3.md
Last active Apr 26, 2019
Install Erlang on Raspberry Pi 3
View install-erlang-on-raspberry-pi-3.md

Dependencies

The libwxbase2.8/libqt5/libgtk2.0-dev could be installed for insurance.

# for erlang
sudo apt-get install fop 
sudo apt-get install libncurses5-dev
sudo apt-get install openjdk-6-jdk
sudo apt-get install unixodbc-dev
sudo apt-get install g++
You can’t perform that action at this time.