public
Created — forked from stepchud/gist:2241056

Installing ruby-debug19 on ruby 1.9.3-p0 on Mac OS X Lion 10.7.2 with Xcode 4.2.1

  • Download Gist
gistfile1.txt
1 2 3 4 5 6 7 8 9 10 11
# assumes 1.9.3-p0 is already installed in RVM (1.9.2) and you are in an empty gemset
 
curl -OL http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem
curl -OL http://rubyforge.org/frs/download.php/75415/ruby-debug-base19-0.11.26.gem
gem install rake
gem install archive-tar-minitar
gem install ruby_core_source
gem install columnize
gem install linecache19-0.5.13.gem -- --with-ruby-include="$rvm_path/src/`rvm tools strings`"
gem install ruby-debug-base19-0.11.26.gem -- --with-ruby-include="$rvm_path/src/`rvm tools strings`"
gem install ruby-debug19 -- --with-ruby-include="$rvm_path/src/`rvm tools strings`"

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.