Skip to content

Instantly share code, notes, and snippets.

Avatar

Anderson Dias andersondias

View GitHub Profile
@andersondias
andersondias / gist:311138
Created Feb 22, 2010
Basics of scope_by_attribute plugin
View gist:311138
module ScopeByAttribute
def self.included(base)
base.send(:extend, ScopeByAttribute::ClassMethods)
end
module ClassMethods
def scope_by_attribute(attribute)
@scoped_attributes ||= []
@scoped_attributes << attribute.to_sym
end
View .vimrc
"Use Vim settings, rather then Vi settings (much better!).
"This must be first, because it changes other options as a side effect.
set nocompatible
"allow backspacing over everything in insert mode
set backspace=indent,eol,start
"store lots of :cmdline history
set history=1000
@andersondias
andersondias / no_store_cache_monkey_patch.rb
Created Jun 30, 2009
This monkey patch intends to solve cache errors on development environment when config.cache_classes = false.
View no_store_cache_monkey_patch.rb
# Authors: Anderson Dias (andersondias.github.com) and João Vitor (joaovitor.github.com)
# This monkey patch intends to solve cache errors on development environment when config.cache_classes = false.
# In order to use it you need to put it into you lib/ folder and
# insert "require File.join(RAILS_ROOT, 'lib', 'no_store_cache_monkey_patch')"
# after the "require File.join(File.dirname(__FILE__), 'boot')" line in config/environment.rb:
module ActiveSupport
module Cache
class NoStore < Store
@andersondias
andersondias / cache_classes_patch.patch
Created Jun 28, 2009
Patch to solve bug when using cache_classes = false in development
View cache_classes_patch.patch
diff --git a/activesupport/lib/active_support/cache.rb b/activesupport/lib/active_support/cache.rb
index e62cec6..336f7c4 100644
--- a/activesupport/lib/active_support/cache.rb
+++ b/activesupport/lib/active_support/cache.rb
@@ -221,3 +221,4 @@ require 'active_support/cache/memory_store'
require 'active_support/cache/drb_store'
require 'active_support/cache/mem_cache_store'
require 'active_support/cache/compressed_mem_cache_store'
+require 'active_support/cache/no_store'
diff --git a/activesupport/lib/active_support/cache/no_store.rb b/activesupport/lib/active_support/cache/no_store.rb
View template.rb
# template.rb
# from Anderson Dias
#====================
# PLUGINS
#====================
# Testing
plugin 'rspec-rails', :git => 'git://github.com/dchelimsky/rspec-rails.git'
plugin 'cucumber', :git => 'git://github.com/aslakhellesoy/cucumber.git'
@andersondias
andersondias / install_rails_env
Created Apr 1, 2009
Script to install Ruby on Rails environment on Ubuntu 8.10
View install_rails_env
# Updating Ubuntu
sudo aptitude update
sudo aptitude --assume-yes dist-upgrade
# Installing vim
sudo aptitude --assume-yes install vim vim-gnome
# Installing dependencies
sudo aptitude --assume-yes install build-essential
You can’t perform that action at this time.