Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
ankita @ Vhagar ~/Codes/MediaWiki/vagrant $ vagrant git-update
==> Updating /srv/jobrunner ...
fatal: ref HEAD is not a symbolic ref
expr: syntax error
Previous HEAD position was 5c927f9... trim() the stderr output too
Switched to branch 'master'
Your branch is up-to-date with 'origin/master'.
Already up-to-date.
==> Updating /srv/parsoid ...
Already up-to-date.
==> Updating /vagrant/mediawiki ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki for branch 'master'
==> Updating /vagrant/mediawiki/extensions/Cite ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki/extensions/Cite for branch 'master'
==> Updating /vagrant/mediawiki/extensions/CodeEditor ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki/extensions/CodeEditor for branch 'master'
==> Updating /vagrant/mediawiki/extensions/ParserFunctions ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki/extensions/ParserFunctions for branch 'master'
==> Updating /vagrant/mediawiki/extensions/Parsoid ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki/extensions/Parsoid for branch 'master'
==> Updating /vagrant/mediawiki/extensions/Scribunto ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki/extensions/Scribunto for branch 'master'
==> Updating /vagrant/mediawiki/extensions/SyntaxHighlight_GeSHi ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki/extensions/SyntaxHighlight_GeSHi for branch 'master'
==> Updating /vagrant/mediawiki/extensions/TemplateData ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki/extensions/TemplateData for branch 'master'
==> Updating /vagrant/mediawiki/extensions/UniversalLanguageSelector ...
Already up-to-date.
==> Updating /vagrant/mediawiki/extensions/VisualEditor ...
From https://gerrit.wikimedia.org/r/p/mediawiki/extensions/VisualEditor
02923f6..4f4ab81 wmf/1.25wmf20 -> origin/wmf/1.25wmf20
Already up-to-date.
==> Updating /vagrant/mediawiki/extensions/WikiEditor ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki/extensions/WikiEditor for branch 'master'
==> Updating /vagrant/mediawiki/skins/Vector ...
error: cannot open .git/FETCH_HEAD: Protocol error
***** GIT PULL failed in /vagrant/mediawiki/skins/Vector for branch 'master'
==> Updating composer dependencies in /vagrant/mediawiki ...
Loading composer repositories with package information
Updating dependencies (including require-dev)
- Removing sebastian/exporter (1.1.0)
[RuntimeException]
Could not delete /vagrant/mediawiki/vendor/sebastian/exporter/.gitignore:
update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [packages1] ... [packagesN]
==> Updating composer dependencies in /vagrant/mediawiki/extensions/Scribunto ...
Loading composer repositories with package information
Updating dependencies (including require-dev)
[RuntimeException]
/vagrant/mediawiki/extensions/Scribunto/vendor does not exist and could not be created.
update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [packages1] ... [packagesN]
==> Updating composer dependencies in /vagrant/mediawiki/extensions/TemplateData ...
Loading composer repositories with package information
Updating dependencies (including require-dev)
[RuntimeException]
/vagrant/mediawiki/extensions/TemplateData/vendor does not exist and could not be created.
update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [packages1] ... [packagesN]
==> Updating composer dependencies in /vagrant/mediawiki/extensions/UniversalLanguageSelector ...
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Generating optimized autoload files
==> Updating composer dependencies in /vagrant/mediawiki/extensions/VisualEditor ...
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Generating optimized autoload files
==> Updating composer dependencies in /vagrant/mediawiki/extensions/WikiEditor ...
Loading composer repositories with package information
Updating dependencies (including require-dev)
[RuntimeException]
/vagrant/mediawiki/extensions/WikiEditor/vendor does not exist and could not be created.
update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [packages1] ... [packagesN]
==> Updating database ...
-----------------------------------------------------------------
wiki
-----------------------------------------------------------------
wiki: #!/usr/bin/env php
wiki: MediaWiki 1.25alpha Updater
wiki:
wiki: Your composer.lock file is up to date with current dependencies!
wiki: DB connection error: Unknown database 'wiki' ()
wiki: Backtrace:
wiki: #0 /vagrant/mediawiki/includes/db/LoadBalancer.php(796): DatabaseBase->reportConnectionError('Unknown error (...')
wiki: #1 /vagrant/mediawiki/includes/db/LoadBalancer.php(506): LoadBalancer->reportConnectionError()
wiki: #2 /vagrant/mediawiki/includes/GlobalFunctions.php(3635): LoadBalancer->getConnection(-2, Array, false)
wiki: #3 /vagrant/mediawiki/maintenance/update.php(140): wfGetDB(-2)
wiki: #4 /vagrant/mediawiki/maintenance/doMaintenance.php(102): UpdateMediaWiki->execute()
wiki: #5 /vagrant/mediawiki/maintenance/update.php(211): require_once('/vagrant/mediaw...')
wiki: #6 /var/www/w/MWScript.php(89): require_once('/vagrant/mediaw...')
wiki: #7 {main}
************* Errors ***********
* GIT PULL failed in /vagrant/mediawiki for branch 'master'
* GIT PULL failed in /vagrant/mediawiki/extensions/Cite for branch 'master'
* GIT PULL failed in /vagrant/mediawiki/extensions/CodeEditor for branch 'master'
* GIT PULL failed in /vagrant/mediawiki/extensions/ParserFunctions for branch 'master'
* GIT PULL failed in /vagrant/mediawiki/extensions/Parsoid for branch 'master'
* GIT PULL failed in /vagrant/mediawiki/extensions/Scribunto for branch 'master'
* GIT PULL failed in /vagrant/mediawiki/extensions/SyntaxHighlight_GeSHi for branch 'master'
* GIT PULL failed in /vagrant/mediawiki/extensions/TemplateData for branch 'master'
* GIT PULL failed in /vagrant/mediawiki/extensions/WikiEditor for branch 'master'
* GIT PULL failed in /vagrant/mediawiki/skins/Vector for branch 'master'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.