Skip to content

Instantly share code, notes, and snippets.

/gist:3554743
Created Aug 31, 2012

Embed
What would you like to do?
apt-get install -f
~
$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
asymptote-doc chromium-inspector cpp-4.3 cpp-4.4 dcraw dkms dnet-common doc-base dvd+rw-tools fonts-comfortaa fonts-gfs-complutum
fonts-inconsolata fonts-junicode fonts-linuxlibertine fonts-oflb-asana-math fuse-utils g++-4.5 gcc-4.4-base gcj-4.6-base gcj-4.6-jre-lib
gir1.2-clutter-gst-1.0 gir1.2-evince-3.0 gir1.2-gst-plugins-base-0.10 gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0 gir1.2-rsvg-2.0 gnome-doc-utils
gnome-sushi-common javascript-common kdebase-apps kdebase-workspace konq-plugins-l10n krita-data lib32asound2 lib32bz2-1.0 lib32ncurses5
lib32tinfo5 lib32v4l-0 lib32z1 libaudiofile0 libavdevice52 libavdevice53 libavfilter1 libavresample0 libbind9-60 libbluray0
libboost-filesystem1.42.0 libboost-filesystem1.46.1 libboost-filesystem1.48.0 libboost-iostreams1.42.0 libboost-iostreams1.46.1
libboost-iostreams1.48.0 libboost-program-options1.42.0 libboost-program-options1.46.1 libboost-program-options1.48.0 libboost-regex1.46.1
libboost-regex1.48.0 libboost-signals1.46.1 libboost-signals1.48.0 libboost-system1.42.0 libboost-system1.46.1 libboost-system1.48.0
libboost-thread1.46.1 libboost-thread1.48.0 libbz2-dev libcamel-1.2-29 libcdio-cdda0 libcdio-paranoia0 libcdio10 libcelt0-0 libcheese-gtk18
libdb4.7 libdbusmenu-glib3 libdjvulibre-dev libdnet libdns69 libdvbpsi6 libebook-1.2-12 libecal-1.2-10 libedataserver-1.2-15 libevent-1.4-2
libexif-dev libfame-0.9-1 libgcj12 libgck0 libgegl-0.1-0 libggi-target-x libggi2 libggiwmh0 libggiwmh0-target-x libgii1 libgii1-target-x libgjs0b
libglew1.5 libglew1.6 libglu1-mesa:i386 libgmime-2.4-2 libgnome-bluetooth7 libgnome-bluetooth8 libgnome-desktop-2-17 libgps19 libgraphicsmagick3
libgraphviz-dev libgtksourceview-3.0-0 libgtksourceview-3.0-common libhunspell-1.2-0 libicu44 libidl-dev libimobiledevice1 libisc62 libisccc60
libisccfg62 libiso9660-7 libjim0debian1 libjs-jquery libjs-jquery-ui libkdcraw20 libkdcraw8 libkdcraw9 libkde4-ruby1.8 libkexiv2-9 libkonq5
libkpathsea5 libkwineffects1abi1 libkwineffects1abi2 libkworkspace4 liblash3 liblcms1-dev liblensfun-data liblensfun0 liblqr-1-0-dev liblwres60
libmagick++3 libmagick++4 libmagickcore3 libmagickcore3-extra libmagickcore4 libmagickcore4-extra libmagickwand3 libmagickwand4 libmarblewidget11
libmarblewidget12 libmatroska3 libmediastreamer0 libmozjs185-1.0 libmozjs2d libmozjs7d libmozjs8d libmozjs9d libmpg123-0:i386 libmusicbrainz4c2a
libncurses5-dev libnl1 libnl2 libnl3 libnm-glib2 libnm-util1 libnotify1 libntfs-3g80 libntfs-3g804 libntfs10 liborbit2-dev libplasma-ruby
libplasma-ruby1.8 libpoppler-glib4 libpoppler-glib6 libpoppler13 libpoppler5 libpostproc51 libqt4-ruby1.8 libqtmultimediakit1 libquvi0
libqzeitgeist0 librecode0 libroar1 librsvg2-dev libscim8c2a libserf-0-0 libsilc-1.1-2 libsilcclient-1.1-3 libsmokephonon3 libsmokeqtscript4-3
libsmokeqttest4-3 libsmokeqtuitools4-3 libsmokesoprano3 libsmpeg0 libsolidcontrol4abi1 libsolidcontrolifaces4abi1 libspnav0 libstdc++6-4.5-dev
libswscale0 libsysfs2 libtextcat-data libtextcat0 libtiff5 libtokyocabinet8 libtracker-client-0.8-0 libtracker-sparql-0.10-0
libtracker-sparql-0.12-0 libtunepimp5 libunique-1.0-0 libv8-3.4.14.21 libv8-3.5.10.24 libv8-3.6.6.14 libv8-3.7.12.22 libwebkit-1.0-2
libwebkit-1.0-common libwebp0 libwine-gecko-1.4 libwine-gecko-unstable libwmf-dev libwnck-common libwnck22 libx264-114 libx264-116 libx264-119
libx264-120 libx264-122 libxalan2-java-gcj libxcb-atom1 libxcb-aux0 libxcb-event1 libxcomposite1:i386 libxcursor1:i386 libxine1 libxine1-bin
libxine1-console libxine1-ffmpeg libxine1-misc-plugins libxine1-plugins libxine1-x libxrandr2:i386 libxres1 libxt-dev libyajl1 libyaml-tiny-perl
linux-headers-3.2.0-1-amd64 linux-headers-3.2.0-1-common linux-headers-3.2.0-2-amd64 linux-headers-3.2.0-2-common linux-kbuild-2.6.32
linux-kbuild-2.6.37 linux-kbuild-2.6.38 linux-kbuild-2.6.39 linux-kbuild-3.0.0 linux-kbuild-3.1 mplayer-skin-blue mtools ntfsprogs
openvpn-blacklist orbit2 otf-freefont pybliographer python-bibtex python-gconf python-gnome2 python-gobject-cairo python-libxml2 python-pyorbit
ruby-phonon ruby-qt4-script ruby-qt4-test ruby-qt4-uitools texlive-fonts-extra texlive-fonts-extra-doc texpower texpower-manual ttf-opensymbol
ufraw-batch wwwconfig-common xli xulrunner-1.9.1 xulrunner-7.0 xulrunner-8.0 xulrunner-9.0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
cpp-4.7 g++-4.7 gcc-4.7 libgfortran3 libgomp1 libitm1 libquadmath0 libstdc++6-4.7-dev
Suggested packages:
gcc-4.7-locales g++-4.7-multilib gcc-4.7-doc libstdc++6-4.7-dbg gcc-4.7-multilib libmudflap0-4.7-dev libgcc1-dbg libgomp1-dbg libitm1-dbg
libquadmath0-dbg libmudflap0-dbg binutils-gold libstdc++6-4.7-doc
The following NEW packages will be installed:
libitm1 libstdc++6-4.7-dev
The following packages will be upgraded:
cpp-4.7 g++-4.7 gcc-4.7 libgfortran3 libgomp1 libquadmath0
6 upgraded, 2 newly installed, 0 to remove and 6 not upgraded.
15 not fully installed or removed.
Need to get 0 B/24.0 MB of archives.
After this operation, 11.4 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Selecting previously unselected package libstdc++6-4.7-dev.
(Reading database ... 305846 files and directories currently installed.)
Unpacking libstdc++6-4.7-dev (from .../libstdc++6-4.7-dev_4.7.1-7_amd64.deb) ...
Selecting previously unselected package libitm1:amd64.
Unpacking libitm1:amd64 (from .../libitm1_4.7.1-7_amd64.deb) ...
dpkg: dependency problems prevent configuration of libgomp1:amd64:
libgomp1:amd64 depends on gcc-4.7-base (= 4.7.1-4); however:
Version of gcc-4.7-base:amd64 on system is 4.7.1-7.
dpkg: error processing libgomp1:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libfftw3-3:amd64:
libfftw3-3:amd64 depends on libgomp1 (>= 4.2.1); however:
Package libgomp1:amd64 is not configured yet.
dpkg: error processing libfftw3-3:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libquadmath0:amd64:
libquadmath0:amd64 depends on gcc-4.7-base (= 4.7.1-4); however:
Version of gcc-4.7-base:amd64 on system is 4.7.1-7.
dpkg: error processing libquadmath0:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgfortran3:amd64:
libgfortran3:amd64 depends on gcc-4.7-base (= 4.7.1-4); however:
Version of gcc-4.7-base:amd64 on system is 4.7.1-7.
libgfortran3:amd64 depends on libquadmath0 (>= 4.6); however:
Package libquadmath0:amd64 is not configured yet.
dpkg: error processing libgfortran3:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmagickcore5:amd64:
libmagickcore5:amd64 depends on libgomp1 (>= 4.2.1); however:
Package libgomp1:amd64 is not configured yet.
dpkg: error processing libmagickcore5:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmagickwand5:amd64:
libmagickwand5:amd64 depends on libgomp1 (>= 4.2.1); however:
Package libgomp1:amd64 is not configured yet.
libmagickwand5:amd64 depends on libmagickcore5 (>= 8:6.7.7.10); however:
Package libmagickcore5:amd64 is not configured yet.
dpkg: error processing libmagickwand5:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmagick++5:amd64:
libmagick++5:amd64 depends on libgomp1 (>= 4.2.1); however:
Package libgomp1:amd64 is not configured yet.
libmagick++5:amd64 depends on libmagickcore5 (>= 8:6.7.7.10); however:
Package libmagickcore5:amd64 is not configured yet.
libmagick++5:amd64 depends on libmagickwand5 (>= 8:6.7.7.10); however:
Package libmagickwand5:amd64 is not configured yet.
dpkg: error processing libmagick++5:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cpp-4.7:
cpp-4.7 depends on gcc-4.7-base (= 4.7.1-4); however:
Version of gcc-4.7-base:amd64 on system is 4.7.1-7.
dpkg: error processing cpp-4.7 (--configure):
dependency problems - leaving unconfigured
Setting up libitm1:amd64 (4.7.1-7) ...
dpkg: dependency problems prevent configuration of gcc-4.7:
gcc-4.7 depends on gcc-4.7-base (= 4.7.1-4); however:
Version of gcc-4.7-base:amd64 on system is 4.7.1-7.
gcc-4.7 depends on cpp-4.7 (= 4.7.1-4); however:
Package cpp-4.7 is not configured yet.
gcc-4.7 depends on libgomp1 (>= 4.7.1-4); however:
Package libgomp1:amd64 is not configured yet.
gcc-4.7 depends on libquadmath0 (>= 4.7.1-4); however:
Package libquadmath0:amd64 is not configured yet.
dpkg: error processing gcc-4.7 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of g++-4.7:
g++-4.7 depends on gcc-4.7-base (= 4.7.1-4); however:
Version of gcc-4.7-base:amd64 on system is 4.7.1-7.
g++-4.7 depends on gcc-4.7 (= 4.7.1-4); however:
Package gcc-4.7 is not configured yet.
g++-4.7 depends on libstdc++6-4.7-dev (= 4.7.1-4); however:
Version of libstdc++6-4.7-dev on system is 4.7.1-7.
dpkg: error processing g++-4.7 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libstdc++6-4.7-dev:
libstdc++6-4.7-dev depends on g++-4.7 (= 4.7.1-7); however:
Version of g++-4.7 on system is 4.7.1-4.
dpkg: error processing libstdc++6-4.7-dev (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gcc-4.6:
gcc-4.6 depends on libgomp1 (>= 4.6.3-9); however:
Package libgomp1:amd64 is not configured yet.
gcc-4.6 depends on libquadmath0 (>= 4.6.3-9); however:
Package libquadmath0:amd64 is not configured yet.
dpkg: error processing gcc-4.6 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgraphicsmagick3:
libgraphicsmagick3 depends on libgomp1 (>= 4.2.1); however:
Package libgomp1:amd64 is not configured yet.
dpkg: error processing libgraphicsmagick3 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of liblapack3:
liblapack3 depends on libgfortran3 (>= 4.6); however:
Package libgfortran3:amd64 is not configured yet.
liblapack3 depends on libquadmath0 (>= 4.6); however:
Package libquadmath0:amd64 is not configured yet.
dpkg: error processing liblapack3 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of liblapack3gf:
liblapack3gf depends on liblapack3; however:
Package liblapack3 is not configured yet.
dpkg: error processing liblapack3gf (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-headers-3.2.0-3-amd64:
linux-headers-3.2.0-3-amd64 depends on gcc-4.6; however:
Package gcc-4.6 is not configured yet.
dpkg: error processing linux-headers-3.2.0-3-amd64 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libgomp1:amd64
libfftw3-3:amd64
libquadmath0:amd64
libgfortran3:amd64
libmagickcore5:amd64
libmagickwand5:amd64
libmagick++5:amd64
cpp-4.7
gcc-4.7
g++-4.7
libstdc++6-4.7-dev
gcc-4.6
libgraphicsmagick3
liblapack3
liblapack3gf
linux-headers-3.2.0-3-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.