Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Submission test log
Ready to upload new build to TestFlight (App: 1029560017)...
[16:59:29]: `Helper.gem_path` is deprecated. Use the `ROOT` constant from the appropriate tool module instead.
[16:59:30]: Going to upload updated app to iTunes Connect
[16:59:30]: This might take a few minutes. Please don't interrupt the script.
[17:00:17]: [Transporter Error Output]: ERROR ITMS-90098: "This bundle is invalid. The key UIRequiredDeviceCapabilities contains value 'watch-companion' which is incompatible with the MinimumOSVersion value of '10.1'." 
[17:00:17]: Transporter transfer failed.
[17:00:17]: 
[17:00:17]: ERROR ITMS-90098: "This bundle is invalid. The key UIRequiredDeviceCapabilities contains value 'watch-companion' which is incompatible with the MinimumOSVersion value of '10.1'." 
[17:00:17]: ERROR ITMS-90098: "This bundle is invalid. The key UIRequiredDeviceCapabilities contains value 'watch-companion' which is incompatible with the MinimumOSVersion value of '10.1'."
Return status of iTunes Transporter was 1: ERROR ITMS-90098: "This bundle is invalid. The key UIRequiredDeviceCapabilities contains value 'watch-companion' which is incompatible with the MinimumOSVersion value of '10.1'."
The call to the iTMSTransporter completed with a non-zero exit status: 1. This indicates a failure.
Error uploading ipa file, more information see above
/usr/local/lib/ruby/gems/2.3.0/gems/submission_runner-0.4.9/lib/submission_runner/projects/project.rb:53:in `upload_ipa'
/usr/local/lib/ruby/gems/2.3.0/gems/submission_runner-0.4.9/lib/submission_runner/submission_manager.rb:77:in `run_submission'
/usr/local/lib/ruby/gems/2.3.0/gems/submission_runner-0.4.9/lib/submission_runner/commands_generator.rb:28:in `block (2 levels) in run'
/usr/local/lib/ruby/gems/2.3.0/gems/commander-4.4.0/lib/commander/command.rb:178:in `call'
/usr/local/lib/ruby/gems/2.3.0/gems/commander-4.4.0/lib/commander/command.rb:153:in `run'
/usr/local/lib/ruby/gems/2.3.0/gems/commander-4.4.0/lib/commander/runner.rb:444:in `run_active_command'
/usr/local/lib/ruby/gems/2.3.0/gems/fastlane_core-0.52.3/lib/fastlane_core/ui/fastlane_runner.rb:38:in `run!'
/usr/local/lib/ruby/gems/2.3.0/gems/commander-4.4.0/lib/commander/delegates.rb:15:in `run!'
/usr/local/lib/ruby/gems/2.3.0/gems/submission_runner-0.4.9/lib/submission_runner/commands_generator.rb:34:in `run'
/usr/local/lib/ruby/gems/2.3.0/gems/submission_runner-0.4.9/bin/submission_runner:6:in `<top (required)>'
/usr/local/bin/submission_runner:23:in `load'
/usr/local/bin/submission_runner:23:in `<main>'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment