Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
conda build r-plotly error
conda build r-plotly/
BUILD START: r-plotly-4.5.6-r3.3.2_0
(actual version deferred until further download or env creation)
updating index in: /usr/local/Anaconda3-4.3.0-Linux-x86_64/conda-bld/linux-64
updating index in: /usr/local/Anaconda3-4.3.0-Linux-x86_64/conda-bld/noarch
The following NEW packages will be INSTALLED:
bzip2: 1.0.6-3
cairo: 1.14.8-0
curl: 7.52.1-0
fontconfig: 2.12.1-3
freetype: 2.5.5-2
glib: 2.50.2-1
gsl: 2.2.1-0
harfbuzz: 0.9.39-2
icu: 54.1-0
jbig: 2.1-0
jpeg: 9b-0
libffi: 3.2.1-1
libgcc: 5.2.0-0
libiconv: 1.14-0
libpng: 1.6.27-0
libtiff: 4.0.6-3
libxml2: 2.9.4-0
ncurses: 5.9-10
openssl: 1.0.2k-1
pango: 1.40.3-1
pcre: 8.39-1
pixman: 0.34.0-0
r-assertthat: 0.1-r3.3.2_4
r-base: 3.3.2-1
r-base64enc: 0.1_3-r3.3.2_0
r-bh: 1.62.0_1-r3.3.2_0
r-colorspace: 1.3_1-r3.3.2_0
r-curl: 2.3-r3.3.2_0
r-dbi: 0.5_1-r3.3.2_0
r-dichromat: 2.0_0-r3.3.2_2
r-digest: 0.6.10-r3.3.2_0
r-dplyr: 0.5.0-r3.3.2_0
r-ggplot2: 2.2.0-r3.3.2_0
r-gtable: 0.2.0-r3.3.2_0
r-hexbin: 1.27.1-r3.3.2_0
r-htmltools: 0.3.5-r3.3.2_0
r-htmlwidgets: 0.8-r3.3.2_0
r-httr: 1.2.1-r3.3.2_0
r-jsonlite: 1.1-r3.3.2_0
r-labeling: 0.3-r3.3.2_2
r-lattice: 0.20_34-r3.3.2_0
r-lazyeval: 0.2.0-r3.3.2_0
r-magrittr: 1.5-r3.3.2_2
r-mass: 7.3_45-r3.3.2_0
r-mime: 0.5-r3.3.2_0
r-munsell: 0.4.3-r3.3.2_0
r-openssl: 0.9.5-r3.3.2_0
r-plyr: 1.8.4-r3.3.2_0
r-purrr: 0.2.2-r3.3.2_0
r-r6: 2.2.0-r3.3.2_0
r-rcolorbrewer: 1.1_2-r3.3.2_3
r-rcpp: 0.12.8-r3.3.2_0
r-reshape2: 1.4.2-r3.3.2_0
r-scales: 0.4.1-r3.3.2_0
r-stringi: 1.1.2-r3.3.2_0
r-stringr: 1.1.0-r3.3.2_0
r-tibble: 1.2-r3.3.2_0
r-tidyr: 0.6.0-r3.3.2_0
r-viridislite: 0.1.3-r3.3.2_0
r-yaml: 2.1.14-r3.3.2_0
readline: 6.2-2
tk: 8.5.18-0
xz: 5.2.2-1
zlib: 1.2.8-3
Source cache directory is: /usr/local/Anaconda3-4.3.0-Linux-x86_64/conda-bld/src_cache
Downloading source to cache: plotly_4.5.6.tar.gz
Downloading https://cran.r-project.org/src/contrib/plotly_4.5.6.tar.gz
Success
Extracting download
BUILD START (revised): r-plotly-4.5.6-r3.3.2_0
Package: r-plotly-4.5.6-r3.3.2_0
source tree in: /usr/local/Anaconda3-4.3.0-Linux-x86_64/conda-bld/r-plotly_1489255513453/work/plotly
+ source /usr/local/Anaconda3-4.3.0-Linux-x86_64/bin/activate /usr/local/Anaconda3-4.3.0-Linux-x86_64/conda-bld/r-plotly_1489255513453/_b_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_place
+ mv DESCRIPTION DESCRIPTION.old
+ grep -v '^Priority: ' DESCRIPTION.old
+ /usr/local/Anaconda3-4.3.0-Linux-x86_64/conda-bld/r-plotly_1489255513453/_b_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_place/bin/R CMD INSTALL --build .
Warning: invalid package ‘.’
Error: ERROR: no packages specified
Traceback (most recent call last):
File "/usr/local/Anaconda3-4.3.0-Linux-x86_64/bin/conda-build", line 6, in <module>
sys.exit(conda_build.cli.main_build.main())
File "/usr/local/Anaconda3-4.3.0-Linux-x86_64/lib/python3.6/site-packages/conda_build/cli/main_build.py", line 322, in main
execute(sys.argv[1:])
File "/usr/local/Anaconda3-4.3.0-Linux-x86_64/lib/python3.6/site-packages/conda_build/cli/main_build.py", line 313, in execute
noverify=args.no_verify)
File "/usr/local/Anaconda3-4.3.0-Linux-x86_64/lib/python3.6/site-packages/conda_build/api.py", line 97, in build
need_source_download=need_source_download, config=config)
File "/usr/local/Anaconda3-4.3.0-Linux-x86_64/lib/python3.6/site-packages/conda_build/build.py", line 1494, in build_tree
config=config)
File "/usr/local/Anaconda3-4.3.0-Linux-x86_64/lib/python3.6/site-packages/conda_build/build.py", line 1129, in build
utils.check_call_env(cmd, env=env, cwd=src_dir)
File "/usr/local/Anaconda3-4.3.0-Linux-x86_64/lib/python3.6/site-packages/conda_build/utils.py", line 620, in check_call_env
return _func_defaulting_env_to_os_environ(subprocess.check_call, *popenargs, **kwargs)
File "/usr/local/Anaconda3-4.3.0-Linux-x86_64/lib/python3.6/site-packages/conda_build/utils.py", line 616, in _func_defaulting_env_to_os_environ
return func(_args, **kwargs)
File "/usr/local/Anaconda3-4.3.0-Linux-x86_64/lib/python3.6/subprocess.py", line 291, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/bin/bash', '-x', '-e', '/usr/local/Anaconda3-4.3.0-Linux-x86_64/conda-bld/r-plotly_1489255513453/work/plotly/conda_build.sh']' returned non-zero exit status 1.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.