Skip to content

Instantly share code, notes, and snippets.

💭
Looking to relocate to the Seattle, WA area!

Brian J King brianjking

💭
Looking to relocate to the Seattle, WA area!
Block or report user

Report or block brianjking

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
View ecp-remove-gen-bc
/*
* Remove Genesis Breadcrumbs from the Event Calendar View Pages
* The Events Calendar @3.8
* Genesis @2.1.2
*/
add_action( 'genesis_before', 'tribe_remove_genesis_breadcrumbs' );
function tribe_remove_genesis_breadcrumbs() {
if( tribe_is_upcoming() || tribe_is_past() || tribe_is_map() || tribe_is_photo() || tribe_is_month() || tribe_is_week() || tribe_is_day() || tribe_is_photo() ) {
remove_action( 'genesis_before_loop', 'genesis_do_breadcrumbs' );
View ecp-genesis-sharing
/**
* The Events Calendar Include Genesis Simple Sharing Above Event Calendar
*
*/
add_filter( 'tribe_events_single_event_before_the_content', 'tribe_genesis_event_share' );
function tribe_genesis_event_share( $post_info ) {
// Return the existing post info for pages or when plugin is not active
if ( is_singular('tribe_events') || function_exists( 'genesis_share_get_icon_output' ) ) {
global $Genesis_Simple_Share;
View ecp-genesis-events-meta
/*
* Genesis Remove Genesis Meta Filter on Event Calendar Pages
* The Events Calendar @3.8
* Genesis @2.1.2
*
*/
add_action( 'genesis_doctype', 'tribe_genesis_meta_title' );
function tribe_genesis_meta_title() {
if( tribe_is_upcoming() || tribe_is_past() || tribe_is_map() || tribe_is_photo() || tribe_is_month() || tribe_is_week() || tribe_is_day() || tribe_is_photo() ) {
View default-template.php
<?php
/**
* Default Events Template for Genesis
* This file is the basic wrapper template for all the views if 'Default Events Template'
* is selected in Events -> Settings -> Template -> Events Template.
*
* @package TribeEventsCalendar
* @since 3.0
* @author Modern Tribe Inc. | Tweaked by Thought Refinery
*
View ecp-genesis-page-width
/*
* Genesis Page Layout of The Event Calendar Main Events Page
* The Events Calendar @3.8
* Genesis @2.1.2
* Options - full-width-content, content-sidebar, sidebar-content, content-sidebar-sidebar, sidebar-sidebar-content, sidebar-content-sidebar
*/
add_filter( 'genesis_site_layout', 'tribe_genesis_page_width' );
function tribe_genesis_page_width() {
if( tribe_is_upcoming() || tribe_is_past() || tribe_is_map() || tribe_is_photo() || tribe_is_month() || tribe_is_week() || tribe_is_day() || tribe_is_photo() ) {
return 'full-width-content';
View gist:5e529779629d80b77a2d
/**
* Forces full width content layout on Tribe events calendar or list view
* Uses $wpquery query_vars to determine template
*
* @param $layout
*
* @return string
*/
function ssm_force_layout($layout){
if(is_admin())
View README.md

Gulp workflow for WordPress theme development

Requirements

In order for Livereload to work, you need a Firefox or Chrome extension as Gulp doesn't inset it automatically. Alternatively, you can also manually put the livereload script in footer.php, just make sure to insert it only on development environment:

<script>document.write('<script src="http://' + (location.host || 'localhost').split(':')[0] + ':35729/livereload.js?snipver=1"></' + 'script>')</script>
View codeable.io.conf
server {
include /home/webmaster/www/codeable.io.conf;
server_name codeable.io;
listen 443 ssl spdy default_server;
root /home/webmaster/www/codeable.io;
index index.php index.html;
error_log /var/log/nginx/codeable.io.error.log warn;
View tcpdf-text-multiple-columns-no-overlaps-example.php
<?php
//============================================================+
// File name : example_010.php
// Begin : 2008-03-04
// Last Update : 2013-05-14
//
// Description : Example 010 for TCPDF class
// Text on multiple columns
//
// Author: Nicola Asuni
View README
This configuration is a working copy which I have tested on Apache 2.2.x and 2.4.x
I highly recommend you use this version of mod_fastcgi as it works with Apache 2.4.x, fastcgi.com version does not!
https://github.com/ByteInternet/libapache-mod-fastcgi
The fastcgi.com version is 2.4.6, the version I am recommending registers as 2.4.7
To patch mod_fastcgi for use with Apache 2.4.x look at the debian/patches folder. It's not specific to Debian OS so don't let that fool you. I personally use Archlinux.
Of course to compile mod_fastcgi:
You can’t perform that action at this time.