Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
$ cabal install cabal-plan --dry -v3
no user package environment file found at
/Users/carter/WorkSpace/projects/active/concat-linear-work
Searching for ghc in path.
Found ghc at /Users/carter/.install-ghc/ghc-8.2.2/bin/ghc
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc --numeric-version
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc is version 8.2.2
looking for tool ghc-pkg near compiler in
/Users/carter/.install-ghc/ghc-8.2.2/bin
candidate locations:
["/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc-pkg","/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc-pkg-ghc-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc-pkg-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc-pkg"]
found ghc-pkg in /Users/carter/.install-ghc/ghc-8.2.2/bin/ghc-pkg
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc-pkg --version
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc-pkg is version 8.2.2
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc --supported-languages
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc --info
Searching for alex in path.
Found alex at /Users/carter/.cabal/bin/alex
/Users/carter/.cabal/bin/alex --version
/Users/carter/.cabal/bin/alex is version 3.2.3
Searching for ar in path.
Found ar at /usr/bin/ar
Searching for c2hs in path.
Found c2hs at /Users/carter/.cabal/bin/c2hs
/Users/carter/.cabal/bin/c2hs --numeric-version
/Users/carter/.cabal/bin/c2hs is version 0.28.1
Searching for cpphs in path.
Found cpphs at /Users/carter/.cabal/bin/cpphs
/Users/carter/.cabal/bin/cpphs --version
/Users/carter/.cabal/bin/cpphs is version 1.20.8
Searching for doctest in path.
Found doctest at /Users/carter/.cabal/bin/doctest
/Users/carter/.cabal/bin/doctest --version
/Users/carter/.cabal/bin/doctest is version 0.11.0
Searching for clang in path.
Found clang at /usr/bin/clang
/usr/bin/clang -dumpversion
/usr/bin/clang is version 4.2.1
Searching for ghcjs in path.
Found ghcjs at /Users/carter/.cabal/bin/ghcjs
/Users/carter/.cabal/bin/ghcjs --numeric-ghcjs-version
/Users/carter/.cabal/bin/ghcjs is version 0.2.1
Searching for ghcjs-pkg in path.
Found ghcjs-pkg at /Users/carter/.cabal/bin/ghcjs-pkg
/Users/carter/.cabal/bin/ghcjs-pkg --version
/Users/carter/.cabal/bin/ghcjs-pkg is version 8.0.2
Searching for greencard in path.
Cannot find greencard on the path
looking for tool haddock near compiler in
/Users/carter/.install-ghc/ghc-8.2.2/bin
candidate locations:
["/Users/carter/.install-ghc/ghc-8.2.2/bin/haddock","/Users/carter/.install-ghc/ghc-8.2.2/bin/haddock-ghc-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/haddock-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/haddock"]
found haddock in /Users/carter/.install-ghc/ghc-8.2.2/bin/haddock
/Users/carter/.install-ghc/ghc-8.2.2/bin/haddock --version
/Users/carter/.install-ghc/ghc-8.2.2/bin/haddock is version 2.18.1
Searching for happy in path.
Found happy at /Users/carter/.cabal/bin/happy
/Users/carter/.cabal/bin/happy --version
/Users/carter/.cabal/bin/happy is version 1.19.7
Searching for hmake in path.
Cannot find hmake on the path
looking for tool hpc near compiler in /Users/carter/.install-ghc/ghc-8.2.2/bin
candidate locations:
["/Users/carter/.install-ghc/ghc-8.2.2/bin/hpc","/Users/carter/.install-ghc/ghc-8.2.2/bin/hpc-ghc-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/hpc-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/hpc"]
found hpc in /Users/carter/.install-ghc/ghc-8.2.2/bin/hpc
/Users/carter/.install-ghc/ghc-8.2.2/bin/hpc version
/Users/carter/.install-ghc/ghc-8.2.2/bin/hpc is version 0.67
looking for tool hsc2hs near compiler in
/Users/carter/.install-ghc/ghc-8.2.2/bin
candidate locations:
["/Users/carter/.install-ghc/ghc-8.2.2/bin/hsc2hs","/Users/carter/.install-ghc/ghc-8.2.2/bin/hsc2hs-ghc-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/hsc2hs-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/hsc2hs"]
found hsc2hs in /Users/carter/.install-ghc/ghc-8.2.2/bin/hsc2hs
/Users/carter/.install-ghc/ghc-8.2.2/bin/hsc2hs --version
/Users/carter/.install-ghc/ghc-8.2.2/bin/hsc2hs is version 0.68.2
Searching for HsColour in path.
Found HsColour at /Users/carter/.cabal/bin/HsColour
/Users/carter/.cabal/bin/HsColour -version
/Users/carter/.cabal/bin/HsColour is version 1.24
Searching for jhc in path.
Cannot find jhc on the path
Searching for ld in path.
Found ld at /usr/bin/ld
Environment: [("Apple_PubSub_Socket_Render","/private/tmp/com.apple.launchd.u66CeZJen6/Render"),("CAML_LD_LIBRARY_PATH","/Users/carter/.opam/system/lib/stublibs\RS/usr/local/lib/ocaml/stublibs"),("CLICOLOR","1;"),("COLORFGBG","11;15"),("COLORTERM","truecolor"),("DISPLAY","/private/tmp/com.apple.launchd.EYOET7JPXl/org.macosforge.xquartz:0"),("EDITOR","subl -w -n"),("GOPATH","/Users/carter/.go"),("GREP_OPTIONS","--color=auto"),("HOME","/Users/carter"),("ITERM_PROFILE","Default"),("ITERM_SESSION_ID","w0t7p0:5FBD0F02-8BC2-46B6-982A-F75B35486B20"),("LANG","en_US.UTF-8"),("LOGNAME","carter"),("NODE_PATH","/usr/local/lib/node_modules\RS/usr/local/lib/node"),("OCAML_TOPLEVEL_PATH","/Users/carter/.opam/system/lib/toplevel"),("OPAMUTF8MSGS","1"),("PATH","/Users/carter/.cabal/bin:/Users/carter/.install-ghc/ghc-8.2.2/bin:/Users/carter/bin:/Users/carter/.scripts:/Users/carter/docTemplates:/Library/TeX/texbin:/Users/carter/.cargo/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/usr/local/MacGPG2/bin:/Library/Frameworks/Mono.framework/Versions/Current/Commands:/Library/TeX/texbin:/Users/carter/.opam/system/bin:/usr/local/sbin:/Users/carter/.cabal/bin"),("PWD","/Users/carter/WorkSpace/projects/active/concat-linear-work"),("PYTHONPATH","/usr/local/share/python\RS/usr/local/lib/python\RS/usr/local/lib/python2.7"),("SHELL","/bin/bash"),("SHLVL","1"),("SSH_AUTH_SOCK","/private/tmp/com.apple.launchd.sO7kAggBUv/Listeners"),("TERM","xterm-256color"),("TERM_PROGRAM","iTerm.app"),("TERM_PROGRAM_VERSION","3.1.6"),("TERM_SESSION_ID","w0t7p0:5FBD0F02-8BC2-46B6-982A-F75B35486B20"),("TMPDIR","/var/folders/py/wgp_hj9d2rl3cx48yym_ynj00000gn/T/"),("USER","carter"),("XPC_FLAGS","0x0"),("XPC_SERVICE_NAME","0"),("__CF_USER_TEXT_ENCODING","0x1F5:0x0:0x0")]
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc -hide-all-packages -c /var/folders/py/wgp_hj9d2rl3cx48yym_ynj00000gn/T/54053-0.c -o /var/folders/py/wgp_hj9d2rl3cx48yym_ynj00000gn/T/54053-1.o
/usr/bin/ld -x -r /var/folders/py/wgp_hj9d2rl3cx48yym_ynj00000gn/T/54053-1.o -o /var/folders/py/wgp_hj9d2rl3cx48yym_ynj00000gn/T/54053-2.o
Searching for lhc in path.
Cannot find lhc on the path
Searching for lhc-pkg in path.
Cannot find lhc-pkg on the path
Searching for pkg-config in path.
Found pkg-config at /usr/local/bin/pkg-config
/usr/local/bin/pkg-config --version
/usr/local/bin/pkg-config is version 0.29.2
looking for tool runghc near compiler in
/Users/carter/.install-ghc/ghc-8.2.2/bin
candidate locations:
["/Users/carter/.install-ghc/ghc-8.2.2/bin/runghc","/Users/carter/.install-ghc/ghc-8.2.2/bin/runghc-ghc-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/runghc-8.2.2","/Users/carter/.install-ghc/ghc-8.2.2/bin/runghc"]
found runghc in /Users/carter/.install-ghc/ghc-8.2.2/bin/runghc
/Users/carter/.install-ghc/ghc-8.2.2/bin/runghc --version
/Users/carter/.install-ghc/ghc-8.2.2/bin/runghc is version 8.2.2
Searching for strip in path.
Found strip at /usr/bin/strip
/usr/bin/strip --version
/usr/bin/strip returned ExitFailure 1 with error message:
error:
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/strip:
unrecognized option: --version
Usage:
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/strip
[-AnuSXx] [-] [-d filename] [-s filename] [-R filename] [-o output] file [...]
Warning: cannot determine version of /usr/bin/strip :
""
Searching for tar in path.
Found tar at /usr/bin/tar
/usr/bin/tar --help
Searching for uhc in path.
Cannot find uhc on the path
Reading installed packages...
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc-pkg dump --global -v0
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc-pkg dump --user -v0
/Users/carter/.install-ghc/ghc-8.2.2/bin/ghc --print-libdir
Reading available packages of hackage.haskell.org...
Using most recent state (could not read timestamp file)
index-state(hackage.haskell.org) =
/usr/local/bin/pkg-config --list-all
/usr/local/bin/pkg-config --modversion system.web.mvc libpcre2-posix apr-1 python3 dotnet35 xbuild12 python-3.6 mono-lineeditor monodoc reactive libpcre2-16 ImageMagick system.web.extensions_1.0 libpng aspnetwebstack 'Magick++-7.Q16HDRI' libtcmalloc libpcreposix libcurl mono-options libevent_extra libgit2 libevent libecpg mono-cairo zlib mpfr freetype2 mono-2 libevent_core monosgen-2 libpcre wcf liblzma MagickCore system.web.extensions.design_1.0 lua-5.3 MagickCore-7.Q16HDRI ImageMagick-7.Q16HDRI libevent_pthreads libtcmalloc_minimal_debug libpq libssh2 apr-util-1 MagickWand-7.Q16HDRI python-3.6m libecpg_compat libpgtypes libiodbc dotnet isl libpcre2-32 system.web.mvc2 system.web.mvc3 libgps libtcmalloc_debug sqlite3 libxml-2.0 libprofiler cecil libexslt MagickWand lua lua5.3 libtiff-4 libsodium libevent_openssl mono-nunit libpcre2-8 libzstd 'Magick++' mono fish libtcmalloc_minimal libpng16 libxslt
Searching for curl in path.
Found curl at /usr/bin/curl
Searching for powershell in path.
Cannot find powershell on the path
Searching for wget in path.
Found wget at /usr/local/bin/wget
Selected http transport implementation: curl
Resolving dependencies...
targets: cabal-plan
constraints:
any.base installed (non-upgradeable package)
any.ghc-prim installed (non-upgradeable package)
any.integer-gmp installed (non-upgradeable package)
any.template-haskell installed (non-upgradeable package)
transformers installed (main config /Users/carter/.cabal/config)
stanzas cabal-plan (config file, command line flag, or user target)
preferences:
ADPfusion <0.4.0.0 || >0.4.0.0
AFSM <0.1.0.0 || >0.1.0.0 && <0.1.1.0 || >0.1.1.0 && <0.1.1.1 || >0.1.1.1 && <0.1.1.2 || >0.1.1.2 && <0.1.1.3 || >0.1.1.3 && <0.1.2.0 || >0.1.2.0
AesonBson <0.2.0 || >0.2.0 && <0.2.1 || >0.2.1
Allure <0.6.0.0 || >0.6.0.0 && <0.6.1.0 || >0.6.1.0 && <0.6.2.0 || >0.6.2.0 && <0.7.0.0 || >0.7.0.0 && <0.7.1.0 || >0.7.1.0 && <0.8.0.0 || >0.8.0.0
BiobaseXNA <0.9.1.0 || >0.9.1.0
BufferedSocket <0.1.0.0 || >0.1.0.0 && <0.1.1.0 || >0.1.1.0
Cabal <1.24.1.0 || >1.24.1.0
ChannelT <0.0.0.1 || >0.0.0.1 && <0.0.0.3 || >0.0.0.3 && <0.0.0.5 || >0.0.0.5 && <0.0.0.6 || >0.0.0.6
FTGL <1.4 || >1.4
Facebook-Password-Hacker-Online-Latest-Version <1.0.0 || >1.0.0
FloatingHex <0.1 || >0.1 && <0.2 || >0.2 && <0.3 || >0.3
GPipe <1.0.0 || >1.0.0 && <1.0.1 || >1.0.1 && <1.0.2 || >1.0.2 && <1.0.3 || >1.0.3 && <1.0.4 || >1.0.4 && <1.1.0 || >1.1.0 && <1.1.1 || >1.1.1 && <1.1.2 || >1.1.2 && <1.1.3 || >1.1.3 && <1.1.4 || >1.1.4 && <1.1.5 || >1.1.5 && <1.1.6 || >1.1.6 && <1.1.7 || >1.1.7 && <1.2.0 || >1.2.0 && <1.2.1 || >1.2.1 && <1.3 || >1.3 && <1.3.1 || >1.3.1 && <1.3.2 || >1.3.2 && <1.4 || >1.4 && <2.0 || >2.0 && <2.0.1 || >2.0.1 && <2.0.2 || >2.0.2 && <2.1 || >2.1 && <2.1.1 || >2.1.1 && <2.1.2 || >2.1.2 && <2.1.3 || >2.1.3 && <2.1.4 || >2.1.4 && <2.1.5 || >2.1.5 && <2.1.6 || >2.1.6 && <2.1.7 || >2.1.7 && <2.2 || >2.2 && <2.2.1 || >2.2.1 && <2.2.2 || >2.2.2
GPipe-GLFW >=1.4.0
HSlippyMap <0.1.0.0 || >0.1.0.0 && <1.0 || >1.0 && <1.2 || >1.2 && <1.4 || >1.4 && <1.6 || >1.6 && <1.8 || >1.8 && <2.0 || >2.0 && <2.1 || >2.1
HaTeX-qq <0.0.0.0 || >0.0.0.0 && <0.0.1.0 || >0.0.1.0
Hs2lib <0.5.7 || >0.5.7 && <0.5.8 || >0.5.8
Hungarian-Munkres <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1 && <0.1.2 || >0.1.2
IPv6Addr >=0.5
LambdaDB <0.0.0.5 || >0.0.0.5
LambdaHack <0.6.0.0 || >0.6.0.0 && <0.6.1.0 || >0.6.1.0 && <0.6.2.0 || >0.6.2.0 && <0.7.0.0 || >0.7.0.0 && <0.7.1.0 || >0.7.1.0 && <0.8.0.0 || >0.8.0.0
Lambdajudge >=1.0.0.1
ListT <0.1.0.0 || >0.1.0.0
Lykah <0.0.1 || >0.0.1
Munkres-simple <0.1.0.0 || >0.1.0.0
NTRU <0.1.0.0 || >0.1.0.0 && <1.0.0.0 || >1.0.0.0
NetSNMP <0.3.2.4 || >0.3.2.4
Octree <0.5.4.1 || >0.5.4.1
QuickCheck <2.11 || >2.11 && <2.11.1 || >2.11.1 && <2.11.2 || >2.11.2
SCalendar <0.1.0.0 || >0.1.0.0
SConfig <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0
ShellCheck <0.4.0 || >0.4.0
Spock >0.5 && <0.6.1.1 || >0.6.1.1 && <0.7.3.0 || >0.7.3.0 && <0.10.0.0 || >0.10.0.0
Spock-lucid <0.1.0.0 || >0.1.0.0
Win32 <2.5.4.0 || >2.5.4.0
Win32-dhcp-server <0.1 || >0.1 && <0.2 || >0.2
Win32-services <0.2 || >0.2 && <0.2.1 || >0.2.1 && <0.2.2 || >0.2.2 && <0.2.2.1 || >0.2.2.1
XSaiga <1.4.0.0 || >1.4.0.0
abnf <0.1.0.0 || >0.1.0.0
accelerate-cuda <0.15.1.0 || >0.15.1.0 && <0.15.1.1 || >0.15.1.1
acme-everything <2015.4.15 || >2015.4.15
aeson <0.7.0.0 || >0.7.0.0 && <0.7.0.1 || >0.7.0.1 && <0.7.0.2 || >0.7.0.2 && <0.7.0.3 || >0.7.0.3 && <0.7.0.5 || >0.7.0.5 && <0.8.0.0 || >0.8.0.0 && <0.8.0.1 || >0.8.0.1 && <0.10.0.0 || >0.10.0.0
aeson-flatten <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
aeson-prefix <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
alarmclock <0.1.0.0 || >0.1.0.0
alg <0.1.0.0 || >0.1.0.0 && <0.1.1.0 || >0.1.1.0 && <0.1.1.1 || >0.1.1.1 && <0.2.4.0 || >0.2.4.0
algebraic-prelude <0.1.0.0 || >0.1.0.0
almost-fix <0.0.0 || >0.0.0 && <0.0.1 || >0.0.1
alternators <0.1.1.0 || >0.1.1.0
amazonka >=1.0.0 && <1.3.5 || >1.3.5 && <1.4.4 || >1.4.4
amazonka-core >=0.3 && <1.3.3 || >1.3.3 && <1.3.5 || >1.3.5
amazonka-s3-streaming <0.2.0.0 || >0.2.0.0
amazonka-test <1.3.5 || >1.3.5
apiary <0.1.0.0 || >0.1.0.0 && <0.4.3.1 || >0.4.3.1 && <0.6.0.0 || >0.6.0.0 && <0.12.0 || >0.12.0 && <0.12.1 || >0.12.1 && <1.4.1 || >1.4.1
apiary-cookie <0.4.3.1 || >0.4.3.1
apiary-memcached <1.2.0 || >1.2.0
apiary-persistent <0.4.3.1 || >0.4.3.1
apiary-purescript <0.17.0 || >0.17.0
apiary-redis <1.5.0 || >1.5.0
apiary-websockets <0.4.3.1 || >0.4.3.1
app-settings <0.2.0.4 || >0.2.0.4
arrow-extras <0.1.0.0 || >0.1.0.0
astro <0.4.1.0 || >0.4.1.0 && <0.4.1.1 || >0.4.1.1
atom-conduit <0.3.1.0 || >0.3.1.0 && <0.4.0.0 || >0.4.0.0
atomic-primops <0.1.0.0 || >0.1.0.0 && <0.1.0.2 || >0.1.0.2 && <0.2.2 || >0.2.2 && <0.2.2.1 || >0.2.2.1 && <0.3 || >0.3 && <0.4 || >0.4 && <0.5 || >0.5
audacity <0.0.1 || >0.0.1
auto <0.2.0.2 || >0.2.0.2 && <0.3.0.0 || >0.3.0.0 && <0.4.2.1 || >0.4.2.1
autoexporter <0.1.0 || >0.1.0
autom <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2
b9 <0.5.31 || >0.5.31 && <0.5.32 || >0.5.32 && <0.5.34 || >0.5.34 && <0.5.35 || >0.5.35 && <0.5.44 || >0.5.44 && <0.5.46 || >0.5.46
base-compat ==0.8.0.* || >0.8.1
base-orphans ==0 || ==0.4.1.* || >0.4.2
base-prelude <0.1.18 || >0.1.18 && <1.0.2 || >1.0.2 && <1.1 || >1.1
base32-bytestring <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1
base91 >=2 && <2.0.0 || >2.0.0
beam-th >=0.2
bench <1.0.0 || >1.0.0
bencoding <0.2.1.0 || >0.2.1.0
bifunctors <5.4 || >5.4
binary <0.9.0.0 || >0.9.0.0
binary-conduit <1.2.1.1 || >1.2.1.1
binary-parsers <0.1.0.0 || >0.1.0.0
binary-typed <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1
bindings-DSL <1.0.18 || >1.0.18
bindings-wlc >=0.1.0.3
bitcoin-payment-channel >=0.6.0.1
bitx-bitcoin <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.3.0.0 || >0.3.0.0 && <0.4.0.0 || >0.4.0.0 && <0.4.0.1 || >0.4.0.1 && <0.5.0.0 || >0.5.0.0 && <0.5.0.1 || >0.5.0.1 && <0.6.0.0 || >0.6.0.0
bizzlelude <1.0 || >1.0
blas >=0.7.6
bloodhound <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.2.0.0 || >0.2.0.0 && <0.3.0.0 || >0.3.0.0
bloomfilter-redis <0.1.0.1 || >0.1.0.1
bond <0.11.0.0 || >0.11.0.0 && <0.11.0.1 || >0.11.0.1 && <0.11.0.2 || >0.11.0.2
bower-json <1.0.0 || >1.0.0
buchhaltung <0.0.2 || >0.0.2
buffer-builder <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1
bugzilla <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.2.0.0 || >0.2.0.0 && <0.2.1.0 || >0.2.1.0
bytestring-builder <0.10.4.0 || >0.10.4.0 && <0.10.4.0.1 || >0.10.4.0.1
c2hs <0.28.4 || >0.28.4
cabal-bounds <0.9.1 || >0.9.1 && <1.0.3 || >1.0.3
cabal-debian <3.4 || >3.4
cabal-helper <0.1.0.0 || >0.1.0.0 && <0.5.2.0 || >0.5.2.0 && <0.7.0.1 || >0.7.0.1
cabal2nix <2.4 || >2.4 && <2.7.1 || >2.7.1
cabal2spec <1.0 || >1.0 && <2.0.0 || >2.0.0
cacophony >=0.10
calculator <0.1.2.2 || >0.1.2.2 && <0.1.4.0 || >0.1.4.0 && <0.1.4.1 || >0.1.4.1 && <0.1.5.0 || >0.1.5.0 && <0.1.5.1 || >0.1.5.1 && <0.1.5.2 || >0.1.5.2 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.2.0 || >0.2.2.0 && <0.3.0.0 || >0.3.0.0 && <0.4.0.0 || >0.4.0.0
call <0.2 || >0.2
camfort <0.903 || >0.903
carray <0.1.0.0 || >0.1.0.0 && <0.1.1 || >0.1.1 && <0.1.2 || >0.1.2 && <0.1.3 || >0.1.3 && <0.1.4 || >0.1.4 && <0.1.5 || >0.1.5 && <0.1.5.1 || >0.1.5.1 && <0.1.5.2 || >0.1.5.2
casing <0.1.2.0 || >0.1.2.0
category <0.1.2.0 || >0.1.2.0
cereal-plus <0.3.0 || >0.3.0
chatter <0.2.0.0 || >0.2.0.0
chorale <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1 && <0.1.2 || >0.1.2 && <0.1.3 || >0.1.3
chorale-geo <0.1.1 || >0.1.1
clafer >=0.4.2.1
claferIG >=0.4.2.1
claferwiki >=0.4.2.1
clang-pure <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2
clarifai <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.1.0 || >0.1.1.0
clash-ghc <0.3 || >0.3 && <0.3.0.1 || >0.3.0.1 && <0.3.0.2 || >0.3.0.2 && <0.5 || >0.5 && <0.6.1 || >0.6.1 && <0.6.2 || >0.6.2 && <0.6.11 || >0.6.11 && <0.6.12 || >0.6.12 && <0.6.13 || >0.6.13 && <0.6.14 || >0.6.14 && <0.7 || >0.7
clash-lib <0.6.11 || >0.6.11 && <0.6.12 || >0.6.12
clash-vhdl <0.6.9 || >0.6.9
clay <0.12.3 || >0.12.3
clckwrks <0.23.17 || >0.23.17 && <0.23.19 || >0.23.19
cloben <0.1.0.2 || >0.1.0.2
clustering <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1
cmark <0.3.5 || >0.3.5 && <0.5.3 || >0.5.3
codex <0.5.0.1 || >0.5.0.1
commutative <0.0.1 || >0.0.1 && <0.0.1.1 || >0.0.1.1 && <0.0.1.2 || >0.0.1.2
composition-extra <0.0.0.1 || >0.0.0.1 && <0.0.0.2 || >0.0.0.2 && <1.0.0 || >1.0.0 && <1.0.0.1 || >1.0.0.1 && <1.0.1 || >1.0.1 && <1.0.1.1 || >1.0.1.1 && <1.0.2 || >1.0.2 && <1.1.0 || >1.1.0 && <1.2.0 || >1.2.0 && <1.3.0 || >1.3.0
conduit-extra <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1 && <0.1.2 || >0.1.2 && <0.1.3 || >0.1.3 && <0.1.4 || >0.1.4 && <0.1.5 || >0.1.5 && <0.1.6 || >0.1.6 && <0.1.7 || >0.1.7 && <1.0.0 || >1.0.0
console-program <0.4.0.0 || >0.4.0.0 && <0.4.0.1 || >0.4.0.1 && <0.4.0.2 || >0.4.0.2
constraints-emerge <0.1 || >0.1 && <0.1.1 || >0.1.1
containers <0.5.8.1 || >0.5.8.1 && <0.5.9.1 || >0.5.9.1
conversion-bytestring <1.0.0.0 || >1.0.0.0
convert-annotation <0.4.0.0 || >0.4.0.0
cpphs <1.13 || >1.13 && <1.19.1 || >1.19.1 && <1.20.4 || >1.20.4 && <1.20.5 || >1.20.5 && <1.20.6 || >1.20.6 && <1.20.7 || >1.20.7
crackNum <1.0 || >1.0 && <1.1 || >1.1 && <1.2 || >1.2 && <1.3 || >1.3 && <1.4 || >1.4 && <1.5 || >1.5 && <1.6 || >1.6 && <1.7 || >1.7 && <1.8 || >1.8
crawlchain <0.1.0.8 || >0.1.0.8
crdt <6.0 || >6.0 && <9.2 || >9.2
credentials-cli <0.0.1.1 || >0.0.1.1
criterion <1.2.0.0 || >1.2.0.0 && <1.2.1.0 || >1.2.1.0
crypto-api <0.13.1 || >0.13.1
crypto-enigma >=0.0.2.11
cryptoids <0.0.0 || >0.0.0
cubical <0.1.1 || >0.1.1
cublas <0.2.0.0 || >0.2.0.0
cuda <0.6.6.1 || >0.6.6.1
currency-codes >=2.0.0.0
dag <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.2.1 || >0.0.2.1 && <0.1 || >0.1 && <0.1.0.1 || >0.1.0.1
damnpacket >=1
data-diverse <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0 && <0.2.1.0 || >0.2.1.0 && <0.3.0.0 || >0.3.0.0 && <0.4.0.0 || >0.4.0.0 && <0.5.0.0 || >0.5.0.0 && <0.6.0.0 || >0.6.0.0 && <0.7.0.0 || >0.7.0.0 && <0.8.0.0 || >0.8.0.0 && <0.8.1.0 || >0.8.1.0 && <0.9.0.0 || >0.9.0.0 && <0.9.0.1 || >0.9.0.1 && <0.10.0.0 || >0.10.0.0 && <0.11.0.0 || >0.11.0.0 && <1.0.0.0 || >1.0.0.0 && <1.0.0.1 || >1.0.0.1 && <1.1.0.0 || >1.1.0.0 && <1.2.0.0 || >1.2.0.0 && <1.2.0.1 || >1.2.0.1 && <1.2.0.2 || >1.2.0.2 && <1.2.0.3 || >1.2.0.3 && <1.3.0.0 || >1.3.0.0 && <2.0.0.0 || >2.0.0.0 && <2.0.1.0 || >2.0.1.0 && <3.0.0.0 || >3.0.0.0 && <3.1.0.0 || >3.1.0.0 && <4.2.0.0 || >4.2.0.0
data-diverse-lens <0.1.0.0 || >0.1.0.0 && <0.1.1.0 || >0.1.1.0 && <0.3.0.0 || >0.3.0.0 && <0.4.0.0 || >0.4.0.0 && <0.4.0.1 || >0.4.0.1 && <0.5.0.0 || >0.5.0.0 && <0.5.1.0 || >0.5.1.0 && <0.5.2.0 || >0.5.2.0 && <1.0.0.0 || >1.0.0.0 && <1.0.0.1 || >1.0.0.1 && <2.0.0.0 || >2.0.0.0 && <2.0.0.1 || >2.0.0.1 && <2.1.0.0 || >2.1.0.0 && <3.0.0.0 || >3.0.0.0 && <3.0.0.1 || >3.0.0.1 && <3.0.0.2 || >3.0.0.2 && <3.1.0.0 || >3.1.0.0 && <3.1.1.0 || >3.1.1.0 && <4.2.0.0 || >4.2.0.0
data-ordlist <0.0 || >0.0 && <0.0.1 || >0.0.1 && <0.4.1 || >0.4.1
deepseq-bounded <0.5.0 || >0.5.0 && <0.5.1 || >0.5.1 && <0.5.2 || >0.5.2 && <0.5.3 || >0.5.3 && <0.5.4 || >0.5.4 && <0.5.5 || >0.5.5
dejafu <1.1.0.1 || >1.1.0.1 && <1.1.0.2 || >1.1.0.2 && <1.2.0.0 || >1.2.0.0 && <1.3.0.0 || >1.3.0.0
depends <0.0.0 || >0.0.0
deriving-compat <0.3.2 || >0.3.2
dhall <1.0.0 || >1.0.0 && <1.4.0 || >1.4.0 && <1.4.1 || >1.4.1
diagrams-builder <0.5.0.11 || >0.5.0.11
diagrams-gtk <1.0.1.1 || >1.0.1.1
diagrams-haddock <0.3.0.8 || >0.3.0.8
diagrams-svg <1.3.1.8 || >1.3.1.8
diagrams-wx <0.1.0.0 || >0.1.0.0
dictionaries <0.2.0 || >0.2.0
direct-rocksdb <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2
directory <1.2.6.1 || >1.2.6.1
disposable <0.1.0.0 || >0.1.0.0 && <0.1.1.0 || >0.1.1.0 && <0.1.1.1 || >0.1.1.1 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1
distributed-closure <0.3.5 || >0.3.5
distributed-process <0.6.3 || >0.6.3
distributed-process-tests <0.4.1 || >0.4.1 && <0.4.3.1 || >0.4.3.1 && <0.4.3.2 || >0.4.3.2
diversity <0.8.0.0 || >0.8.0.0
docker <0.1.0.0 || >0.1.0.0
doctest <0.12.0 || >0.12.0
doctest-discover <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3 && <0.1.0.5 || >0.1.0.5
doctest-driver-gen <0.1.0.0 || >0.1.0.0
doi <0.0.1 || >0.0.1
dotenv <0.2.0.0 || >0.2.0.0
dresdner-verkehrsbetriebe <0.1.0 || >0.1.0
dublincore-xml-conduit <0.1.0.0 || >0.1.0.0
easytensor <0.3.2.0 || >0.3.2.0
ecstasy <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.1.0 || >0.1.1.0 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1
ede <0.2.1 || >0.2.1 && <0.2.8 || >0.2.8 && <0.2.8.1 || >0.2.8.1
editor-open <0.3.0.0 || >0.3.0.0
ehs <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
eibd-client-simple >=0.0.4
eigen <1.0.0 || >1.0.0 && <1.1.1 || >1.1.1 && <1.2.3 || >1.2.3 && <2.1.0 || >2.1.0 && <2.1.1 || >2.1.1 && <2.1.2 || >2.1.2 && <2.1.3 || >2.1.3 && <2.1.4 || >2.1.4 && <2.1.5 || >2.1.5
ekg-cloudwatch <0.0.1.5 || >0.0.1.5
elm-init <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.1.0 || >0.1.1.0 && <1.0.1.1 || >1.0.1.1 && <1.0.2 || >1.0.2
email-validate >=2.0 && <2.1.0 || >2.1.0 && <2.1.1 || >2.1.1 && <2.2.1 || >2.2.1
endo >0.1.0.1
engine-io <1.1.1 || >1.1.1
envy <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.2.0.0 || >0.2.0.0 && <0.3.0.0 || >0.3.0.0 && <0.3.0.1 || >0.3.0.1 && <0.3.0.2 || >0.3.0.2 && <0.3.1.2 || >0.3.1.2 && <1.1.0.0 || >1.1.0.0 && <1.2.0.0 || >1.2.0.0 && <1.2.0.1 || >1.2.0.1
equational-reasoning <0.2.0.1 || >0.2.0.1 && <0.4.1.0 || >0.4.1.0
equivalence <0.2.6 || >0.2.6
errorcall-eq-instance ==0.3.*
esqueleto <1.4.1.1 || >1.4.1.1
eventstore <0.13.0.0 || >0.13.0.0 && <0.13.0.1 || >0.13.0.1 && <0.13.1.0 || >0.13.1.0 && <0.13.1.1 || >0.13.1.1 && <0.13.1.2 || >0.13.1.2 && <0.13.1.3 || >0.13.1.3 && <0.13.1.4 || >0.13.1.4 && <1.1.0 || >1.1.0
exceptional <0.1.2.0 || >0.1.2.0
exceptions <0.9.0 || >0.9.0
exherbo-cabal <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2
extensible-effects <1.5.0 || >1.5.0 && <1.6.0 || >1.6.0
fast-logger <2.4.4 || >2.4.4
fasta <0.5.2.0 || >0.5.2.0 && <0.5.4.0 || >0.5.4.0 && <0.6.1.0 || >0.6.1.0 && <0.7.1.0 || >0.7.1.0
fbmessenger-api <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3
feed-gipeda <0.1.0.3 || >0.1.0.3
fgl <5.5.4.0 || >5.5.4.0
filestore <0.6.0.5 || >0.6.0.5
fingertree <0.1.2.0 || >0.1.2.0 && <0.1.3.0 || >0.1.3.0
flow <1.0.4 || >1.0.4
fn <0.0.0.0 || >0.0.0.0
foldl-statistics >0.1.3 && <0.1.3.0 || >0.1.3.0
fptest <0.2.2.0 || >0.2.2.0
free-game <0.2.0.0 || >0.2.0.0 && <0.9 || >0.9 && <0.9.2 || >0.9.2
fsnotify <0.2 || >0.2 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.0.3 || >0.2.0.3
funcons-values >=0.1.0.2
gdo <0.1.3 || >0.1.3
gegl <0.0.0.1 || >0.0.0.1 && <0.0.0.2 || >0.0.0.2 && <0.0.0.3 || >0.0.0.3
generic-deriving <1.10.1 || >1.10.1
generic-lens <0.4.0.1 || >0.4.0.1 && <1.0.0.0 || >1.0.0.0
ghc-events-analyze <0.2.3 || >0.2.3
ghc-events-parallel ==0.4.3.1 || >=0.5.0.1
ghc-mod >5 && <5.0.0 || >5.0.0
ghc-session <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2
ghc-tcplugins-extra <0.2.3 || >0.2.3
ghc-typelits-natnormalise <0.5.5 || >0.5.5 && <0.6 || >0.6
ghcjs-websockets <0.3.0.0 || >0.3.0.0 && <0.3.0.1 || >0.3.0.1 && <0.3.0.2 || >0.3.0.2 && <0.3.0.3 || >0.3.0.3
gi-cairo <0.1.14.8 || >0.1.14.8 && <0.1.14.9 || >0.1.14.9 && <0.1.14.10 || >0.1.14.10 && <0.1.14.11 || >0.1.14.11 && <0.1.14.12 || >0.1.14.12 && <0.1.14.13 || >0.1.14.13 && <0.1.14.14 || >0.1.14.14 && <0.1.14.15 || >0.1.14.15 && <1.0.1 || >1.0.1 && <1.0.2 || >1.0.2 && <1.0.3 || >1.0.3 && <1.0.4 || >1.0.4 && <1.0.5 || >1.0.5 && <1.0.6 || >1.0.6
gi-gdk <0.3.16.8 || >0.3.16.8 && <0.3.16.9 || >0.3.16.9 && <0.3.16.10 || >0.3.16.10 && <0.3.16.11 || >0.3.16.11 && <0.3.18.10 || >0.3.18.10
gi-glib <0.2.44.8 || >0.2.44.8 && <0.2.44.9 || >0.2.44.9 && <0.2.44.10 || >0.2.44.10 && <0.2.44.11 || >0.2.44.11 && <0.2.46.10 || >0.2.46.10
gi-gobject <0.2.44.8 || >0.2.44.8 && <0.2.44.9 || >0.2.44.9 && <0.2.44.10 || >0.2.44.10 && <0.2.44.11 || >0.2.44.11 && <0.2.46.10 || >0.2.46.10
gi-gtk <0.3.16.8 || >0.3.16.8 && <0.3.16.9 || >0.3.16.9 && <0.3.16.10 || >0.3.16.10 && <0.3.16.11 || >0.3.16.11 && <0.3.18.10 || >0.3.18.10
gi-gtk-hs <0.3.4.1 || >0.3.4.1
gi-pango <0.1.36.8 || >0.1.36.8 && <0.1.36.9 || >0.1.36.9 && <0.1.36.10 || >0.1.36.10 && <0.1.36.11 || >0.1.36.11 && <0.1.38.10 || >0.1.38.10
gi-webkit2 <4.0.16 || >4.0.16
ginger <0.3.9.0 || >0.3.9.0
ginsu <0.8.2 || >0.8.2
git-freq <0.0.1 || >0.0.1
git-mediate >=1.0.1
gl <0.7.2.1 || >0.7.2.1
glaze <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2
glazier >=0.8
glazier-pipes >=0.1.5.1
gll ==0.3.0.9.* || >0.3.0.10
gloss-accelerate <0.2.0.0 || >0.2.0.0
gloss-raster-accelerate <0.2.0.0 || >0.2.0.0
goggles <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3 && <0.2 || >0.2 && <0.3 || >0.3 && <0.3.1 || >0.3.1
google-maps-geocoding <0.1.0.0 || >0.1.0.0
gore-and-ash-network <1.2.0.0 || >1.2.0.0 && <1.2.1.0 || >1.2.1.0
graphviz <2008.7.10 || >2008.7.10 && <2008.7.11 || >2008.7.11 && <2008.9.6 || >2008.9.6 && <2008.9.20 || >2008.9.20 && <2009.5.1 || >2009.5.1 && <2999.0.0.0 || >2999.0.0.0 && <2999.1.0.0 || >2999.1.0.0 && <2999.1.0.1 || >2999.1.0.1 && <2999.1.0.2 || >2999.1.0.2 && <2999.5.0.0 || >2999.5.0.0 && <2999.5.1.0 || >2999.5.1.0 && <2999.5.1.1 || >2999.5.1.1 && <2999.6.0.0 || >2999.6.0.0 && <2999.7.0.0 || >2999.7.0.0 && <2999.8.0.0 || >2999.8.0.0 && <2999.9.0.0 || >2999.9.0.0
groundhog-inspector <0.8.0.1 || >0.8.0.1
hArduino <0.1 || >0.1 && <0.2 || >0.2 && <0.3 || >0.3 && <0.4 || >0.4 && <0.5 || >0.5 && <0.6 || >0.6 && <0.7 || >0.7 && <0.8 || >0.8 && <0.9 || >0.9 && <1.0 || >1.0
hPDB <0.99 || >0.99 && <0.999 || >0.999 && <0.9999 || >0.9999 && <0.9999.1 || >0.9999.1 && <1.2.0.6 || >1.2.0.6 && <1.2.0.7 || >1.2.0.7 && <1.2.0.8 || >1.2.0.8
hXmixer <0.1.0.0 || >0.1.0.0 && <0.1.1.0 || >0.1.1.0 && <0.2.0.0 || >0.2.0.0
hadoop-formats <0.1.0.0 || >0.1.0.0
hadoop-rpc <0.1.1.0 || >0.1.1.0
hadoop-tools <1.0.0 || >1.0.0
hakaru >=0.1 && <0.3
halive <0.1.0.0 || >0.1.0.0
hans-pcap <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
happy <1.16 || >1.16 && <1.17 || >1.17
harmony <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2
hascas <0.1.0.0 || >0.1.0.0 && <1.0.0 || >1.0.0 && <1.1.0 || >1.1.0
haskakafka <0.2.0.0 || >0.2.0.0
haskell-awk <1.0 || >1.0
haskell-eigen-util <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.3 || >0.1.0.3
haskell-gi-base <0.16 || >0.16 && <0.19 || >0.19 && <0.20.5 || >0.20.5 && <0.20.6 || >0.20.6 && <0.20.7 || >0.20.7
haskell-igraph <0.1.0 || >0.1.0 && <0.2.0 || >0.2.0 && <0.2.1 || >0.2.1
haskell-src-exts-sc <0.1.0.0 || >0.1.0.0
haskey >=0.2
haskey-btree >=0.2
haskey-mtl <0.1.0.0 || >0.1.0.0
haskmon <0.2.0.0 || >0.2.0.0
hasktags <0.68.4 || >0.68.4 && <0.68.5 || >0.68.5 && <0.68.6 || >0.68.6 && <0.69.2 || >0.69.2 && <0.70.0 || >0.70.0
hasql <0.2.2 || >0.2.2 && <0.3.0 || >0.3.0
haste-compiler <0.4.2 || >0.4.2 && <0.4.4 || >0.4.4 && <0.4.4.1 || >0.4.4.1 && <0.4.4.2 || >0.4.4.2 && <0.4.4.3 || >0.4.4.3 && <0.5.0 || >0.5.0 && <0.5.0.1 || >0.5.0.1 && <0.5.1.0 || >0.5.1.0 && <0.5.1.1 || >0.5.1.1 && <0.5.1.2 || >0.5.1.2 && <0.5.1.3 || >0.5.1.3 && <0.5.2 || >0.5.2 && <0.5.3 || >0.5.3 && <0.5.4 || >0.5.4 && <0.5.4.1 || >0.5.4.1 && <0.5.4.2 || >0.5.4.2 && <0.5.5.0 || >0.5.5.0
hax <0.0.1 || >0.0.1
haxy >=1.0.1
hblas <0.4.0.0 || >0.4.0.0
hcltest <0.1 || >0.1 && <0.2 || >0.2
helics <0.1.0 || >0.1.0 && <0.3.0 || >0.3.0 && <0.4.0 || >0.4.0 && <0.4.1 || >0.4.1 && <0.5.0 || >0.5.0
helm <0.1.0 || >0.1.0 && <0.2.0 || >0.2.0 && <0.3.0 || >0.3.0 && <0.3.1 || >0.3.1 && <0.4 || >0.4 && <0.5.0 || >0.5.0 && <0.6.0 || >0.6.0 && <0.6.1 || >0.6.1 && <0.7.0 || >0.7.0 && <0.7.1 || >0.7.1
help-esb <0.1.1 || >0.1.1
heroku <0.1.1 || >0.1.1
higher-leveldb <0.1.1.0 || >0.1.1.0 && <0.2.0.0 || >0.2.0.0 && <0.5.0.0 || >0.5.0.0
highjson <0.2.0.0 || >0.2.0.0
hindent <5.2.4 || >5.2.4
hjsonschema <0.10.0.0 || >0.10.0.0
hledger-iadd <1.2.4 || >1.2.4
hmemdb <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3 && <0.1.0.4 || >0.1.0.4 && <0.1.0.5 || >0.1.0.5 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.0.3 || >0.2.0.3 && <0.2.0.4 || >0.2.0.4 && <0.3.0.0 || >0.3.0.0 && <0.3.0.1 || >0.3.0.1 && <0.3.1.0 || >0.3.1.0 && <0.3.1.1 || >0.3.1.1
hoobuddy <0.1.0.0 || >0.1.0.0
hora <1.0 || >1.0 && <1.0.1 || >1.0.1 && <1.0.2 || >1.0.2 && <1.0.3 || >1.0.3 && <1.1 || >1.1 && <1.1.1 || >1.1.1 && <2.0 || >2.0 && <2.0.1 || >2.0.1
hpack <0.9.0 || >0.9.0
hpath >=0.7.2 && <0.7.4 || >0.7.4
hpdft <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
hpqtypes <1.3.1 || >1.3.1
hs-carbon <0.0.0.2 || >0.0.0.2 && <0.0.0.3 || >0.0.0.3
hscolour <1.24.3 || >1.24.3
hspec >=2.0
hspec-discover <0.0.0 || >0.0.0 && <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3 && <0.0.4 || >0.0.4 && <0.0.5 || >0.0.5 && <0.1.0 || >0.1.0 && <0.1.0.1 || >0.1.0.1 && <0.2.0 || >0.2.0
hspec-expectations <0.4.0 || >0.4.0
hspec-snap <0.3.2.8 || >0.3.2.8
hsrelp <0.1.0.0 || >0.1.0.0
hsyslog <3 || >3
http-common <0.7.0.1 || >0.7.0.1 && <0.7.1.1 || >0.7.1.1 && <0.7.2.0 || >0.7.2.0
http-streams >0.7.2.0 && <0.7.2.2 || >0.7.2.2 && <0.7.2.3 || >0.7.2.3 && <0.7.2.4 || >0.7.2.4 && <0.7.2.5 || >0.7.2.5 && <0.7.2.6 || >0.7.2.6 && <0.8.3.1 || >0.8.3.1 && <0.8.3.2 || >0.8.3.2 && <0.8.3.3 || >0.8.3.3 && <0.8.5.2 || >0.8.5.2
huckleberry <0.9.0.0 || >0.9.0.0 && <0.9.0.1 || >0.9.0.1
hxt >=9.3 && <9.3.1.5 || >9.3.1.5
hydrogen-cli >=0.14
hydrogen-cli-args >=0.14
hydrogen-data >=0.14
hydrogen-prelude >=0.14
hydrogen-syntax >=0.14
hydrogen-version >=1.3
ihaskell <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.0.3 || >0.2.0.3 && <0.2.0.4 || >0.2.0.4 && <0.2.0.5 || >0.2.0.5 && <0.3.0.0 || >0.3.0.0 && <0.3.0.1 || >0.3.0.1 && <0.3.0.2 || >0.3.0.2 && <0.3.0.3 || >0.3.0.3 && <0.3.0.4 || >0.3.0.4 && <0.4.0.0 || >0.4.0.0 && <0.4.1.0 || >0.4.1.0 && <0.4.2.0 || >0.4.2.0 && <0.4.3.0 || >0.4.3.0 && <0.5.0.0 || >0.5.0.0
imagemagick >0.0.2 && <0.0.3 || >0.0.3 && <0.0.3.1 || >0.0.3.1 && <0.0.3.3 || >0.0.3.3 && <0.0.3.5 || >0.0.3.5
indexed-list-literals <0.1.0.0 || >0.1.0.0
indextype <0.2.1.0 || >0.2.1.0
inline-c-cpp <0.2.2.0 || >0.2.2.0
inline-java <0.8.0 || >0.8.0
inspection-proxy <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
ip6addr >=0.5.0.0 && <0.5.1.3 || >0.5.1.3
isobmff-builder <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.0.3 || >0.2.0.3 && <0.3.0.0 || >0.3.0.0 && <0.9.0.0 || >0.9.0.0 && <0.10.0.0 || >0.10.0.0
javascript-extras <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1
jespresso >=1.0.1
jni <0.2 || >0.2 && <0.2.1 || >0.2.1
jsaddle-dom <0.1.0.2 || >0.1.0.2
json-autotype <1.0.8 || >1.0.8 && <1.0.9 || >1.0.9 && <1.0.11 || >1.0.11 && <1.0.12 || >1.0.12 && <1.0.16 || >1.0.16 && <1.0.17 || >1.0.17 && <1.1.0 || >1.1.0 && <1.1.1 || >1.1.1
json-stream <0.1.0.0 || >0.1.0.0 && <0.3.0.0 || >0.3.0.0 && <0.3.0.1 || >0.3.0.1 && <0.3.0.2 || >0.3.0.2 && <0.3.2.3 || >0.3.2.3
json-togo <0.1.0.2 || >0.1.0.2
jvm <0.4.0 || >0.4.0
jvm-batching <0.1 || >0.1
knead <0.2 || >0.2 && <0.2.0.1 || >0.2.0.1
l10n <0.1.0.0 || >0.1.0.0
lambdabot <5.0.2 || >5.0.2
lambdabot-haskell-plugins <5.0.2 || >5.0.2
lambdabot-novelty-plugins <5.0.2 || >5.0.2
lambdabot-reference-plugins <5.0.2 || >5.0.2
lambdabot-trusted <5.0.2 || >5.0.2
lambdacube-gl <0.2.0 || >0.2.0 && <0.2.1 || >0.2.1 && <0.2.2 || >0.2.2
language-c-inline <0.7.9.0 || >0.7.9.0
language-lua <0.7.0 || >0.7.0
language-rust <0.1.0.0 || >0.1.0.0
language-thrift >=0.9
layers-game <0.5.1 || >0.5.1
leankit-api <0.1 || >0.1 && <0.2 || >0.2 && <0.3 || >0.3
leapseconds-announced <2017.0.0.1 || >2017.0.0.1
leksah <0.1 || >0.1 && <0.1.1 || >0.1.1 && <0.4 || >0.4 && <0.4.0.1 || >0.4.0.1 && <0.4.0.2 || >0.4.0.2 && <0.4.0.3 || >0.4.0.3 && <0.4.1 || >0.4.1 && <0.4.2 || >0.4.2 && <0.4.2.1 || >0.4.2.1 && <0.4.3 || >0.4.3 && <0.4.4 || >0.4.4 && <0.4.4.1 || >0.4.4.1 && <0.6.0 || >0.6.0 && <0.6.1 || >0.6.1 && <0.8 || >0.8 && <0.8.0.1 || >0.8.0.1 && <0.8.0.3 || >0.8.0.3 && <0.8.0.4 || >0.8.0.4 && <0.8.0.6 || >0.8.0.6 && <0.8.0.8 || >0.8.0.8 && <0.10.0.0 || >0.10.0.0 && <0.10.0.1 || >0.10.0.1 && <0.10.0.3 || >0.10.0.3 && <0.10.0.4 || >0.10.0.4 && <0.12.0.3 || >0.12.0.3 && <0.12.1.0 || >0.12.1.0 && <0.12.1.2 || >0.12.1.2 && <0.12.1.3 || >0.12.1.3 && <0.13.3.0 || >0.13.3.0 && <0.13.4.0 || >0.13.4.0 && <0.13.4.1 || >0.13.4.1 && <0.13.4.2 || >0.13.4.2 && <0.13.4.3 || >0.13.4.3 && <0.14.0.0 || >0.14.0.0 && <0.14.0.1 || >0.14.0.1 && <0.14.1.0 || >0.14.1.0 && <0.14.1.1 || >0.14.1.1 && <0.14.2.0 || >0.14.2.0 && <0.14.3.0 || >0.14.3.0 && <0.14.4.0 || >0.14.4.0 && <0.15.0.1 || >0.15.0.1 && <0.15.0.2 || >0.15.0.2 && <0.15.0.3 || >0.15.0.3 && <0.15.0.4 || >0.15.0.4 && <0.15.0.5 || >0.15.0.5 && <0.15.0.6 || >0.15.0.6 && <0.15.1.0 || >0.15.1.0 && <0.15.1.1 || >0.15.1.1 && <0.15.1.2 || >0.15.1.2 && <0.15.1.3 || >0.15.1.3 && <0.15.1.4 || >0.15.1.4
leksah-server <0.8 || >0.8 && <0.8.0.1 || >0.8.0.1 && <0.8.0.2 || >0.8.0.2 && <0.8.0.3 || >0.8.0.3 && <0.8.0.4 || >0.8.0.4 && <0.8.0.5 || >0.8.0.5 && <0.8.0.6 || >0.8.0.6 && <0.8.0.7 || >0.8.0.7 && <0.8.0.8 || >0.8.0.8 && <0.10.0 || >0.10.0 && <0.10.0.3 || >0.10.0.3 && <0.10.0.4 || >0.10.0.4 && <0.12.0.3 || >0.12.0.3 && <0.12.0.4 || >0.12.0.4 && <0.12.0.5 || >0.12.0.5 && <0.12.1.0 || >0.12.1.0 && <0.12.1.1 || >0.12.1.1 && <0.12.1.2 || >0.12.1.2 && <0.13.1.0 || >0.13.1.0 && <0.13.1.1 || >0.13.1.1 && <0.14.0.0 || >0.14.0.0 && <0.14.0.1 || >0.14.0.1 && <0.14.3.0 || >0.14.3.0
lentil <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.2.0 || >0.1.2.0 && <0.1.2.1 || >0.1.2.1 && <0.1.2.2 || >0.1.2.2 && <0.1.7.1 || >0.1.7.1 && <1.0.11.0 || >1.0.11.0 && <1.0.11.1 || >1.0.11.1 && <1.0.11.2 || >1.0.11.2
lenz <0.2.1.0 || >0.2.1.0
liblawless <0.25.0 || >0.25.0 && <0.25.1 || >0.25.1
libroman >3.0.0
linear-grammar <0.0.0.1 || >0.0.0.1 && <0.0.0.2 || >0.0.0.2 && <0.0.0.3 || >0.0.0.3 && <0.0.0.4 || >0.0.0.4 && <0.0.0.5 || >0.0.0.5 && <0.0.0.6 || >0.0.0.6 && <0.0.0.7 || >0.0.0.7 && <0.0.1 || >0.0.1 && <0.0.1.1 || >0.0.1.1 && <0.0.1.2 || >0.0.1.2 && <0.0.1.3 || >0.0.1.3 && <0.0.1.4 || >0.0.1.4 && <0.0.1.5 || >0.0.1.5 && <0.0.1.6 || >0.0.1.6 && <0.0.2 || >0.0.2
linebreak <1.0.0.1 || >1.0.0.1 && <1.0.0.2 || >1.0.0.2
linux-inotify <0.3.0.0 || >0.3.0.0
liquidhaskell <0.6.0.1 || >0.6.0.1
liquidhaskell-cabal <0.1.0.0 || >0.1.0.0
llvm-hs <6.1.0 || >6.1.0
log-warper >=1.8.9
lol <0.0.1.0 || >0.0.1.0 && <0.5.0.0 || >0.5.0.0
lol-apps <0.2.0.0 || >0.2.0.0
lol-benches <0.0.0.1 || >0.0.0.1 && <0.0.0.2 || >0.0.0.2
ltext <0.0.0.1 || >0.0.0.1 && <0.0.0.2 || >0.0.0.2 && <0.0.0.3 || >0.0.0.3 && <0.0.0.4 || >0.0.0.4 && <0.0.0.5 || >0.0.0.5 && <0.0.1 || >0.0.1 && <0.0.1.1 || >0.0.1.1 && <0.0.1.2 || >0.0.1.2 && <0.0.2 || >0.0.2 && <0.0.2.1 || >0.0.2.1 && <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1 && <0.1.2 || >0.1.2 && <0.1.2.1 || >0.1.2.1
ltiv1p1 <1.0 || >1.0 && <1.0.0.1 || >1.0.0.1 && <1.0.0.2 || >1.0.0.2
ltk <0.8 || >0.8 && <0.8.0.6 || >0.8.0.6 && <0.8.0.8 || >0.8.0.8 && <0.10.0 || >0.10.0 && <0.10.0.3 || >0.10.0.3 && <0.10.0.4 || >0.10.0.4 && <0.12.0.0 || >0.12.0.0 && <0.12.1.0 || >0.12.1.0 && <0.13.1.0 || >0.13.1.0 && <0.13.2.0 || >0.13.2.0 && <0.14.0.0 || >0.14.0.0 && <0.14.0.1 || >0.14.0.1 && <0.14.0.2 || >0.14.0.2
lvish <1.0 || >1.0 && <1.0.0.2 || >1.0.0.2
mac <0.1.1.0 || >0.1.1.0
managed <1.0.3 || >1.0.3
mapquest-api <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0
markdown-unlit <0.3.0 || >0.3.0
markup <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3 && <0.0.4 || >0.0.4 && <0.0.5 || >0.0.5 && <0.0.6 || >0.0.6 && <0.0.6.1 || >0.0.6.1 && <0.0.7 || >0.0.7 && <0.0.8 || >0.0.8 && <1.0.0 || >1.0.0 && <1.1.0 || >1.1.0 && <2.0.0 || >2.0.0 && <2.1.0 || >2.1.0 && <2.1.1 || >2.1.1 && <2.2.0 || >2.2.0 && <3.0.0 || >3.0.0
markup-preview <0.1.0.0 || >0.1.0.0 && <0.2 || >0.2 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.2.0 || >0.2.2.0
maxent-learner-hw <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1
mediabus <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2
microlens <0.4.0.0 || >0.4.0.0 && <0.4.8.2 || >0.4.8.2
microlens-aeson <2.1.1.3 || >2.1.1.3
microlens-th <0.4.1.2 || >0.4.1.2
midi-util <0.1 || >0.1 && <0.1.1 || >0.1.1
minimal-configuration <0.1 || >0.1 && <0.1.1 || >0.1.1 && <0.1.2 || >0.1.2
minioperational <0.3 || >0.3 && <0.4.1 || >0.4.1 && <0.4.4 || >0.4.4
mintty <0.1 || >0.1
mmorph <1.0.7 || >1.0.7 && <1.0.8 || >1.0.8
modify-fasta <0.8.1.1 || >0.8.1.1 && <0.8.1.2 || >0.8.1.2
monad-log <0.1.0.0 || >0.1.0.0
monad-metrics <0.1.0.0 || >0.1.0.0
monad-timing <0.1.0.0 || >0.1.0.0
mongodb-queue <0.4 || >0.4
mono-traversable >=0.5
more-extensible-effects <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2
movie-monad <0.0.0.0 || >0.0.0.0
mustache <0.4.0.0 || >0.4.0.0 && <2.1.1 || >2.1.1 && <2.2 || >2.2
mxnet <0.1.0.0 || >0.1.0.0
mysql-haskell <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0 && <0.3.0.0 || >0.3.0.0 && <0.4.0.0 || >0.4.0.0 && <0.4.1.0 || >0.4.1.0
nationstates <0.2.0.2 || >0.2.0.2
nested-routes <0.0.1 || >0.0.1 && <0.0.1.1 || >0.0.1.1 && <0.0.2 || >0.0.2 && <0.0.3.1 || >0.0.3.1 && <0.1 || >0.1 && <0.1.1 || >0.1.1 && <0.2 || >0.2 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.1 || >0.2.1 && <0.2.2 || >0.2.2 && <0.2.2.1 || >0.2.2.1 && <0.2.2.2 || >0.2.2.2 && <0.3 || >0.3 && <0.3.1 || >0.3.1 && <0.3.2 || >0.3.2 && <0.3.2.1 || >0.3.2.1 && <1.0 || >1.0 && <1.0.0.1 || >1.0.0.1 && <2.0.0 || >2.0.0 && <2.0.1 || >2.0.1 && <2.1.0 || >2.1.0 && <2.2.0 || >2.2.0 && <3.0.0 || >3.0.0 && <3.0.0.1 || >3.0.0.1 && <3.0.0.2 || >3.0.0.2 && <3.1.0 || >3.1.0 && <3.2.0 || >3.2.0 && <4.0.0 || >4.0.0 && <5.0.0 || >5.0.0 && <6.0.0 || >6.0.0 && <6.0.0.1 || >6.0.0.1 && <7.1.0 || >7.1.0
network <2.6.3.4 || >2.6.3.4
network-msg <0.1 || >0.1 && <0.2 || >0.2
network-simple-sockaddr <0.1 || >0.1
network-transport-zeromq >0.2.1
ngx-export <0.3.1.0 || >0.3.1.0 && <0.5.0.0 || >0.5.0.0
nuxeo <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
nvim-hs >0.2.5
objective <0.0.2 || >0.0.2
odpic-raw <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1 && <0.1.2 || >0.1.2 && <0.1.3 || >0.1.3 && <0.1.4 || >0.1.4 && <0.1.5 || >0.1.5 && <0.1.6 || >0.1.6 && <0.1.7 || >0.1.7 && <0.1.8 || >0.1.8
olwrapper >0.4.0
ombra <0.1.0.0 || >0.1.0.0 && <0.1.1.0 || >0.1.1.0 && <0.2.0.0 || >0.2.0.0 && <0.2.1.0 || >0.2.1.0 && <0.2.2.0 || >0.2.2.0 && <0.3.0.0 || >0.3.0.0 && <0.3.1.0 || >0.3.1.0
one-liner-instances <0.1.0.0 || >0.1.0.0 && <0.1.2.0 || >0.1.2.0
opaleye <0.3.1.1 || >0.3.1.1 && <0.5.2.1 || >0.5.2.1
opaleye-sqlite <0.0.0.0 || >0.0.0.0
open-union <0.1.0.0 || >0.1.0.0
opench-meteo <0.1.0.0 || >0.1.0.0 && <0.1.1.0 || >0.1.1.0 && <0.2.0.1 || >0.2.0.1
opml-conduit <0.4.0.0 || >0.4.0.0
optparse-generic <1.0.0 || >1.0.0 && <1.1.2 || >1.1.2
orgstat <0.1.0 || >0.1.0
overloaded-records <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0
pagerduty ==0.0.4.* || >0.0.5
pandoc <1.14 || >1.14 && <1.14.0.1 || >1.14.0.1 && <1.14.0.2 || >1.14.0.2 && <1.14.0.3 || >1.14.0.3 && <1.14.0.4 || >1.14.0.4 && <1.15 || >1.15 && <1.15.0.1 || >1.15.0.1
pandoc-crossref >=0.1.6.5 && <0.2 || ==0.2.1.3 || ==0.2.2.1 || ==0.2.3.0 || ==0.2.4.2 || >=0.2.5 && <0.3 || ==0.3.0.2 || ==0.3.0.3 || >=0.3.1
pandoc-types <1.19 || >1.19
parameterized <0.1.0.0 || >0.1.0.0
paramtree >=0.1.1
parser241 <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
path-extra <0.0.0 || >0.0.0 && <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2
paypal-adaptive-hoops <0.5.0.0 || >0.5.0.0 && <0.5.1.0 || >0.5.1.0 && <0.5.2.0 || >0.5.2.0 && <0.5.3.0 || >0.5.3.0 && <0.6.0.0 || >0.6.0.0 && <0.7.0.0 || >0.7.0.0 && <0.8.0.0 || >0.8.0.0 && <0.9.0.0 || >0.9.0.0
pcgen <1.0.0 || >1.0.0
pcre-utils <0.1.6 || >0.1.6 && <0.1.7 || >0.1.7 && <0.1.8 || >0.1.8
penrose <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
perfect-hash-generator <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3 && <0.1.0.4 || >0.1.0.4 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.0.3 || >0.2.0.3 && <0.2.0.4 || >0.2.0.4 && <0.2.0.5 || >0.2.0.5
persistent <1.2.3.1 || >1.2.3.1 && <2.0.0 || >2.0.0 && <2.0.0.1 || >2.0.0.1 && <2.0.1 || >2.0.1 && <2.0.1.1 || >2.0.1.1 && <2.0.2 || >2.0.2 && <2.0.3 || >2.0.3 && <2.0.3.1 || >2.0.3.1 && <2.0.4 || >2.0.4 && <2.0.5 || >2.0.5 && <2.0.5.1 || >2.0.5.1 && <2.0.7 || >2.0.7 && <2.0.7.1 || >2.0.7.1 && <2.0.8 || >2.0.8 && <2.7.2 || >2.7.2
persistent-mongoDB <1.3.0 || >1.3.0 && <1.3.1 || >1.3.1 && <1.4.4 || >1.4.4 && <1.4.4.1 || >1.4.4.1 && <1.4.4.2 || >1.4.4.2 && <2.0.0 || >2.0.0 && <2.0.0.1 || >2.0.0.1 && <2.0.0.2 || >2.0.0.2 && <2.0.1 || >2.0.1 && <2.0.2 || >2.0.2 && <2.0.3 || >2.0.3 && <2.0.3.1 || >2.0.3.1 && <2.0.4 || >2.0.4 && <2.0.5 || >2.0.5 && <2.0.6 || >2.0.6 && <2.0.7 || >2.0.7 && <2.0.8 || >2.0.8 && <2.0.8.1 || >2.0.8.1 && <2.0.9 || >2.0.9
persistent-mysql <2.0.0 || >2.0.0 && <2.0.1 || >2.0.1 && <2.0.3 || >2.0.3 && <2.0.4 || >2.0.4 && <2.0.5 || >2.0.5
persistent-postgresql <2.0.0 || >2.0.0 && <2.0.1 || >2.0.1 && <2.0.3 || >2.0.3 && <2.0.4 || >2.0.4 && <2.0.4.1 || >2.0.4.1 && <2.0.5 || >2.0.5
persistent-redis <2.5.0 || >2.5.0 && <2.5.1 || >2.5.1
persistent-sqlite <2.0.0 || >2.0.0 && <2.0.0.1 || >2.0.0.1 && <2.0.1 || >2.0.1 && <2.0.3 || >2.0.3 && <2.0.4 || >2.0.4 && <2.0.5 || >2.0.5 && <2.6.3.2 || >2.6.3.2
persistent-template <2.0.0 || >2.0.0 && <2.0.0.1 || >2.0.0.1 && <2.0.0.2 || >2.0.0.2 && <2.0.0.3 || >2.0.0.3 && <2.0.1 || >2.0.1 && <2.0.2 || >2.0.2 && <2.0.2.1 || >2.0.2.1 && <2.0.2.2 || >2.0.2.2 && <2.0.3 || >2.0.3 && <2.0.3.1 || >2.0.3.1 && <2.0.3.2 || >2.0.3.2 && <2.0.4 || >2.0.4 && <2.1.3.2 || >2.1.3.2 && <2.1.3.5 || >2.1.3.5
peyotls-codec <0.3.1.1 || >0.3.1.1
pg <0.5.2.1 || >0.5.2.1
pgdl <6.2 || >6.2 && <6.3 || >6.3 && <6.4 || >6.4 && <9.0 || >9.0
phone-metadata <0.0.1.3 || >0.0.1.3
pinch <0.1.0.0 || >0.1.0.0
pipe-enumerator <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0
pipes-bgzf <0.2.0.0 || >0.2.0.0
pipes-cacophony >=0.5
pipes-category <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1
pipes-cereal <0.1.0.0 || >0.1.0.0
pipes-cereal-plus <0.3.0 || >0.3.0
pipes-errors <0.1 || >0.1 && <0.2 || >0.2
pipes-fluid <0.3.0.0 || >0.3.0.0 && <0.3.1.0 || >0.3.1.0 && <0.4.0.0 || >0.4.0.0 && <0.5.0.0 || >0.5.0.0 && <0.5.0.2 || >0.5.0.2 && <0.5.0.3 || >0.5.0.3
pipes-misc <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.1.1 || >0.2.1.1 && <0.2.2.0 || >0.2.2.0 && <0.2.2.1 || >0.2.2.1 && <0.2.3.0 || >0.2.3.0 && <0.2.4.0 || >0.2.4.0 && <0.2.5.0 || >0.2.5.0 && <0.3.0.0 || >0.3.0.0 && <0.4.0.0 || >0.4.0.0
pipes-p2p <0.1 || >0.1 && <0.2 || >0.2 && <0.3 || >0.3
pipes-p2p-examples <0.1 || >0.1 && <0.2 || >0.2
pipes-parse <3.0.0 || >3.0.0
plot-gtk-ui <0.0.1.0 || >0.0.1.0 && <0.0.2.0 || >0.0.2.0 && <0.0.3.0 || >0.0.3.0
plot-lab <0.0.1.6 || >0.0.1.6 && <0.0.1.7 || >0.0.1.7
plot-light <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3 && <0.1.0.4 || >0.1.0.4 && <0.1.0.5 || >0.1.0.5 && <0.1.0.6 || >0.1.0.6 && <0.1.0.7 || >0.1.0.7 && <0.1.0.8 || >0.1.0.8 && <0.1.0.9 || >0.1.0.9 && <0.1.1 || >0.1.1 && <0.1.2 || >0.1.2 && <0.2 || >0.2 && <0.2.1 || >0.2.1 && <0.2.2 || >0.2.2 && <0.2.3 || >0.2.3 && <0.2.4 || >0.2.4 && <0.2.5 || >0.2.5 && <0.2.6 || >0.2.6 && <0.2.7 || >0.2.7 && <0.2.9 || >0.2.9 && <0.3 || >0.3 && <0.3.1 || >0.3.1 && <0.3.2 || >0.3.2 && <0.3.2.1 || >0.3.2.1 && <0.3.3 || >0.3.3 && <0.3.3.1 || >0.3.3.1 && <0.3.3.2 || >0.3.3.2 && <0.4 || >0.4 && <0.4.1 || >0.4.1 && <0.4.2 || >0.4.2
poly-arity <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3 && <0.0.4 || >0.0.4 && <0.0.4.1 || >0.0.4.1 && <0.0.5 || >0.0.5 && <0.0.6 || >0.0.6
polyvariadic <0.3.0.0 || >0.3.0.0 && <0.3.0.1 || >0.3.0.1 && <0.3.0.2 || >0.3.0.2
posix-pty >=0.2.1
possible <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2
postgresql-libpq <0.9.1.0 || >0.9.1.0
postgresql-orm <0.2 || >0.2 && <0.2.1 || >0.2.1
postgresql-simple <0.4.1.0 || >0.4.1.0 && <0.4.2.0 || >0.4.2.0 && <0.4.3.0 || >0.4.3.0 && <0.4.4.0 || >0.4.4.0 && <0.5.0.0 || >0.5.0.0
potoki-core <0.9 || >0.9 && <0.9.1 || >0.9.1
praglude <0.4.0.0 || >0.4.0.0
pred-set <0.0.0 || >0.0.0
pred-trie <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3 && <0.0.4 || >0.0.4 && <0.0.5 || >0.0.5 && <0.0.6 || >0.0.6 && <0.0.6.1 || >0.0.6.1 && <0.0.7 || >0.0.7 && <0.0.7.1 || >0.0.7.1 && <0.0.8 || >0.0.8 && <0.0.8.1 || >0.0.8.1 && <0.0.9 || >0.0.9 && <0.0.10 || >0.0.10 && <0.0.10.1 || >0.0.10.1 && <0.0.10.2 || >0.0.10.2 && <0.0.11 || >0.0.11 && <0.0.12 || >0.0.12 && <0.1 || >0.1 && <0.2.0 || >0.2.0 && <0.2.1 || >0.2.1 && <0.2.3 || >0.2.3 && <0.2.4 || >0.2.4 && <0.3.0 || >0.3.0 && <0.4.0 || >0.4.0 && <0.4.1 || >0.4.1
prelude-compat <0.0 || >0.0
present <2.0 || >2.0
pretty-types <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3
prettyprinter <0.1 || >0.1
prettyprinter-ansi-terminal <0.1 || >0.1
prettyprinter-compat-annotated-wl-pprint <0.1 || >0.1
prettyprinter-compat-ansi-wl-pprint <0.1 || >0.1
prettyprinter-compat-wl-pprint ==0.* || >1
primitive <0.6 || >0.6 && <0.6.2.0 || >0.6.2.0 && <0.6.3.0 || >0.6.3.0
prizm <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3 && <0.1.0.4 || >0.1.0.4 && <0.2.0.0 || >0.2.0.0 && <0.2.1.0 || >0.2.1.0 && <0.3.0.0 || >0.3.0.0 && <0.3.1.0 || >0.3.1.0 && <0.3.1.1 || >0.3.1.1 && <1.0.0 || >1.0.0 && <1.0.1 || >1.0.1 && <1.0.2 || >1.0.2 && <1.0.3 || >1.0.3 && <1.0.4 || >1.0.4 && <1.0.5 || >1.0.5
process-extras <0.7 || >0.7
prompt <0.1.1.1 || >0.1.1.1
protolude >0.1.9
pseudo-trie <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3 && <0.0.4 || >0.0.4 && <0.0.4.1 || >0.0.4.1
qchas <1.0.0 || >1.0.0 && <1.0.1.0 || >1.0.1.0
quickcheck-classes <0.1 || >0.1 && <0.2 || >0.2 && <0.3 || >0.3 && <0.3.1 || >0.3.1 && <0.3.2 || >0.3.2 && <0.3.3 || >0.3.3 && <0.4.11 || >0.4.11
random <1.0.1.3 || >1.0.1.3
random-bytestring <0.0.1 || >0.0.1
random-class <0.1.0.0 || >0.1.0.0 && <0.1.1.0 || >0.1.1.0
rank-product <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3
rawstring-qm <0.1.5 || >0.1.5 && <0.2.0 || >0.2.0 && <0.2.1 || >0.2.1 && <0.2.2 || >0.2.2
reactive-banana <1.0.0.0 || >1.0.0.0 && <1.0.0.1 || >1.0.0.1
readcsv <0.1 || >0.1
record <0.2.2 || >0.2.2
reddit <0.2.2.0 || >0.2.2.0 && <0.2.2.1 || >0.2.2.1
reedsolomon <0.0.1.0 || >0.0.1.0 && <0.0.1.1 || >0.0.1.1 && <0.0.1.2 || >0.0.1.2 && <0.0.2.0 || >0.0.2.0 && <0.0.4.1 || >0.0.4.1
ref <0.1.0.0 || >0.1.0.0
regex <0.10.0.0 || >0.10.0.0 && <0.10.0.1 || >0.10.0.1
regex-do <1.0 || >1.0 && <1.1 || >1.1 && <1.3 || >1.3 && <1.4 || >1.4 && <1.5 || >1.5 && <1.6 || >1.6 && <1.7 || >1.7 && <1.8 || >1.8 && <1.9 || >1.9 && <2.0 || >2.0 && <2.1 || >2.1 && <2.2 || >2.2 && <2.3 || >2.3 && <2.4 || >2.4 && <2.5 || >2.5 && <2.6 || >2.6 && <2.6.1 || >2.6.1 && <2.6.2 || >2.6.2 && <3.0 || >3.0 && <3.0.1 || >3.0.1 && <3.1 || >3.1
regex-examples <0.10.0.0 || >0.10.0.0 && <0.10.0.1 || >0.10.0.1
regex-with-pcre <0.10.0.0 || >0.10.0.0 && <0.10.0.1 || >0.10.0.1
relapse >=1.0.0.0
relational-query <0.8.3.9 || >0.8.3.9
relational-query-HDBC <0.6.1.0 || >0.6.1.0
relational-record-examples <0.3.1.2 || >0.3.1.2 && <0.3.1.3 || >0.3.1.3 && <0.3.1.4 || >0.3.1.4
remote-monad <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
repa-v4l2 >=0.2
reroute <0.3.0.1 || >0.3.0.1
rest-gen <0.12 || >0.12
rivet-core <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
roller <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1
rose-trees <0.0.1 || >0.0.1 && <0.0.1.1 || >0.0.1.1 && <0.0.2 || >0.0.2 && <0.0.2.1 || >0.0.2.1
rot13 <=0.1.0.2 || >0.2.0.0
rss-conduit <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.3.1.0 || >0.3.1.0 && <0.3.1.1 || >0.3.1.1 && <0.4.2.0 || >0.4.2.0
rts-loader <0.0.0.0 || >0.0.0.0 && <0.0.0.1 || >0.0.0.1 && <0.0.0.2 || >0.0.0.2
sasl <0.0.0.2 || >0.0.0.2
sbv <0.9 || >0.9 && <0.9.1 || >0.9.1 && <0.9.2 || >0.9.2 && <0.9.3 || >0.9.3 && <0.9.4 || >0.9.4 && <0.9.5 || >0.9.5 && <0.9.6 || >0.9.6 && <0.9.7 || >0.9.7 && <0.9.8 || >0.9.8 && <0.9.9 || >0.9.9 && <0.9.10 || >0.9.10 && <0.9.11 || >0.9.11 && <0.9.12 || >0.9.12 && <0.9.13 || >0.9.13 && <0.9.14 || >0.9.14 && <0.9.15 || >0.9.15 && <0.9.16 || >0.9.16 && <0.9.17 || >0.9.17 && <0.9.18 || >0.9.18 && <0.9.19 || >0.9.19 && <0.9.20 || >0.9.20 && <0.9.21 || >0.9.21 && <0.9.22 || >0.9.22 && <0.9.23 || >0.9.23 && <0.9.24 || >0.9.24 && <1.0 || >1.0 && <1.1 || >1.1 && <1.2 || >1.2 && <1.3 || >1.3 && <1.4 || >1.4 && <2.0 || >2.0 && <2.1 || >2.1 && <2.2 || >2.2 && <2.3 || >2.3 && <2.4 || >2.4 && <2.5 || >2.5 && <2.6 || >2.6 && <2.7 || >2.7 && <2.8 || >2.8 && <2.9 || >2.9 && <2.10 || >2.10 && <3.0 || >3.0 && <3.1 || >3.1 && <3.2 || >3.2 && <3.3 || >3.3 && <3.4 || >3.4 && <3.5 || >3.5 && <4.0 || >4.0 && <4.1 || >4.1 && <4.2 || >4.2 && <4.3 || >4.3 && <4.4 || >4.4 && <5.0 || >5.0 && <5.1 || >5.1 && <5.2 || >5.2 && <5.3 || >5.3 && <5.4 || >5.4 && <5.5 || >5.5 && <5.6 || >5.6 && <5.7 || >5.7 && <5.8 || >5.8 && <5.9 || >5.9 && <5.10 || >5.10 && <5.11 || >5.11 && <5.12 || >5.12 && <5.13 || >5.13 && <5.14 || >5.14 && <5.15 || >5.15
sbvPlugin <0.1 || >0.1 && <0.2 || >0.2 && <0.3 || >0.3 && <0.4 || >0.4 && <0.5 || >0.5 && <0.6 || >0.6 && <0.7 || >0.7
scalendar <1.2.0 || >1.2.0
schedule-planner <0.1.0.1 || >0.1.0.1
sci-ratio <0.2.0.0 || >0.2.0.0
scotty >0.5.0
sdl2 <2.3.0.1 || >2.3.0.1
sdl2-compositor <1.2 || >1.2 && <1.2.0.1 || >1.2.0.1 && <1.2.0.3 || >1.2.0.3 && <1.2.0.4 || >1.2.0.4
selda <0.1.1.0 || >0.1.1.0 && <0.1.3.0 || >0.1.3.0 && <0.1.3.1 || >0.1.3.1 && <0.1.3.2 || >0.1.3.2 && <0.1.4.0 || >0.1.4.0 && <0.1.10.0 || >0.1.10.0 && <0.1.11.0 || >0.1.11.0 && <0.1.11.1 || >0.1.11.1 && <0.1.12 || >0.1.12
semigroupoids <4.5 || >4.5
seqalign <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.0.3 || >0.2.0.3
seqid <0.3.0 || >0.3.0 && <0.4.0 || >0.4.0
serokell-util <0.1.2.1 || >0.1.2.1 && <0.1.2.2 || >0.1.2.2
servant-auth-cookie <0.4.1 || >0.4.1 && <0.5.0 || >0.5.0 && <0.5.0.6 || >0.5.0.6
servant-auth-server <0.2.2.0 || >0.2.2.0
servant-auth-token <0.3.0.0 || >0.3.0.0 && <0.4.6.0 || >0.4.6.0
servant-auth-token-api <0.3.0.0 || >0.3.0.0
servant-docs <0.10.0.1 || >0.10.0.1
servant-pagination >=2.1.0
servant-proto-lens <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
servant-static-th <0.2.0.0 || >0.2.0.0
serviette >=0.1.0.6
sets <0.0.1 || >0.0.1 && <0.0.1.1 || >0.0.1.1 && <0.0.2 || >0.0.2 && <0.0.2.1 || >0.0.2.1 && <0.0.2.2 || >0.0.2.2 && <0.0.2.3 || >0.0.2.3 && <0.0.3 || >0.0.3 && <0.0.4 || >0.0.4
sexp-grammar <1.0.0 || >1.0.0 && <1.1.0 || >1.1.0 && <1.2.0 || >1.2.0 && <1.2.0.1 || >1.2.0.1 && <1.2.4 || >1.2.4
shadower >=0.1.0.6
shellmate <0.3.2 || >0.3.2 && <0.3.2.1 || >0.3.2.1 && <0.3.4 || >0.3.4
shelly <1.5 || >1.5 && <1.5.3 || >1.5.3
signal <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
simple-effects <0.9.0.0 || >0.9.0.0
sized-vector <1.3.1.0 || >1.3.1.0
skylighting <0.3.5 || >0.3.5
smallcheck-laws <0.1 || >0.1 && <0.2 || >0.2
snap-utils <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1
soap >0.2.3.4
socket <0.1.0.0 || >0.1.0.0 && <0.4.0.0 || >0.4.0.0
sparkle <0.5 || >0.5
sparse-linear-algebra <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.3 || >0.1.0.3 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.2.0.2 || >0.2.0.2 && <0.2.0.3 || >0.2.0.3 && <0.2.0.4 || >0.2.0.4 && <0.2.0.5 || >0.2.0.5 && <0.2.0.7 || >0.2.0.7 && <0.2.0.8 || >0.2.0.8 && <0.2.0.9 || >0.2.0.9 && <0.2.1.0 || >0.2.1.0 && <0.2.1.1 || >0.2.1.1 && <0.2.2.0 || >0.2.2.0 && <0.2.9 || >0.2.9 && <0.2.9.1 || >0.2.9.1 && <0.2.9.2 || >0.2.9.2 && <0.2.9.3 || >0.2.9.3 && <0.2.9.8 || >0.2.9.8 && <0.2.9.9 || >0.2.9.9
splay <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3
stack <9.9.9 || >9.9.9
stm-extras <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
store <0.4.0 || >0.4.0
streaming-bytestring <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.0.7 || >0.1.0.7
streaming-concurrency <0.2.0.0 || >0.2.0.0
streaming-postgresql-simple <0.2.0.2 || >0.2.0.2
string-transform <0.1.0 || >0.1.0
stripe <0.3.0.1 || >0.3.0.1
stylish-cabal <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0 && <0.3.0.0 || >0.3.0.0 && <0.4.0.0 || >0.4.0.0
svg-tree <0.3.2.2 || >0.3.2.2
table-layout <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0 && <0.3.0.0 || >0.3.0.0 && <0.4.0.0 || >0.4.0.0 && <0.4.0.1 || >0.4.0.1 && <0.5.0.0 || >0.5.0.0
taco <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0 && <0.3.0.0 || >0.3.0.0
tai64 <0.1.0 || >0.1.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.3 || >0.1.0.3
tar <0.4.3.0 || >0.4.3.0 && <0.4.4.0 || >0.4.4.0
task-distribution <0.1.0.1 || >0.1.0.1
tasty-laws <0.2 || >0.2 && <0.3 || >0.3
tasty-rerun >=1.1.0
tasty-stats <0.1.0.0 || >0.1.0.0
tasty-th <0.1.5 || >0.1.5 && <0.1.6 || >0.1.6
tasty-travis >=0.1.2
telegram-api <0.1.0.0 || >0.1.0.0
termbox-bindings >0.1.0.4
terminal-progress-bar <0.1.2 || >0.1.2
texbuilder <0.1.0.1 || >0.1.0.1 && <0.1.1.0 || >0.1.1.0 && <0.1.1.1 || >0.1.1.1 && <0.1.1.2 || >0.1.1.2 && <0.1.1.3 || >0.1.1.3 && <0.1.2.0 || >0.1.2.0
texmath <0.6.5.1 || >0.6.5.1 && <0.6.7 || >0.6.7 && <0.9.2 || >0.9.2
text-all <0.4.1.0 || >0.4.1.0
th-printf <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0 && <0.2.0.1 || >0.2.0.1 && <0.3.0.0 || >0.3.0.0 && <0.3.1 || >0.3.1
thorn >=0.1.0.3
thread-local-storage <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2
throttled-io-loop <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
thyme <0.3.5.0 || >0.3.5.0
tighttp <0.0.0.4 || >0.0.0.4
timemap <0.0.0 || >0.0.0 && <0.0.1 || >0.0.1
timeprint <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2
timerep <2.0.0.1 || >2.0.0.1
timezone-series <0.1.6 || >0.1.6
transformers <0.1.0.0 || >0.1.0.0 && <0.2.2.0 || >0.2.2.0 && <0.4.0.0 || >0.4.0.0 && <0.5.0.2 || >0.5.0.2 && <0.5.3.0 || >0.5.3.0 && <0.5.3.1 || >0.5.3.1
tries <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3
tslogger <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
ttrie <0.1.0.0 || >0.1.0.0
twitter-conduit <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.2.1 || >0.0.2.1 && <0.0.3 || >0.0.3 && <0.0.4 || >0.0.4 && <0.0.5 || >0.0.5 && <0.0.5.1 || >0.0.5.1 && <0.0.5.2 || >0.0.5.2 && <0.0.5.3 || >0.0.5.3 && <0.0.5.4 || >0.0.5.4 && <0.0.5.5 || >0.0.5.5
txt <0.0.0.0 || >0.0.0.0 && <0.0.2.0 || >0.0.2.0
type-natural <0.0.1.0 || >0.0.1.0 && <0.2.1.0 || >0.2.1.0 && <0.2.1.1 || >0.2.1.1 && <0.2.1.2 || >0.2.1.2 && <0.2.1.3 || >0.2.1.3 && <0.2.1.4 || >0.2.1.4 && <0.2.3.0 || >0.2.3.0 && <0.4.0.0 || >0.4.0.0 && <0.4.1.0 || >0.4.1.0 && <0.7.0.0 || >0.7.0.0
type-tree <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0
typed-spreadsheet <1.0.1 || >1.0.1
typelits-witnesses <0.1.3.0 || >0.1.3.0
typerbole >=1.0.0.0
unboxed-ref <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0
universum >=1.1.0
unix-compat <0.4.3.0 || >0.4.3.0
unix-time <0.1.10 || >0.1.10
unsafely <0.1.0.0 || >0.1.0.0
up-grade <0.0.1 || >0.0.1
urlpath <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3 && <0.0.4 || >0.0.4 && <0.0.5 || >0.0.5 && <0.0.6 || >0.0.6 && <0.1 || >0.1 && <0.1.0.1 || >0.1.0.1 && <0.2 || >0.2 && <1.0.0 || >1.0.0 && <1.1.0 || >1.1.0 && <2.0.0 || >2.0.0 && <2.1.0 || >2.1.0 && <3.0.0 || >3.0.0 && <3.1.0 || >3.1.0 && <3.1.1 || >3.1.1 && <3.2.0 || >3.2.0 && <3.2.1 || >3.2.1 && <3.2.1.1 || >3.2.1.1 && <3.3.0 || >3.3.0 && <4.0.0 || >4.0.0 && <4.0.0.1 || >4.0.0.1 && <4.1.0 || >4.1.0 && <4.2.0 || >4.2.0 && <5.0.0 || >5.0.0
uuid-crypto <1.2.0.0 || >1.2.0.0
validated-literals <0.1.0 || >0.1.0
varying >0.1.1.1
vector <0.10.9.3 || >0.10.9.3 && <0.10.12.0 || >0.10.12.0
vector-binary-instances <0.2.3.0 || >0.2.3.0
vector-instances <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.2.1 || >0.0.2.1 && <0.1.0 || >0.1.0 && <0.1.0.1 || >0.1.0.1
vector-th-unbox >=0.2.1 && <0.2.1.0 || >0.2.1.0 && <0.2.1.1 || >0.2.1.1 && <0.2.1.2 || >0.2.1.2
vectortiles <1.2.0.3 || >1.2.0.3
versions <3.0.1 || >3.0.1 && <3.1.0 || >3.1.0
vinyl-gl <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.2 || >0.1.2 && <0.1.3 || >0.1.3 && <0.1.3.1 || >0.1.3.1
vty <5.12 || >5.12
vulkan <0.1.0.0 || >0.1.0.0 && <0.2.0.0 || >0.2.0.0 && <1.0.0.0 || >1.0.0.0 && <1.2.0.0 || >1.2.0.0 && <1.3.0.0 || >1.3.0.0 && <1.3.1.0 || >1.3.1.0 && <1.3.2.0 || >1.3.2.0 && <1.5.0.0 || >1.5.0.0 && <1.5.1.0 || >1.5.1.0 && <1.6.0.0 || >1.6.0.0 && <1.7.0.0 || >1.7.0.0
vulkan-api <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <1.1.0.0 || >1.1.0.0
wai-accept-language <0.1.0.0 || >0.1.0.0
wai-extra <3.0.10.1 || >3.0.10.1
wai-middleware-content-type <0.0.0 || >0.0.0 && <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3 && <0.0.3.1 || >0.0.3.1 && <0.0.3.2 || >0.0.3.2 && <0.0.3.3 || >0.0.3.3 && <0.0.4 || >0.0.4 && <0.1.0 || >0.1.0 && <0.1.0.1 || >0.1.0.1 && <0.1.1 || >0.1.1 && <0.1.1.1 || >0.1.1.1 && <0.2.0 || >0.2.0 && <0.2.1 || >0.2.1 && <0.3.0 || >0.3.0
wai-middleware-verbs <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3 && <0.0.4 || >0.0.4 && <0.0.5 || >0.0.5 && <0.1.0 || >0.1.0 && <0.1.1 || >0.1.1
wai-transformers <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2
wai-util <0.1 || >0.1 && <0.2 || >0.2 && <0.3 || >0.3 && <0.4 || >0.4 && <0.5 || >0.5 && <0.6 || >0.6
warp <3.2.4 || >3.2.4
webapi <0.1.0.0 || >0.1.0.0
webapp >=0.6.1
webdriver >=0.6 && <0.6.3 || >0.6.3 && <0.8 || >0.8 && <0.8.0.1 || >0.8.0.1 && <0.8.0.2 || >0.8.0.2
webpage <0.0.1 || >0.0.1 && <0.0.2 || >0.0.2 && <0.0.3 || >0.0.3 && <0.0.3.1 || >0.0.3.1
websockets <0.9.8.0 || >0.9.8.0
witherable <0.1.3.1 || >0.1.3.1
word <0.1.0.0 || >0.1.0.0
word12 <1.0.0 || >1.0.0
writer-cps-lens <0.1.0.0 || >0.1.0.0
writer-cps-morph <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1
xdcc <1.0.0 || >1.0.0 && <1.0.5 || >1.0.5 && <1.1.0 || >1.1.0 && <1.1.1 || >1.1.1
xml-conduit <1.7.1.0 || >1.7.1.0 && <1.7.1.1 || >1.7.1.1
xmlbf >=0.4
xxhash-ffi <0.1.0.0 || >0.1.0.0
yam-app >=0.2.0
yam-config <0.3.0 || >0.3.0
yam-job >=0.2.0
yam-logger <0.3.0 || >0.3.0
yam-servant >=0.2.0
yam-transaction <0.3.0 || >0.3.0
yam-transaction-odbc <0.1.0.0 || >0.1.0.0 && <0.1.0.1 || >0.1.0.1 && <0.1.0.2 || >0.1.0.2 && <0.1.3 || >0.1.3 && <0.1.4 || >0.1.4 && <0.1.5 || >0.1.5 && <0.1.6 || >0.1.6 && <0.1.7 || >0.1.7
yam-transaction-postgresql >=0.2.0
yam-web <0.3.0 || >0.3.0
yaml-light-lens <0.3.1.8 || >0.3.1.8
yesod-bin <1.5.0 || >1.5.0
yocto >=1
zifter <0.0.0.0 || >0.0.0.0
zip-archive <0.2.3 || >0.2.3 && <0.2.3.1 || >0.2.3.1
strategy: PreferLatestForSelected
reorder goals: False
count conflicts: True
independent goals: False
avoid reinstalls: False
shadow packages: False
strong flags: False
allow boot library installs: False
max backjumps: 2000
[__0] trying: cabal-plan-0.1.1.0 (user goal)
[__1] next goal: base (dependency of cabal-plan)
[__1] rejecting: base-4.10.1.0/installed-4.1... (conflict: cabal-plan => base>=4.6 && <4.10)
[__1] rejecting: base-4.10.0.0, base-4.9.1.0, base-4.9.0.0, base-4.8.2.0, base-4.8.1.0, base-4.8.0.0, base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1, base-4.6.0.0, base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0, base-4.3.1.0, base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0, base-4.1.0.0, base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from non-upgradeable package requires installed instance)
[__1] fail (backjumping, conflict set: base, cabal-plan)
[__0] trying: cabal-plan-0.1.0.0
[__1] next goal: base (dependency of cabal-plan)
[__1] rejecting: base-4.10.1.0/installed-4.1... (conflict: cabal-plan => base>=4.6 && <4.10)
[__1] rejecting: base-4.10.0.0, base-4.9.1.0, base-4.9.0.0, base-4.8.2.0, base-4.8.1.0, base-4.8.0.0, base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1, base-4.6.0.0, base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0, base-4.3.1.0, base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0, base-4.1.0.0, base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from non-upgradeable package requires installed instance)
[__0] fail (backjumping, conflict set: base, cabal-plan)
CallStack (from HasCallStack):
die', called at ./Distribution/Client/Install.hs:238:21 in main:Distribution.Client.Install
cabal: Could not resolve dependencies:
[__0] trying: cabal-plan-0.1.1.0 (user goal)
[__1] next goal: base (dependency of cabal-plan)
[__1] rejecting: base-4.10.1.0/installed-4.1... (conflict: cabal-plan =>
base>=4.6 && <4.10)
[__1] rejecting: base-4.10.0.0, base-4.9.1.0, base-4.9.0.0, base-4.8.2.0,
base-4.8.1.0, base-4.8.0.0, base-4.7.0.2, base-4.7.0.1, base-4.7.0.0,
base-4.6.0.1, base-4.6.0.0, base-4.5.1.0, base-4.5.0.0, base-4.4.1.0,
base-4.4.0.0, base-4.3.1.0, base-4.3.0.0, base-4.2.0.2, base-4.2.0.1,
base-4.2.0.0, base-4.1.0.0, base-4.0.0.0, base-3.0.3.2, base-3.0.3.1
(constraint from non-upgradeable package requires installed instance)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: base (52), cabal-plan (5)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.