Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
Enable 9650SE-2LP RAID controller on VMware ESXi 5.0.0
# download 3ware 9650SE-2LP vib from http://kb.lsi.com/KnowledgebaseArticle15753.aspx#vmware
# ftp://tsupport:tsupport@ftp0.lsil.com/private/3Ware/kbarticledrivers/scsi-3w-9xxx-3.26.08.036-1OEM.500.0.0.406165.x86_64.vib
# Upload the vib to the datastore on the ESXi host
# Put the ESXi host into maintenance mode
# Enable ssh on the ESXi host from within vSphere Client
# ssh to the ESXi host and run:
esxcli software vib install --no-sig-check -v /vmfs/volumes/datastore1/scsi-3w-9xxx-3.26.08.036-1OEM.500.0.0.406165.x86_64.vib
# Disable maintenance mode
@richardpowellus

This comment has been minimized.

Copy link

@richardpowellus richardpowellus commented Jan 23, 2012

Thanks for this. I was wondering how I would get my 3ware device to work with ESXi 5.0. By the way, is this a beta driver or are you just using the 4.1 driver on 5.0?

@cdwilson

This comment has been minimized.

Copy link
Owner Author

@cdwilson cdwilson commented Jan 26, 2012

Hey dprus, sorry, didn't see this till now. It looks like they took the 5.0 driver down for some reason... check out http://communities.vmware.com/message/1856418 for a link to download it again ( ftp://tsupport:tsupport@ftp0.lsil.com/private/3Ware/kbarticledrivers/scsi-3w-9xxx-3.26.08.036-1OEM.500.0.0.406165.x86_64.vib )

I've actually not tested this since vanilla ESXi came out and from the forum it looks like they might have removed support for it in an update? Let me know how things go for you on this, I'm curious as to what the official support will be.

@cdwilson

This comment has been minimized.

Copy link
Owner Author

@cdwilson cdwilson commented Mar 29, 2012

@cdwilson

This comment has been minimized.

Copy link
Owner Author

@cdwilson cdwilson commented Mar 30, 2012

@cdwilson

This comment has been minimized.

Copy link
Owner Author

@cdwilson cdwilson commented Sep 6, 2013

See https://github.com/cdwilson/esxi-3ware for an automated ESXi ISO builder

@KlausHuber

This comment has been minimized.

Copy link

@KlausHuber KlausHuber commented Apr 5, 2017

Anybody got the 9650SE working on ESXi 6.5?
I'm getting an error like:
VIB ... requires vmkapi_2_0_0_0, but the requirement cannotbe satisfied within the ImageProfile.
and
VIB ... requires com.vmware.driverAPI-9.2.0.0, but the requirement cannotbe satisfied within the ImageProfile.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.