Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
`bundle install` with OJ gem fails on jruby-1.7.0
jruby 1.7.0 (1.9.3p203) 2012-10-22 ff1ebbe on Java HotSpot(TM) 64-Bit Server VM 1.6.0_29-b11-402-11D50b [darwin-x86_64]
rvm info [jruby-1.7.0][master!]
jruby-1.7.0:
system:
uname: "Darwin cookrn.local 11.4.2 Darwin Kernel Version 11.4.2: Thu Aug 23 16:25:48 PDT 2012; root:xnu-1699.32.7~1/RELEASE_X86_64 x86_64"
system: "osx/10.7/x86_64"
bash: "/bin/bash => GNU bash, version 3.2.48(1)-release (x86_64-apple-darwin11)"
zsh: "/bin/zsh => zsh 4.3.11 (i386-apple-darwin11.0)"
rvm:
version: "rvm 1.16.20 () by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]"
updated: "13 minutes 47 seconds ago"
ruby:
interpreter: "jruby"
version: "1.7.0"
date: "jruby 1.7.0 (1.9.3p203) 2012-10-22 ff1ebbe on Java HotSpot(TM) 64-Bit Server VM 1.6.0_29-b11-402-11D50b [darwin-x86_64]"
platform: "darwin-x86_64"
patchlevel: "TM"
full_version: "jruby 1.7.0 (1.9.3p203) 2012-10-22 ff1ebbe on Java HotSpot(TM) 64-Bit Server VM 1.6.0_29-b11-402-11D50b [darwin-x86_64]"
homes:
gem: "/Users/cookrn/.rvm/gems/jruby-1.7.0"
ruby: "/Users/cookrn/.rvm/rubies/jruby-1.7.0"
binaries:
ruby: "/Users/cookrn/.rvm/rubies/jruby-1.7.0/bin/ruby"
irb: "/Users/cookrn/.rvm/rubies/jruby-1.7.0/bin/irb"
gem: "/Users/cookrn/.rvm/rubies/jruby-1.7.0/bin/gem"
rake: "/Users/cookrn/.rvm/gems/jruby-1.7.0@global/bin/rake"
environment:
PATH: "/Users/cookrn/.rvm/gems/jruby-1.7.0/bin:/Users/cookrn/.rvm/gems/jruby-1.7.0@global/bin:/Users/cookrn/.rvm/rubies/jruby-1.7.0/bin:/Users/cookrn/.rvm/bin:/Users/cookrn/bin:/usr/local/sbin:/usr/local/ActivePerl-5.14/site/bin:/usr/local/ActivePerl-5.14/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin"
GEM_HOME: "/Users/cookrn/.rvm/gems/jruby-1.7.0"
GEM_PATH: "/Users/cookrn/.rvm/gems/jruby-1.7.0:/Users/cookrn/.rvm/gems/jruby-1.7.0@global"
MY_RUBY_HOME: "/Users/cookrn/.rvm/rubies/jruby-1.7.0"
IRBRC: "/Users/cookrn/.rvm/rubies/jruby-1.7.0/.irbrc"
RUBYOPT: ""
gemset: ""
Installing oj (1.4.4) with native extensions
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
/Users/cookrn/.rvm/rubies/jruby-1.7.0/bin/jruby extconf.rb
/Users/cookrn/.rvm/rubies/jruby-1.7.0/lib/ruby/shared/mkmf.rb:14: Use RbConfig instead of obsolete and deprecated Config.
>>>>> Creating Makefile for jruby version 1.9.3 on darwin <<<<<
creating Makefile
make
cc -I. -I/Users/cookrn/.rvm/rubies/jruby-1.7.0/lib/native/include -I/Users/cookrn/.rvm/rubies/jruby-1.7.0/lib/native/include/ruby -I. -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -DRUBY_TYPE=jruby -DJRUBY_RUBY -DRUBY_VERSION=1.9.3 -DRUBY_VERSION_MAJOR=1 -DRUBY_VERSION_MINOR=9 -DRUBY_VERSION_MICRO=3 -DHAS_RB_TIME_TIMESPEC=0 -DHAS_ENCODING_SUPPORT=0 -DHAS_NANO_TIME=0 -DHAS_RSTRUCT=0 -DHAS_IVAR_HELPERS=0 -DHAS_EXCEPTION_MAGIC=1 -DHAS_PROC_WITH_BLOCK=0 -DHAS_TOP_LEVEL_ST_H=0 -DIS_WINDOWS=0 -DSAFE_CACHE=1 -Wall -fPIC -DTARGET_RT_MAC_CFM=0 -fno-omit-frame-pointer -fno-strict-aliasing -fexceptions -arch x86_64 -c cache.c
cc -I. -I/Users/cookrn/.rvm/rubies/jruby-1.7.0/lib/native/include -I/Users/cookrn/.rvm/rubies/jruby-1.7.0/lib/native/include/ruby -I. -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -DRUBY_TYPE=jruby -DJRUBY_RUBY -DRUBY_VERSION=1.9.3 -DRUBY_VERSION_MAJOR=1 -DRUBY_VERSION_MINOR=9 -DRUBY_VERSION_MICRO=3 -DHAS_RB_TIME_TIMESPEC=0 -DHAS_ENCODING_SUPPORT=0 -DHAS_NANO_TIME=0 -DHAS_RSTRUCT=0 -DHAS_IVAR_HELPERS=0 -DHAS_EXCEPTION_MAGIC=1 -DHAS_PROC_WITH_BLOCK=0 -DHAS_TOP_LEVEL_ST_H=0 -DIS_WINDOWS=0 -DSAFE_CACHE=1 -Wall -fPIC -DTARGET_RT_MAC_CFM=0 -fno-omit-frame-pointer -fno-strict-aliasing -fexceptions -arch x86_64 -c cache8.c
cc -I. -I/Users/cookrn/.rvm/rubies/jruby-1.7.0/lib/native/include -I/Users/cookrn/.rvm/rubies/jruby-1.7.0/lib/native/include/ruby -I. -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -DRUBY_TYPE=jruby -DJRUBY_RUBY -DRUBY_VERSION=1.9.3 -DRUBY_VERSION_MAJOR=1 -DRUBY_VERSION_MINOR=9 -DRUBY_VERSION_MICRO=3 -DHAS_RB_TIME_TIMESPEC=0 -DHAS_ENCODING_SUPPORT=0 -DHAS_NANO_TIME=0 -DHAS_RSTRUCT=0 -DHAS_IVAR_HELPERS=0 -DHAS_EXCEPTION_MAGIC=1 -DHAS_PROC_WITH_BLOCK=0 -DHAS_TOP_LEVEL_ST_H=0 -DIS_WINDOWS=0 -DSAFE_CACHE=1 -Wall -fPIC -DTARGET_RT_MAC_CFM=0 -fno-omit-frame-pointer -fno-strict-aliasing -fexceptions -arch x86_64 -c dump.c
dump.c:79: error: expected ‘)’ before ‘c’
dump.c:111: warning: type defaults to ‘int’ in declaration of ‘u_char’
dump.c:111: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
dump.c:112: warning: type defaults to ‘int’ in declaration of ‘u_char’
dump.c:112: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
dump.c:148: warning: type defaults to ‘int’ in declaration of ‘u_char’
dump.c:148: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
dump.c:158: warning: type defaults to ‘int’ in declaration of ‘u_char’
dump.c:158: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
dump.c:231: error: expected ‘)’ before ‘c’
dump.c: In function ‘dump_cstr’:
dump.c:458: warning: implicit declaration of function ‘ascii_friendly_size’
dump.c:458: error: ‘u_char’ undeclared (first use in this function)
dump.c:458: error: (Each undeclared identifier is reported only once
dump.c:458: error: for each function it appears in.)
dump.c:458: error: expected expression before ‘)’ token
dump.c:461: warning: implicit declaration of function ‘hibit_friendly_size’
dump.c:461: error: expected expression before ‘)’ token
dump.c:472: warning: implicit declaration of function ‘dump_hex’
dump.c: In function ‘hash_cb_object’:
dump.c:812: error: ‘u_char’ undeclared (first use in this function)
dump.c:812: error: expected ‘;’ before ‘b’
dump.c:822: error: ‘b’ undeclared (first use in this function)
make: *** [dump.o] Error 1
Gem files will remain installed in /Users/cookrn/Workspace/dojo4/eb_jruby/vendor/bundle/gems/oj-1.4.4 for inspection.
Results logged to /Users/cookrn/Workspace/dojo4/eb_jruby/vendor/bundle/gems/oj-1.4.4/ext/oj/gem_make.out
An error occurred while installing oj (1.4.4), and Bundler cannot continue.
Make sure that `gem install oj -v '1.4.4'` succeeds before bundling.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment