Skip to content

@darthdeus /articles_spec.rb
Created

Embed URL

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
require 'spec_helper'
describe "Articles" do
describe "POST /articles" do
it "should create an article" do
create(:category, :name => "lipsum")
visit new_article_path
fill_in "Title", :with => "Lorem Ipsum"
fill_in "Text", :with => "Lorem ipsum dolor sit amet"
select "lipsum", :from => "article_category_id"
click_button "Publish"
page.should have_content("Article published")
end
end
end
require 'spec_helper'
describe "Categories" do
describe "POST /categories" do
it "create category" do
post categories_path, :category => { :name => "foo" }, :format => :js
Category.last.name.should == "foo"
response.status.should be(200)
end
it "supports js", :js => true do
visit new_article_path
fill_in "category_name", :with => "foobar"
click_button "Add category"
page.should have_content("foobar")
end
it "focuses category form when I click 'add new category'" do
pending
visit new_article_path
click_link "add new category"
find_field("category_name").should have_focus
end
end
end
$ rspec .
No DRb server is running. Running in local process instead ...
........./Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/nokogiri.bundle: warning: already initialized constant LIBXML_VERSION
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/nokogiri.bundle: warning: already initialized constant LIBXML_PARSER_VERSION
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/nokogiri.bundle: warning: already initialized constant LIBXML_ICONV_ENABLED
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/nokogiri.bundle: warning: already initialized constant INTERNAL_GENERAL
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/nokogiri.bundle: warning: already initialized constant EXTERNAL_GENERAL_PARSED
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/nokogiri.bundle: warning: already initialized constant EXTERNAL_GENERAL_UNPARSED
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/nokogiri.bundle: warning: already initialized constant INTERNAL_PARAMETER
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/nokogiri.bundle: warning: already initialized constant EXTERNAL_PARAMETER
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/nokogiri.bundle: warning: already initialized constant INTERNAL_PREDEFINED
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/version.rb:3: warning: already initialized constant VERSION
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/version.rb:79: warning: already initialized constant VERSION_INFO
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:7: warning: already initialized constant STRICT
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:9: warning: already initialized constant RECOVER
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:11: warning: already initialized constant NOENT
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:13: warning: already initialized constant DTDLOAD
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:15: warning: already initialized constant DTDATTR
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:17: warning: already initialized constant DTDVALID
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:19: warning: already initialized constant NOERROR
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:21: warning: already initialized constant NOWARNING
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:23: warning: already initialized constant PEDANTIC
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:25: warning: already initialized constant NOBLANKS
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:27: warning: already initialized constant SAX1
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:29: warning: already initialized constant XINCLUDE
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:31: warning: already initialized constant NONET
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:33: warning: already initialized constant NODICT
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:35: warning: already initialized constant NSCLEAN
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:37: warning: already initialized constant NOCDATA
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:39: warning: already initialized constant NOXINCNODE
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:41: warning: already initialized constant COMPACT
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:43: warning: already initialized constant OLD10
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:45: warning: already initialized constant NOBASEFIX
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:47: warning: already initialized constant HUGE
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:50: warning: already initialized constant DEFAULT_XML
/Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/parse_options.rb:52: warning: already initialized constant DEFAULT_HTML
FFFFF
Failures:
1) Articles POST /articles should create an article
Failure/Error: visit new_article_path
TypeError:
superclass mismatch for class Attribute
# ./spec/requests/articles_spec.rb:7:in `block (3 levels) in <top (required)>'
2) Categories POST /categories create category
Failure/Error: Unable to find matching line from backtrace
TypeError:
superclass mismatch for class Attribute
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:33:in `<class:Parser>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:32:in `<module:SAX>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:3:in `<module:XML>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:2:in `<module:Nokogiri>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:1:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax.rb:3:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml.rb:3:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri.rb:30:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/rack_test/driver.rb:4:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara.rb:247:in `block in <top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:61:in `call'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:61:in `driver'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:70:in `reset!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `block in reset_sessions!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `reset_sessions!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/rspec.rb:16:in `block (2 levels) in <top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:340:in `instance_eval'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:340:in `instance_eval_with_rescue'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:45:in `run_in'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `block in run_all'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `run_all'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:126:in `run_hook_filtered'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:238:in `run_after_each_hooks'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:152:in `run_after_each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:57:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:110:in `with_around_hooks'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:48:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:306:in `block in run_examples'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:302:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:302:in `run_examples'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:274:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `block (2 levels) in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/reporter.rb:12:in `report'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:21:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:80:in `run_in_process'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:66:in `rescue in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:62:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:10:in `block in autorun'
3) Categories POST /categories supports js
Failure/Error: Unable to find matching line from backtrace
TypeError:
superclass mismatch for class Attribute
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:33:in `<class:Parser>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:32:in `<module:SAX>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:3:in `<module:XML>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:2:in `<module:Nokogiri>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:1:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax.rb:3:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml.rb:3:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri.rb:30:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/rack_test/driver.rb:4:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara.rb:247:in `block in <top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:61:in `call'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:61:in `driver'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:70:in `reset!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `block in reset_sessions!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `reset_sessions!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/rspec.rb:16:in `block (2 levels) in <top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:340:in `instance_eval'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:340:in `instance_eval_with_rescue'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:45:in `run_in'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `block in run_all'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `run_all'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:126:in `run_hook_filtered'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:238:in `run_after_each_hooks'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:152:in `run_after_each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:57:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:110:in `with_around_hooks'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:48:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:306:in `block in run_examples'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:302:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:302:in `run_examples'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:274:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `block (2 levels) in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/reporter.rb:12:in `report'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:21:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:80:in `run_in_process'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:66:in `rescue in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:62:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:10:in `block in autorun'
4) Categories POST /categories focuses category form when I click 'add new category'
Failure/Error: Unable to find matching line from backtrace
TypeError:
superclass mismatch for class Attribute
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:33:in `<class:Parser>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:32:in `<module:SAX>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:3:in `<module:XML>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:2:in `<module:Nokogiri>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:1:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax.rb:3:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml.rb:3:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri.rb:30:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/rack_test/driver.rb:4:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara.rb:247:in `block in <top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:61:in `call'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:61:in `driver'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:70:in `reset!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `block in reset_sessions!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `reset_sessions!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/rspec.rb:16:in `block (2 levels) in <top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:340:in `instance_eval'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:340:in `instance_eval_with_rescue'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:45:in `run_in'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `block in run_all'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `run_all'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:126:in `run_hook_filtered'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:238:in `run_after_each_hooks'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:152:in `run_after_each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:57:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:110:in `with_around_hooks'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:48:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:306:in `block in run_examples'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:302:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:302:in `run_examples'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:274:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `block (2 levels) in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/reporter.rb:12:in `report'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:21:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:80:in `run_in_process'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:66:in `rescue in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:62:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:10:in `block in autorun'
5) Users POST /users create user
Failure/Error: Unable to find matching line from backtrace
TypeError:
superclass mismatch for class Attribute
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:33:in `<class:Parser>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:32:in `<module:SAX>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:3:in `<module:XML>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:2:in `<module:Nokogiri>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax/parser.rb:1:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml/sax.rb:3:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri/xml.rb:3:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/nokogiri-1.5.0/lib/nokogiri.rb:30:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290@global/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/rack_test/driver.rb:4:in `<top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara.rb:247:in `block in <top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:61:in `call'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:61:in `driver'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/session.rb:70:in `reset!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `block in reset_sessions!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/dsl.rb:87:in `reset_sessions!'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/capybara-1.1.1/lib/capybara/rspec.rb:16:in `block (2 levels) in <top (required)>'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:340:in `instance_eval'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:340:in `instance_eval_with_rescue'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:45:in `run_in'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `block in run_all'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:80:in `run_all'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/hooks.rb:126:in `run_hook_filtered'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:238:in `run_after_each_hooks'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:152:in `run_after_each'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:57:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:110:in `with_around_hooks'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example.rb:48:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:306:in `block in run_examples'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:302:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:302:in `run_examples'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:274:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/example_group.rb:275:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `block (2 levels) in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `map'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:24:in `block in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/reporter.rb:12:in `report'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/command_line.rb:21:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:80:in `run_in_process'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:66:in `rescue in run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:62:in `run'
# /Users/darth/.rvm/gems/ruby-1.9.2-p290/gems/rspec-core-2.7.1/lib/rspec/core/runner.rb:10:in `block in autorun'
Finished in 18.39 seconds
14 examples, 5 failures
Failed examples:
rspec ./spec/requests/articles_spec.rb:5 # Articles POST /articles should create an article
rspec ./spec/requests/categories_spec.rb:5 # Categories POST /categories create category
rspec ./spec/requests/categories_spec.rb:11 # Categories POST /categories supports js
rspec ./spec/requests/categories_spec.rb:18 # Categories POST /categories focuses category form when I click 'add new category'
rspec ./spec/requests/users_spec.rb:5 # Users POST /users create user
require 'rubygems'
require 'spork'
Spork.prefork do
require 'capybara/rspec'
Capybara.javascript_driver = :webkit
# This file is copied to spec/ when you run 'rails generate rspec:install'
ENV["RAILS_ENV"] ||= 'test'
require File.expand_path("../../config/environment", __FILE__)
require 'rspec/rails'
require 'rspec/autorun'
# Requires supporting ruby files with custom matchers and macros, etc,
# in spec/support/ and its subdirectories.
Dir[Rails.root.join("spec/support/**/*.rb")].each {|f| require f}
RSpec.configure do |config|
config.mock_with :rspec
# Remove this line if you're not using ActiveRecord or ActiveRecord fixtures
# config.fixture_path = "#{::Rails.root}/spec/fixtures"
# If you're not using ActiveRecord, or you'd prefer not to run each of your
# examples within a transaction, remove the following line or assign false
# instead of true.
config.use_transactional_fixtures = false
# If true, the base class of anonymous controllers will be inferred
# automatically. This will be the default behavior in future versions of
# rspec-rails.
config.infer_base_class_for_anonymous_controllers = false
config.include Factory::Syntax::Methods
config.before(:suite) do
DatabaseCleaner.strategy = :truncation
end
config.before(:each) do
DatabaseCleaner.start
end
config.after(:each) do
DatabaseCleaner.clean
end
end
end
Spork.each_run do
# This code will be run each time you run your specs.
end
require 'spec_helper'
describe "Users" do
describe "POST /users" do
it "create user" do
post_via_redirect users_path, :user => { :username => "foobar", :email => "foobar@example.com", :password => "secret", :password_confirmation => "secret"}
response.body.should include("Signed up!")
end
end
end
@Nerian

Hi,

I am getting the same error, did you find I way to fix it?

Thanks

@darthdeus
Owner

Hi,

yes but unfortunately I don't remember the specifics. I know it was caused by two gems both defining the Attribute class and the wrong one got loaded.

If you show me your Gemfile, I might be able to recall.

@Nerian

It just fixed by some unknown reason :) Thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.