Skip to content

Instantly share code, notes, and snippets.

David Verelst davidovitch

Block or report user

Report or block davidovitch

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
@davidovitch
davidovitch / PKGBUILD
Last active Dec 24, 2015
Arch Linux PKGBUILD for python2-llvmmath-git
View PKGBUILD
# Maintainer: Augusto F Hack <hack.augusto@gmail.com>
pkgname=python2-llvmmath-git
_gitname=llvmmath
pkgver=129.37f1c2e
pkgrel=1
pkgdesc="LLVM math library - The purpose of this project is to provide portable math functions, many of which are in C99 and not available on all platforms. It is based on NumPy's umath and tries to support all floating point and complex types."
arch=('i686' 'x86_64')
url="http://github.com/ContinuumIO/llvmmath.git"
license=('BSD')
depends=('python2' 'python2-llvmpy-git')
@davidovitch
davidovitch / PKGBUILD
Created Sep 30, 2013
Arch Linux PKGBUILD for python2-shapely
View PKGBUILD
pkgname=python2-shapely
pkgver=1.2.18
pkgrel=1
pkgdesc="Geometric objects, predicates, and operations"
arch=('i686' 'x86_64')
url="https://pypi.python.org/pypi/Shapely"
license=('BSD')
depends=('python2' 'geos')
makedepends=('gcc')
optdepends=()
@davidovitch
davidovitch / PKGBUILD
Created May 16, 2014
AUR PKGBUILD for python2-jedi-git
View PKGBUILD
pkgname=python2-jedi-git
_gitname=jedi
pkgver=1
pkgrel=1
pkgdesc="Jedi is an autocompletion tool for Python that can be used in IDEs/editors"
arch=(any)
url="https://github.com/davidhalter/jedi"
license=('MIT')
depends=('python2')
makedepends=('git' 'python2-distribute')
View gist:abdb52fb8095dfd090c5
{
"metadata": {
"celltoolbar": "Slideshow",
"name": "",
"signature": "sha256:9dfcd7f6e417c1823383c42dff3907de267ae7bf64852df9bbcb72e13c2b7c14"
},
"nbformat": 3,
"nbformat_minor": 0,
"worksheets": [
{
@davidovitch
davidovitch / virtualenv-postmk-pyqt-sip
Last active Aug 29, 2015
Linux shell script to create/update a standalone virtualenv scipy-stack with symlinks to PyQt system install
View virtualenv-postmk-pyqt-sip
#!/bin/bash
# source: https://gist.github.com/jlesquembre/2042882
libs=( PyQt4 PyQt5 sip.so )
python_version=python$(python -c "import sys; print (str(sys.version_info[0])+'.'+str(sys.version_info[1]))")
var=( $(which -a $python_version) )
get_python_lib_cmd="from distutils.sysconfig import get_python_lib; print (get_python_lib())"
lib_virtualenv_path=$(python -c "$get_python_lib_cmd")
@davidovitch
davidovitch / PKGBUILD
Last active May 11, 2018
AUR nautilus-compare for python3
View PKGBUILD
# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
pkgname=nautilus-compare
pkgver=0.0.5
pkgrel=2
pkgdesc='Simple context menu file comparison extension for Nautilus 3 and above.'
arch=('any')
url="http://launchpad.net/nautilus-compare/"
license=('GPL3')
depends=('python' 'nautilus' 'python-nautilus' 'python-xdg')
You can’t perform that action at this time.