Skip to content

@daya /gist:2c63602332beead18b7a secret
Created

Embed URL

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
ip-192-168-1-126: [master]! $ ruby -v
jruby 1.6.6 (ruby-1.8.7-p357) (2012-01-30 5673572) (Java HotSpot(TM) 64-Bit Server VM 1.6.0_29) [darwin-x86_64-java]
ip-192-168-1-126: [master]! $ bundle show trinidad
/Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8/gems/trinidad-1.3.4
ip-192-168-1-126: [master]! $ bundle show mizuno
Could not find gem 'mizuno' in the current bundle.
ip-192-168-1-126: [master]! $ pwd
/Users/dayas/RubyProjects/houstonsos
ip-192-168-1-126: [master]! $ bundle exec trinidad -p 4000
Mar 13, 2012 11:30:16 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-4000"]
Mar 13, 2012 11:30:16 AM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Tomcat
Mar 13, 2012 11:30:16 AM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.23
2012-03-13 16:30:17 INFO: No global web.xml found
2012-03-13 16:30:18 INFO: jruby 1.6.6 (ruby-1.8.7-p357) (2012-01-30 5673572) (Java HotSpot(TM) 64-Bit Server VM 1.6.0_29) [darwin-x86_64-java]
=> Located locked Gemfile for development
--- RUBY_ENGINE = jruby
2012-03-13 16:30:32 INFO: Info: received min runtimes = 1
2012-03-13 16:30:32 INFO: Info: received max runtimes = 5
2012-03-13 16:30:32 INFO: An exception happened during JRuby-Rack startup
stack level too deep
--- System
jruby 1.6.6 (ruby-1.8.7-p357) (2012-01-30 5673572) (Java HotSpot(TM) 64-Bit Server VM 1.6.0_29) [darwin-x86_64-java]
Time: Tue Mar 13 11:30:32 -0500 2012
Server: Apache Tomcat/7.0.23
jruby.home: /Users/dayas/.rbenv/versions/jruby-1.6.6
--- Context Init Parameters:
jruby.compat.version = 1.8.7
jruby.initial.runtimes = 1
jruby.max.runtimes = 5
jruby.min.runtimes = 1
public.root = /public
rack.env = development
rackup.path = config.ru
--- Backtrace
SystemStackError: stack level too deep
each at org/jruby/RubyArray.java:1614
safe_load at /Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8/gems/padrino-core-0.10.5/lib/padrino-core/reloader.rb:164
require_dependencies at /Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8/gems/padrino-core-0.10.5/lib/padrino-core/loader.rb:162
each at org/jruby/RubyArray.java:1614
require_dependencies at /Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8/gems/padrino-core-0.10.5/lib/padrino-core/loader.rb:160
load! at /Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8/gems/padrino-core-0.10.5/lib/padrino-core/loader.rb:67
(root) at /Users/dayas/RubyProjects/houstonsos/config/boot.rb:33
require at org/jruby/RubyKernel.java:1027
(root) at /Users/dayas/RubyProjects/houstonsos/config/boot.rb:1
instance_eval at org/jruby/RubyKernel.java:2043
initialize at /Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8/gems/rack-1.4.1/lib/rack/builder.rb:51
(root) at /Users/dayas/RubyProjects/houstonsos/config.ru:1
--- RubyGems
Gem.dir: /Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8
Gem.path:
/Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8
/Users/dayas/RubyProjects/houstonsos/WEB-INF/gems
/Users/dayas/.gem/jruby/1.8
Activated gems:
rake-0.9.2.2
multi_json-1.1.0
activesupport-3.1.4
builder-3.0.0
i18n-0.6.0
activemodel-3.1.4
arel-2.2.3
tzinfo-0.3.32
activerecord-3.1.4
archive-tar-minitar-0.5.2
bouncy-castle-java-1.5.0146.1
bundler-1.1.0
mime-types-1.17.2
nokogiri-1.5.1-java
rack-1.4.1
rack-test-0.6.1
ffi-1.0.11-java
childprocess-0.3.1
rubyzip-0.9.6.1
selenium-webdriver-2.20.0
xpath-0.1.4
capybara-1.1.2
coderay-1.0.5
columnize-0.3.6
diff-lcs-1.1.3
grit-2.4.1
haml-3.1.4
url_mount-0.2.1
http_router-0.10.2
jdbc-mysql-5.1.13
jruby-jars-1.6.7
jruby-openssl-0.7.6.1
jruby-rack-1.1.4
json-1.6.5-java
kramdown-0.13.5
polyglot-0.3.3
treetop-1.4.10
mail-2.3.2
rack-protection-1.2.0
tilt-1.3.3
sinatra-1.3.2
thor-0.14.6
padrino-core-0.10.5
padrino-helpers-0.10.5
padrino-admin-0.10.5
padrino-cache-0.10.5
padrino-gen-0.10.5
padrino-mailer-0.10.5
padrino-0.10.5
sass-3.1.15
sinatra-flash-0.3.0
trinidad_jars-1.0.2
trinidad-1.3.4
warbler-1.3.2
--- Bundler
Bundler.bundle_path: /Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8
Bundler.root: /Users/dayas/RubyProjects/houstonsos
Gemfile: /Users/dayas/RubyProjects/houstonsos/Gemfile
Settings:
build.pg = -–with-opt-include=/usr/local/Cellar/postgresql/9.0.0//include/ --with-opt-lib=/usr/local/Cellar/postgresql/9.0.0/lib/
without = test
bin = bin
gemfile = /Users/dayas/RubyProjects/houstonsos/Gemfile
bin_path = /Users/dayas/.rbenv/versions/jruby-1.6.6/lib/ruby/gems/1.8/gems/bundler-1.1.0/bin/bundle
--- JRuby-Rack Config
compat_version = RUBY1_8
filter_adds_html = true
filter_verifies_resource = false
ignore_environment = false
initial_runtimes = 1
jms_connection_factory =
jms_jndi_properties =
logger = org.jruby.rack.logging.ServletContextLogger@3b52dc4b
logger_class_name = servlet_context
logger_name = jruby.rack
maximum_runtimes = 5
num_initializer_threads =
rackup =
rackup_path = config.ru
rewindable = true
runtime_arguments =
runtime_timeout_seconds =
serial_initialization = false
servlet_context = org.apache.catalina.core.ApplicationContextFacade@2f52084c
2012-03-13 16:30:32 SEVERE: unable to create shared application instance
2012-03-13 16:30:32 SEVERE: Error: application initialization failed
2012-03-13 16:30:34 INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [1,446] milliseconds.
2012-03-13 16:30:34 INFO: Starting ProtocolHandler ["http-bio-4000"]
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.