public
Created

Multiple ruby installs with different rubygems versions

  • Download Gist
1.9.2-nrg1810
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
```shell
∴ rvm --install use 1.9.2-nrg1810 && rvm rubygems 1.8.10
WARN: ruby ruby-1.9.2-p290-nrg1810 is not installed.
Installing Ruby from source to: /Users/me/.rvm/rubies/ruby-1.9.2-p290-nrg1810, this may take a while depending on your cpu(s)...
 
ruby-1.9.2-p290-nrg1810 - #fetching
ruby-1.9.2-p290-nrg1810 - #extracting ruby-1.9.2-p290 to /Users/me/.rvm/src/ruby-1.9.2-p290-nrg1810
ruby-1.9.2-p290-nrg1810 - #extracted to /Users/me/.rvm/src/ruby-1.9.2-p290-nrg1810
Fetching yaml-0.1.4.tar.gz to /Users/me/.rvm/archives
Extracting yaml-0.1.4.tar.gz to /Users/me/.rvm/src
Configuring yaml in /Users/me/.rvm/src/yaml-0.1.4.
Compiling yaml in /Users/me/.rvm/src/yaml-0.1.4.
Installing yaml to /Users/me/.rvm/usr
ruby-1.9.2-p290-nrg1810 - #configuring
ruby-1.9.2-p290-nrg1810 - #compiling
ruby-1.9.2-p290-nrg1810 - #installing
Removing old Rubygems files...
Installing rubygems-1.8.10 for ruby-1.9.2-p290-nrg1810 ...
Installation of rubygems completed successfully.
ruby-1.9.2-p290-nrg1810 - adjusting #shebangs for (gem irb erb ri rdoc testrb rake).
ruby-1.9.2-p290-nrg1810 - #importing default gemsets (/Users/me/.rvm/gemsets/)
Install of ruby-1.9.2-p290-nrg1810 - #complete
Using /Users/me/.rvm/gems/ruby-1.9.2-p290-nrg1810
Removing old Rubygems files...
Installing rubygems-1.8.10 for ruby-1.9.2-p290-nrg1810 ...
Installation of rubygems completed successfully.
 
 
```
1.9.2-nrg186
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
```shell
 
∴ rvm install 1.9.2-nrg186
Installing Ruby from source to: /Users/me/.rvm/rubies/ruby-1.9.2-p290-nrg186, this may take a while depending on your cpu(s)...
 
ruby-1.9.2-p290-nrg186 - #fetching
ruby-1.9.2-p290-nrg186 - #extracting ruby-1.9.2-p290 to /Users/me/.rvm/src/ruby-1.9.2-p290-nrg186
ruby-1.9.2-p290-nrg186 - #extracted to /Users/me/.rvm/src/ruby-1.9.2-p290-nrg186
Fetching yaml-0.1.4.tar.gz to /Users/me/.rvm/archives
Extracting yaml-0.1.4.tar.gz to /Users/me/.rvm/src
Configuring yaml in /Users/me/.rvm/src/yaml-0.1.4.
Compiling yaml in /Users/me/.rvm/src/yaml-0.1.4.
Installing yaml to /Users/me/.rvm/usr
ruby-1.9.2-p290-nrg186 - #configuring
ruby-1.9.2-p290-nrg186 - #compiling
ruby-1.9.2-p290-nrg186 - #installing
Removing old Rubygems files...
Installing rubygems-1.8.10 for ruby-1.9.2-p290-nrg186 ...
Installation of rubygems completed successfully.
ruby-1.9.2-p290-nrg186 - adjusting #shebangs for (gem irb erb ri rdoc testrb rake).
ruby-1.9.2-p290-nrg186 - #importing default gemsets (/Users/me/.rvm/gemsets/)
Install of ruby-1.9.2-p290-nrg186 - #complete
19:03:09 me@pgpmbp-wifi:~
∴ rvm use 1.9.2-nrg186
Using /Users/me/.rvm/gems/ruby-1.9.2-p290-nrg186
19:03:31 me@pgpmbp-wifi:~
∴ rvm rubygems 1.8.6
Retrieving rubygems-1.8.6
Extracting rubygems-1.8.6 ...
Removing old Rubygems files...
Installing rubygems-1.8.6 for ruby-1.9.2-p290-nrg186 ...
Installation of rubygems completed successfully.
```
console.sh
Shell
1 2 3 4 5
∴ rvm 1.9.2-nrg186 exec gem --version
1.8.6
19:09:30 me@pgpmbp-wifi:~
∴ rvm 1.9.2-nrg1810 exec gem --version
1.8.10

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.