Skip to content

Instantly share code, notes, and snippets.

@dpaola2 dpaola2/error.sh
Created Jun 8, 2016

Embed
What would you like to do?
--- ERROR REPORT TEMPLATE -------------------------------------------------------
- What did you do?
I ran the command `/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/bin/bundle install`
- What did you expect to happen?
I expected Bundler to...
- What happened instead?
Instead, what actually happened was...
Error details
OpenSSL::X509::StoreError: setting default path failed: Invalid keystore format
org/jruby/ext/openssl/X509Store.java:185:in `set_default_paths'
/Users/dpaola2/.rvm/rubies/jruby-9.0.0.0/lib/ruby/stdlib/jopenssl/load.rb:22:in `<top>'
org/jruby/RubyKernel.java:940:in `require'
/Users/dpaola2/.rvm/rubies/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:54:in `require'
/Users/dpaola2/.rvm/rubies/jruby-9.0.0.0/lib/ruby/stdlib/openssl.rb:1:in `<top>'
org/jruby/RubyKernel.java:940:in `require'
/Users/dpaola2/.rvm/rubies/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:54:in `require'
/Users/dpaola2/.rvm/rubies/jruby-9.0.0.0/lib/ruby/stdlib/openssl.rb:1:in `<top>'
org/jruby/RubyKernel.java:940:in `require'
/Users/dpaola2/.rvm/rubies/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:54:in `require'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/vendored_persistent.rb:1:in `<top>'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/vendored_persistent.rb:5:in `(root)'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/fetcher.rb:1:in `(root)'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/fetcher.rb:2:in `(root)'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/cli/install.rb:1:in `(root)'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/cli/install.rb:93:in `run'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/cli.rb:175:in `install'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in `block in invoke_command'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor.rb:359:in `dispatch'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/vendor/thor/lib/thor/base.rb:440:in `<top>'
org/jruby/RubyKernel.java:958:in `load'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/gems/bundler-1.12.5/lib/bundler/cli.rb:11:in `<eval>'
org/jruby/RubyKernel.java:979:in `eval'
/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/bin/jruby_executable_hooks:15:in `<top>'
Environment
Bundler 1.12.5
Rubygems 2.4.8
Ruby 2.2.2p0 (2015-07-21 revision 50293) [java]
GEM_HOME /Users/dpaola2/.rvm/gems/jruby-9.0.0.0
GEM_PATH /Users/dpaola2/.rvm/gems/jruby-9.0.0.0:/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global
RVM 1.25.20 (master)
Git 2.5.0
rubygems-bundler (1.4.4)
Bundler settings
build.sqlite3-ruby
Set for the current user (/Users/dpaola2/.bundle/config): "--with-opt-dir=/app/sqlite3"
orig_path
Set via BUNDLE_ORIG_PATH: "/Users/dpaola2/.rvm/gems/jruby-9.0.0.0/bin:/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global/bin:/Users/dpaola2/.rvm/rubies/jruby-9.0.0.0/bin:/Users/dpaola2/.rvm/bin:/Users/dpaola2/projects/github/ansible/bin:/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/Applications/livelykernel-scripts.app/Contents/Resources/livelykernel-scripts/bin:/usr/local/Cellar/openssl/1.0.1e/bin:/usr/local/Cellar/emacs/24.3/bin:/usr/local/Cellar/postgresql/9.3.4/bin:/usr/local/redline:/usr/local/share/npm/bin:/Users/dpaola2/projects/goprojects/bin:/Users/dpaola2/projects/github/yagarto/yagarto-4.7.2/bin:/Users/dpaola2/projects/github/yagarto/yagarto-4.7.2/tools:/Users/dpaola2/projects/github/phabricator/arcanist/bin:/Users/dpaola2/projects/bloc/jigs/bin"
orig_gem_path
Set via BUNDLE_ORIG_GEM_PATH: "/Users/dpaola2/.rvm/gems/jruby-9.0.0.0:/Users/dpaola2/.rvm/gems/jruby-9.0.0.0@global"
--- TEMPLATE END ----------------------------------------------------------------
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.