Skip to content

Instantly share code, notes, and snippets.

@eridal
Created Jul 2, 2017
Embed
What would you like to do?
Algoritmos PSeInt
Algoritmo AdivinarMiNumero
Definir secreto Como Entero
Definir adivino Como Entero
secreto <- aleatorio(1, 100)
oportunidades <- 10
Imprimir "Acabo de pensar un numero entre 1 y 100..."
Repetir
Si oportunidades < 10
Imprimir "Te quedan ", oportunidades, " intentos ..."
FinSi
Imprimir "Que numero sera?"
Leer adivino
Si adivino != secreto
Si adivino < secreto
Imprimir "Ah, mi numero es MAS ALTO"
SiNo
Imprimir "Eh, mi numero es MAS BAJO"
FinSi
oportunidades <- oportunidades - 1
FinSi
Hasta Que adivino = secreto || oportunidades = 0
Si adivino = secreto
Imprimir "Si, Adivinaste!"
SiNo
Imprimir "No, Perdiste! Mi numero era ", secreto
FinSi
FinAlgoritmo
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment