Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
From a2b06000476b5331ea776311244b532603a3670e Mon Sep 17 00:00:00 2001
From: l33tname <sirl33tname@gmail.com>
Date: Sat, 23 Oct 2021 18:11:35 +0000
Subject: [PATCH] devel/ruby-gems: creates different gemspec files
because of that all patch-gemspec should be updated
---
.../rubygem-gitlab-grit/files/patch-gemspec | 20 ++++++++---------
.../files/patch-ext_nokogiri_extconf.rb | 6 ++---
textproc/rubygem-nokogiri/files/patch-gemspec | 16 +++++++-------
www/rubygem-em-websocket/files/patch-gemspec | 18 +++++++--------
www/rubygem-gollum-lib/files/patch-gemspec | 22 +++++++++----------
www/rubygem-gollum/files/patch-gemspec | 16 +++++++-------
www/rubygem-jekyll/files/patch-gemspec | 20 ++++++++---------
7 files changed, 59 insertions(+), 59 deletions(-)
diff --git a/textproc/rubygem-gitlab-grit/files/patch-gemspec b/textproc/rubygem-gitlab-grit/files/patch-gemspec
index c3bc75c288eb..485ee307f1f3 100644
--- a/textproc/rubygem-gitlab-grit/files/patch-gemspec
+++ b/textproc/rubygem-gitlab-grit/files/patch-gemspec
@@ -1,11 +1,11 @@
---- gitlab-grit.gemspec.orig 2020-08-23 06:02:57 UTC
+--- gitlab-grit.gemspec.orig 2021-10-23 17:41:15 UTC
+++ gitlab-grit.gemspec
-@@ -25,7 +25,7 @@ Gem::Specification.new do |s|
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<charlock_holmes>.freeze, ["~> 0.7"])
- s.add_runtime_dependency(%q<posix-spawn>.freeze, ["~> 0.3"])
-- s.add_runtime_dependency(%q<mime-types>.freeze, [">= 1.16", "< 3"])
-+ s.add_runtime_dependency(%q<mime-types>.freeze, [">= 1.16"])
- s.add_runtime_dependency(%q<diff-lcs>.freeze, ["~> 1.1"])
- s.add_development_dependency(%q<mocha>.freeze, [">= 0"])
- s.add_development_dependency(%q<test-unit>.freeze, [">= 0"])
+@@ -26,7 +26,7 @@ Gem::Specification.new do |s|
+ if s.respond_to? :add_runtime_dependency then
+ s.add_runtime_dependency(%q<charlock_holmes>.freeze, ["~> 0.7"])
+ s.add_runtime_dependency(%q<posix-spawn>.freeze, ["~> 0.3"])
+- s.add_runtime_dependency(%q<mime-types>.freeze, [">= 1.16", "< 3"])
++ s.add_runtime_dependency(%q<mime-types>.freeze, [">= 1.16"])
+ s.add_runtime_dependency(%q<diff-lcs>.freeze, ["~> 1.1"])
+ s.add_development_dependency(%q<mocha>.freeze, [">= 0"])
+ s.add_development_dependency(%q<test-unit>.freeze, [">= 0"])
diff --git a/textproc/rubygem-nokogiri/files/patch-ext_nokogiri_extconf.rb b/textproc/rubygem-nokogiri/files/patch-ext_nokogiri_extconf.rb
index c0070a9b7bf0..cec049070a5b 100644
--- a/textproc/rubygem-nokogiri/files/patch-ext_nokogiri_extconf.rb
+++ b/textproc/rubygem-nokogiri/files/patch-ext_nokogiri_extconf.rb
@@ -1,6 +1,6 @@
---- ext/nokogiri/extconf.rb.orig 2021-01-21 20:37:43 UTC
+--- ext/nokogiri/extconf.rb.orig 2021-10-23 18:05:51 UTC
+++ ext/nokogiri/extconf.rb
-@@ -819,6 +819,43 @@ unless using_system_libraries?
+@@ -891,6 +891,43 @@ unless config_system_libraries?
end
end
@@ -43,4 +43,4 @@
+
create_makefile('nokogiri/nokogiri')
- if enable_config('clean', true)
+ if config_clean?
diff --git a/textproc/rubygem-nokogiri/files/patch-gemspec b/textproc/rubygem-nokogiri/files/patch-gemspec
index 43f56f9a0877..408946844b39 100644
--- a/textproc/rubygem-nokogiri/files/patch-gemspec
+++ b/textproc/rubygem-nokogiri/files/patch-gemspec
@@ -1,10 +1,10 @@
---- nokogiri.gemspec.orig 2021-01-21 20:37:44 UTC
+--- nokogiri.gemspec.orig 2021-10-23 18:05:51 UTC
+++ nokogiri.gemspec
-@@ -29,7 +29,6 @@ Gem::Specification.new do |s|
+@@ -30,7 +30,6 @@ Gem::Specification.new do |s|
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<racc>.freeze, ["~> 1.4"])
-- s.add_runtime_dependency(%q<mini_portile2>.freeze, ["~> 2.5.0"])
- s.add_development_dependency(%q<bundler>.freeze, ["~> 2.2"])
- s.add_development_dependency(%q<concourse>.freeze, ["~> 0.41"])
- s.add_development_dependency(%q<hoe-markdown>.freeze, ["~> 1.1"])
+ if s.respond_to? :add_runtime_dependency then
+ s.add_runtime_dependency(%q<racc>.freeze, ["~> 1.4"])
+- s.add_runtime_dependency(%q<mini_portile2>.freeze, ["~> 2.5.0"])
+ s.add_development_dependency(%q<bundler>.freeze, ["~> 2.2"])
+ s.add_development_dependency(%q<concourse>.freeze, ["~> 0.41"])
+ s.add_development_dependency(%q<hoe-markdown>.freeze, ["~> 1.4"])
diff --git a/www/rubygem-em-websocket/files/patch-gemspec b/www/rubygem-em-websocket/files/patch-gemspec
index 0851e6256080..aae69c1ae130 100644
--- a/www/rubygem-em-websocket/files/patch-gemspec
+++ b/www/rubygem-em-websocket/files/patch-gemspec
@@ -1,11 +1,11 @@
---- em-websocket.gemspec.orig 2021-07-15 21:52:22 UTC
+--- em-websocket.gemspec.orig 2021-10-23 18:01:02 UTC
+++ em-websocket.gemspec
-@@ -23,7 +23,7 @@ Gem::Specification.new do |s|
+@@ -24,7 +24,7 @@ Gem::Specification.new do |s|
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<eventmachine>.freeze, [">= 0.12.9"])
-- s.add_runtime_dependency(%q<http_parser.rb>.freeze, ["~> 0.6.0"])
-+ s.add_runtime_dependency(%q<http_parser.rb>.freeze, ["~> 0.6"])
- else
- s.add_dependency(%q<eventmachine>.freeze, [">= 0.12.9"])
- s.add_dependency(%q<http_parser.rb>.freeze, ["~> 0.6.0"])
+ if s.respond_to? :add_runtime_dependency then
+ s.add_runtime_dependency(%q<eventmachine>.freeze, [">= 0.12.9"])
+- s.add_runtime_dependency(%q<http_parser.rb>.freeze, ["~> 0.6.0"])
++ s.add_runtime_dependency(%q<http_parser.rb>.freeze, ["~> 0.6"])
+ else
+ s.add_dependency(%q<eventmachine>.freeze, [">= 0.12.9"])
+ s.add_dependency(%q<http_parser.rb>.freeze, ["~> 0.6.0"])
diff --git a/www/rubygem-gollum-lib/files/patch-gemspec b/www/rubygem-gollum-lib/files/patch-gemspec
index ffa02bdd9a28..ac4ea693e87c 100644
--- a/www/rubygem-gollum-lib/files/patch-gemspec
+++ b/www/rubygem-gollum-lib/files/patch-gemspec
@@ -1,13 +1,13 @@
---- gollum-lib.gemspec.orig 2019-02-07 15:46:07 UTC
+--- gollum-lib.gemspec.orig 2021-10-23 19:06:45 UTC
+++ gollum-lib.gemspec
@@ -29,8 +29,8 @@ Gem::Specification.new do |s|
- s.add_runtime_dependency(%q<rouge>.freeze, ["~> 2.1"])
- s.add_runtime_dependency(%q<nokogiri>.freeze, [">= 1.6.1", "< 2.0"])
- s.add_runtime_dependency(%q<stringex>.freeze, ["~> 2.6"])
-- s.add_runtime_dependency(%q<sanitize>.freeze, ["~> 2.1.1", ">= 2.1.1"])
-- s.add_runtime_dependency(%q<github-markup>.freeze, ["~> 1.6"])
-+ s.add_runtime_dependency(%q<sanitize>.freeze, [">= 2.1.1"])
-+ s.add_runtime_dependency(%q<github-markup>.freeze, [">= 1.6"])
- s.add_runtime_dependency(%q<gemojione>.freeze, ["~> 3.2"])
- s.add_runtime_dependency(%q<twitter-text>.freeze, ["= 1.14.7"])
- s.add_development_dependency(%q<org-ruby>.freeze, ["~> 0.9.9"])
+ s.add_runtime_dependency(%q<rouge>.freeze, ["~> 2.1"])
+ s.add_runtime_dependency(%q<nokogiri>.freeze, [">= 1.6.1", "< 2.0"])
+ s.add_runtime_dependency(%q<stringex>.freeze, ["~> 2.6"])
+- s.add_runtime_dependency(%q<sanitize>.freeze, ["~> 2.1.1", ">= 2.1.1"])
+- s.add_runtime_dependency(%q<github-markup>.freeze, ["~> 1.6"])
++ s.add_runtime_dependency(%q<sanitize>.freeze, [">= 2.1.1"])
++ s.add_runtime_dependency(%q<github-markup>.freeze, [">= 1.6"])
+ s.add_runtime_dependency(%q<gemojione>.freeze, ["~> 3.2"])
+ s.add_runtime_dependency(%q<twitter-text>.freeze, ["= 1.14.7"])
+ s.add_development_dependency(%q<org-ruby>.freeze, ["~> 0.9.9"])
diff --git a/www/rubygem-gollum/files/patch-gemspec b/www/rubygem-gollum/files/patch-gemspec
index 061489f23512..c4e69d21cf83 100644
--- a/www/rubygem-gollum/files/patch-gemspec
+++ b/www/rubygem-gollum/files/patch-gemspec
@@ -1,11 +1,11 @@
---- gollum.gemspec.orig 2019-02-07 15:28:31 UTC
+--- gollum.gemspec.orig 2021-10-23 19:04:23 UTC
+++ gollum.gemspec
@@ -27,7 +27,7 @@ Gem::Specification.new do |s|
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<gollum-lib>.freeze, ["~> 4.2", ">= 4.2.10"])
-- s.add_runtime_dependency(%q<kramdown>.freeze, ["~> 1.9.0"])
-+ s.add_runtime_dependency(%q<kramdown>.freeze, ["~> 1.9"])
- s.add_runtime_dependency(%q<sinatra>.freeze, ["~> 1.4", ">= 1.4.4"])
- s.add_runtime_dependency(%q<mustache>.freeze, [">= 0.99.5", "< 1.0.0"])
- s.add_runtime_dependency(%q<useragent>.freeze, ["~> 0.16.2"])
+ if s.respond_to? :add_runtime_dependency then
+ s.add_runtime_dependency(%q<gollum-lib>.freeze, ["~> 4.2", ">= 4.2.10"])
+- s.add_runtime_dependency(%q<kramdown>.freeze, ["~> 1.9.0"])
++ s.add_runtime_dependency(%q<kramdown>.freeze, ["~> 1.9"])
+ s.add_runtime_dependency(%q<sinatra>.freeze, ["~> 1.4", ">= 1.4.4"])
+ s.add_runtime_dependency(%q<mustache>.freeze, [">= 0.99.5", "< 1.0.0"])
+ s.add_runtime_dependency(%q<useragent>.freeze, ["~> 0.16.2"])
diff --git a/www/rubygem-jekyll/files/patch-gemspec b/www/rubygem-jekyll/files/patch-gemspec
index 3dc516177abd..4a526ffc8122 100644
--- a/www/rubygem-jekyll/files/patch-gemspec
+++ b/www/rubygem-jekyll/files/patch-gemspec
@@ -1,11 +1,11 @@
---- jekyll.gemspec.orig 2021-01-31 08:04:37 UTC
+--- jekyll.gemspec.orig 2021-10-23 19:24:55 UTC
+++ jekyll.gemspec
-@@ -40,7 +40,7 @@ Gem::Specification.new do |s|
- s.add_runtime_dependency(%q<pathutil>.freeze, ["~> 0.9"])
- s.add_runtime_dependency(%q<rouge>.freeze, ["~> 3.0"])
- s.add_runtime_dependency(%q<safe_yaml>.freeze, ["~> 1.0"])
-- s.add_runtime_dependency(%q<terminal-table>.freeze, ["~> 2.0"])
-+ s.add_runtime_dependency(%q<terminal-table>.freeze, [">= 2.0"])
- else
- s.add_dependency(%q<addressable>.freeze, ["~> 2.4"])
- s.add_dependency(%q<colorator>.freeze, ["~> 1.0"])
+@@ -41,7 +41,7 @@ Gem::Specification.new do |s|
+ s.add_runtime_dependency(%q<pathutil>.freeze, ["~> 0.9"])
+ s.add_runtime_dependency(%q<rouge>.freeze, ["~> 3.0"])
+ s.add_runtime_dependency(%q<safe_yaml>.freeze, ["~> 1.0"])
+- s.add_runtime_dependency(%q<terminal-table>.freeze, ["~> 2.0"])
++ s.add_runtime_dependency(%q<terminal-table>.freeze, [">= 2.0"])
+ else
+ s.add_dependency(%q<addressable>.freeze, ["~> 2.4"])
+ s.add_dependency(%q<colorator>.freeze, ["~> 1.0"])
--
2.32.0
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment