Skip to content

Instantly share code, notes, and snippets.

@fcoury
fcoury / gist:2206678
Created Mar 26, 2012 — forked from thattommyhall/gist:2205969
fpm ruby 1.9.3
View gist:2206678
apt-get install libreadline-dev
./configure --prefix=/usr && make && make install DESTDIR=/tmp/ruby193
fpm -s dir -t deb -n ruby -v 1.9.3-p125 -C /tmp/ruby193 \
-p ruby-VERSION_ARCH.deb -d "libstdc++6 (>= 4.4.3)" \
-d "libc6 (>= 2.6)" -d "libffi5 (>= 3.0.4)" -d "libgdbm3 (>= 1.8.3)" \
-d "libncurses5 (>= 5.7)" -d "libreadline6 (>= 6.1)" \
-d "libssl0.9.8 (>= 0.9.8)" -d "zlib1g (>= 1:1.2.2)" \
usr/bin usr/lib usr/share/man usr/include
@jtimberman
jtimberman / gist:881058
Last active Jun 16, 2017
i can has ruby-1.9 package with fpm
View gist:881058
sudo apt-get install libssl-dev
sudo gem install fpm
wget ftp://ftp.ruby-lang.org//pub/ruby/1.9/ruby-1.9.3-p392.tar.gz
tar -zxvf ruby-1.9.3-p392.tar.gz
cd src/ruby-1.9.3-p392
time (./configure --prefix=/usr && make && make install DESTDIR=/tmp/installdir)
fpm -s dir -t deb -n ruby -v 1.9.3-p392 -C /tmp/installdir \
-p ruby-VERSION_ARCH.deb -d "libstdc++6 (>= 4.4.3)" \
You can’t perform that action at this time.