Skip to content

Instantly share code, notes, and snippets.

@geelen geelen/notes.md Secret
Created Jan 22, 2015

Embed
What would you like to do?
Webkit Wayland notes

Ftp server was blocked on my connection:

wget http://mirrors.kernel.org/sources.redhat.com/libffi/libffi-3.0.10.tar.gz
 mv libffi-3.0.10.tar.gz WebKitBuild/DependenciesWPE/Source/
@geelen

This comment has been minimized.

Copy link
Owner Author

commented Jan 22, 2015

Build fails

configure: error: Can't find expat.h. Please install expat.
*** Error during phase configure of wayland: ########## Error running ./configure --prefix /home/ubuntu/src/webkit/WebKitBuild/DependenciesWPE/Root --libdir '/home/ubuntu/src/webkit/WebKitBuild/DependenciesWPE/Root/lib'  --disable-static --disable-gtk-doc  *** [8/15]
@geelen

This comment has been minimized.

Copy link
Owner Author

commented Jan 22, 2015

sudo apt-get install libexpat1-dev doxygen

Now fails with

*** module weston not built due to non buildable cairo *** [9/15]
*** module gstreamer not built due to non buildable glib *** [10/15]
*** module gst-plugins-base not built due to non buildable gstreamer *** [11/15]
*** module gst-plugins-good not built due to non buildable gst-plugins-base *** [12/15]
*** module gst-plugins-bad not built due to non buildable gst-plugins-base *** [13/15]
*** module gst-libav not built due to non buildable gst-plugins-base *** [14/15]
*** module webkitwpe-testing-dependencies not built due to non buildable glib *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable libsoup *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable cairo *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable weston *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gstreamer *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gst-plugins-base *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gst-plugins-good *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gst-plugins-bad *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gst-libav *** [15/15]
*** the following modules were not built *** [15/15]
glib glib-networking libsoup fontconfig cairo weston gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad gst-libav webkitwpe-testing-dependencies
Running jhbuild-wrapper build failed.
Died at Tools/Scripts/update-webkitwpe-libs line 24.
@geelen

This comment has been minimized.

Copy link
Owner Author

commented Jan 22, 2015

Also found this

checking for freetype-config... no
configure: error: You must have freetype installed; see http://www.freetype.org/
*** Error during phase configure of fontconfig: ########## Error running ./configure --prefix /home/ubuntu/src/webkit/WebKitBuild/DependenciesWPE/Root --libdir '/home/ubuntu/src/webkit/WebKitBuild/DependenciesWPE/Root/lib'  --disable-static --disable-gtk-doc  *** [5/15]
*** Checking out pixman *** [6/15]
*** Skipping pixman (not updated) *** [6/15]
*** module cairo not built due to non buildable glib *** [7/15]
*** module cairo not built due to non buildable fontconfig *** [7/15]
@geelen

This comment has been minimized.

Copy link
Owner Author

commented Jan 22, 2015

sudo apt-get install libfreetype6-dev

A lot more proimising! Cairo was at least checked out this time. Now we get:

+ check for build tools
  checking for autoconf >= 2.68 ...   checking for autoconf270 >= 2.68 ...   checking for autoconf269 >= 2.68 ...   checking for autoconf268 >= 2.68 ... autoconf not found !
You must have autoconf installed to compile gstreamer.
Download the appropriate package for your distribution,
or get the source tarball at ftp://ftp.gnu.org/pub/gnu/autoconf/
  checking for automake >= 1.11 ...   checking for automake-1.11 >= 1.11 ... automake not found !
You must have automake installed to compile gstreamer.
Download the appropriate package for your distribution,
or get the source tarball at ftp://ftp.gnu.org/pub/gnu/automake/
  checking for autopoint >= 0.17 ... autopoint not found !
You must have autopoint installed to compile gstreamer.
Download the appropriate package for your distribution,
or get the source tarball at ftp://ftp.gnu.org/pub/gnu/gettext/
  checking for libtoolize >= 2.2.6 ...   checking for glibtoolize >= 2.2.6 ... libtoolize not found !
You must have libtoolize installed to compile gstreamer.
Download the appropriate package for your distribution,
or get the source tarball at ftp://ftp.gnu.org/pub/gnu/libtool/
  checking for pkg-config >= 0.8.0 ... found 0.26, ok.

- Please get the right tools before proceeding.
- Alternatively, if you're sure we're wrong, run with --nocheck.
*** Error during phase configure of gstreamer: ########## Error running ./autogen.sh --prefix /home/ubuntu/src/webkit/WebKitBuild/DependenciesWPE/Root --libdir '/home/ubuntu/src/webkit/WebKitBuild/DependenciesWPE/Root/lib' --disable-gtk-doc --disable-static --disable-gtk-doc  *** [10/15]
*** module gst-plugins-base not built due to non buildable gstreamer *** [11/15]
*** module gst-plugins-good not built due to non buildable gst-plugins-base *** [12/15]
*** module gst-plugins-bad not built due to non buildable gst-plugins-base *** [13/15]
*** module gst-libav not built due to non buildable gst-plugins-base *** [14/15]
*** module webkitwpe-testing-dependencies not built due to non buildable libsoup *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable cairo *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable weston *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gstreamer *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gst-plugins-base *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gst-plugins-good *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gst-plugins-bad *** [15/15]
*** module webkitwpe-testing-dependencies not built due to non buildable gst-libav *** [15/15]
*** the following modules were not built *** [15/15]
glib-networking libsoup cairo weston gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad gst-libav webkitwpe-testing-dependencies
Running jhbuild-wrapper build failed.
Died at Tools/Scripts/update-webkitwpe-libs line 24.
@geelen

This comment has been minimized.

Copy link
Owner Author

commented Jan 22, 2015

Installed a bunch:

sudo apt-get install build-essential autoconf automake autopoint libtool intltool bison flex libgnutls28-dev libxml2-dev libsqlite3-dev

Now this:

checking for cairo's OpenGLESv2 surface backend feature... 
checking for glesv2... no
checking GLES2/gl2.h usability... no
checking GLES2/gl2.h presence... no
checking for GLES2/gl2.h... no
checking whether cairo's OpenGLESv2 surface backend feature could be enabled... no (glesv2.pc nor OpenGL ES 2.0 headers not found)
configure: error:  OpenGLESv2 surface backend feature could not be enabled
configure: WARNING: cache variable cairo_cv_warn_maybe contains a newline
*** Error during phase configure of cairo: ########## Error running ./autogen.sh --prefix /home/ubuntu/src/webkit/WebKitBuild/DependenciesWPE/Root --libdir '/home/ubuntu/src/webkit/WebKitBuild/DependenciesWPE/Root/lib' --enable-egl=yes --enable-glesv2 --disable-static --disable-gtk-doc  *** [7/15]
*** Checking out wayland *** [8/15]
*** Skipping wayland (not updated) *** [8/15]
*** module weston not built due to non buildable cairo *** [9/15]
@geelen

This comment has been minimized.

Copy link
Owner Author

commented Jan 22, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.