public
Created

cocos2d 1.1.rc0 podspec fixed

  • Download Gist
cocos2d.podspec
Ruby
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
Pod::Spec.new do |s|
s.name = 'cocos2d'
s.license = { :type => 'MIT', :file => 'LICENSE_cocos2d.txt' }
s.version = '1.1.rc0'
s.summary = 'cocos2d for iPhone is a framework for building 2D games, demos, and other graphical/interactive applications.'
s.description = 'cocos2d for iPhone is a framework for building 2D games, demos, and other graphical/interactive applications for iPod Touch, iPhone, iPad and Mac. It is based on the cocos2d design but instead of using python it, uses objective-c.'
s.homepage = 'http://www.cocos2d-iphone.org'
s.author = { 'Ricardo Quesada' => 'ricardoquesada@gmail.com', 'Zynga Inc.' => 'https://zynga.com/' }
s.source = {:git => 'https://github.com/cocos2d/cocos2d-iphone.git', :commit => '7ee5b9abf645c32379a45317986a308204277bb1'}
s.preferred_dependency = 'cocos2d'
 
s.subspec 'cocos2d' do |cc|
cc.source_files = 'cocos2d/**/*.{h,m,c}'
cc.frameworks = ["CoreGraphics", "OpenGLES", "QuartzCore"]
cc.library = 'z'
cc.resources = "Resources/Fonts/fps_images*.png"
 
def cc.copy_header_mapping(from)
from.relative_path_from(Pathname.new('cocos2d'))
end
cc.ios.dependency 'FontLabel'
end
 
s.subspec 'CocosDenshion' do |cd|
cd.source_file = 'CocosDenshion/CocosDenshion/*.{h,m}'
cd.frameworks = ["AVFoundation", "OpenAL", "CoreFoundation", "AudioToolbox", "Foundation"]
end
end

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.