Skip to content

Instantly share code, notes, and snippets.

@hilman-dayo

hilman-dayo/Matplotlib.txt Secret

Created Feb 1, 2016
Embed
What would you like to do?
(cv)ProBook:matplotlib hilman_dayo$ git checkout v1.4.3
HEAD is now at 21f46ff... REL : version 1.4.3
(cv)ProBook:matplotlib hilman_dayo$ python setup.py install
============================================================================
Edit setup.cfg to change the build options
BUILDING MATPLOTLIB
matplotlib: yes [1.4.3]
python: yes [2.7.11 (default, Dec 12 2015, 20:59:25) [GCC
4.2.1 Compatible Apple LLVM 7.0.2 (clang-700.1.81)]]
platform: yes [darwin]
REQUIRED DEPENDENCIES AND EXTENSIONS
numpy: yes [version 1.10.2]
six: yes [using six version 1.10.0]
dateutil: yes [using dateutil version 2.4.2]
pytz: yes [using pytz version 2015.7]
tornado: yes [tornado was not found. It is required for the
WebAgg backend. pip/easy_install may attempt to
install it after matplotlib.]
pyparsing: yes [using pyparsing version 2.0.7]
pycxx: yes [Couldn't import. Using local copy.]
libagg: yes [pkg-config information for 'libagg' could not
be found. Using local copy.]
freetype: no [The C/C++ header for freetype2 (ft2build.h)
could not be found. You may need to install the
development package.]
png: yes [version 1.6.19]
qhull: yes [pkg-config information for 'qhull' could not be
found. Using local copy.]
OPTIONAL SUBPACKAGES
sample_data: yes [installing]
toolkits: yes [installing]
tests: yes [nose 0.11.1 or later is required to run the
matplotlib test suite. pip/easy_install may attempt
to install it after matplotlib. / mock is required
to run the matplotlib test suite. pip/easy_install
may attempt to install it after matplotlib.]
toolkits_tests: yes [nose 0.11.1 or later is required to run the
matplotlib test suite. pip/easy_install may attempt
to install it after matplotlib. / mock is required
to run the matplotlib test suite. pip/easy_install
may attempt to install it after matplotlib.]
OPTIONAL BACKEND EXTENSIONS
macosx: yes [installing, darwin]
qt5agg: no [PyQt5 not found]
qt4agg: no [PyQt4 not found]
pyside: no [PySide not found]
gtk3agg: no [Requires pygobject to be installed.]
gtk3cairo: no [Requires cairocffi or pycairo to be installed.]
gtkagg: no [Requires pygtk]
tkagg: no [The C/C++ header for Tk (tk.h) could not be
found. You may need to install the development
package.]
wxagg: no [requires wxPython]
gtk: no [Requires pygtk]
agg: yes [installing]
cairo: no [cairocffi or pycairo not found]
windowing: no [Microsoft Windows only]
OPTIONAL LATEX DEPENDENCIES
dvipng: no
ghostscript: no
latex: no
pdftops: no
============================================================================
* The following required packages can not be built:
* freetype
@Rohitpuranik-cloud

This comment has been minimized.

Copy link

@Rohitpuranik-cloud Rohitpuranik-cloud commented Sep 20, 2020

After installing matplotlib When I was trying to use matplotlib.pyplot it was giving error module not found.

I browsed some white papers and found out that we also need to install scipy library to use the matplotlib so I used the below in my command prompt

python -mpip install scipy

Restarted my kernel session.

It worked!!!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.