Create a gist now

Instantly share code, notes, and snippets.

ruby-debug in ruby-1.9.3 and rbenv
# These instructions are for Ruby 1.9.3 under rbenv.
# To install ruby-debug19 for ruby-1.9.3 you need to download the following gems from http://rubyforge.org/frs/?group_id=8883
linecache19-0.5.13.gem
ruby_core_source-0.1.5.gem
ruby-debug19-0.11.6.gem
ruby-debug-base19-0.11.26.gem
#Then in your console
export RBENV_INCLUDE=/your/path/to/.rbenv/versions/1.9.3-p0/include/ruby-1.9.1/ruby-1.9.3-p0
gem install archive-tar-minitar
gem install ruby_core_source-0.1.5.gem -- --with-ruby-include=/$RBENV_INCLUDE
gem install linecache19-0.5.13.gem -- --with-ruby-include=/$RBENV_INCLUDE
gem install ruby-debug-base19-0.11.26.gem -- --with-ruby-include=/$RBENV_INCLUDE
gem install ruby-debug19-0.11.6.gem -- --with-ruby-include=/$RBENV_INCLUDE
@aka47

great, this worked at the end after many many other things i tried ..

@hoverlover
Owner

Great! Glad it helped.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment