Skip to content

Instantly share code, notes, and snippets.

Avatar
💭
Coding mostly elsewhere

Edouard inouire

💭
Coding mostly elsewhere
View GitHub Profile
View Gemfile
gem 'i18n'
gem 'slugify'
gem 'rake'
gem 'colorize'
gem 'pg'
gem 'sequel'
gem 'sequel_pg', :require=>'sequel'
gem 'que', '~> 1.0.0.beta3'
gem 'require_all' # only used for job env loading
gem 'workflow', '~> 1.2'
@inouire
inouire / i18n.rb
Last active May 20, 2019
Simple i18n setup in my Hanami 1.3 app
View i18n.rb
# config/initializers/i18n.rb
require 'i18n'
# Configure it as you want
I18n.load_path = Dir["config/locales/**.yml"]
I18n.enforce_available_locales = true
I18n.default_locale = "en"
I18n.backend.load_translations
@inouire
inouire / gist:ba850551fd352238579d
Created Dec 9, 2014
CSV dataset provider, draft
View gist:ba850551fd352238579d
<?php
namespace MetarDecoder\Service;
use MetarDecoder\Exception\DatasetLoadingException;
class DatasetProvider
{
private $base_dir;