Skip to content

Instantly share code, notes, and snippets.

@jazzsequence
Last active December 27, 2022 10:45
Show Gist options
  • Save jazzsequence/36600abb8f0655a63724fbe046899deb to your computer and use it in GitHub Desktop.
Save jazzsequence/36600abb8f0655a63724fbe046899deb to your computer and use it in GitHub Desktop.
Start and End G-code for Ender 5 on Cura
; Ender 5 Custom End G-code
G4 ; Wait
M220 S100 ; Reset Speed factor override percentage to default (100%)
M221 S100 ; Reset Extrude factor override percentage to default (100%)
G91 ; Set coordinates to relative
G1 F1800 E-3 ; Retract filament 3 mm to prevent oozing
G1 F3000 Z20 ; Move Z Axis up 20 mm to allow filament ooze freely
G90 ; Set coordinates to absolute
G1 X0 Y220 F1000 ; Move Heat Bed to the front for easy print removal
M106 S0 ; Turn off cooling fan
M104 S0 ; Turn off extruder
M140 S0 ; Turn off bed
M107 ; Turn off Fan
M84 ; Disable stepper motors
M117 That's All Folks!
; End of custom end GCode
; Ender 5 Custom Start G-code
M104 S200 ; Set Extruder temperature to 200.
M140 S70 ; Set Heat Bed temperature to 70
; 50 should be sufficient for the actual build but raising the temp can help builds stick to the base.
M190 S50 ; Wait for Heat Bed temperature.
M109 S200 ; Wait for Extruder temperature
G28 ; Home all axes
M117 ; Purge extruder
G92 E0 ; Reset Extruder
; Draw a line. This is for the test line, so it can be a little lower than we need.
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed.
G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
G92 E0 ; Reset Extruder
G1 Z1.5 F3000 ; Move Z Axis up to where it should be for the actual print.
M117 By your command!
; End of custom start GCode
@cnyper
Copy link

cnyper commented Feb 6, 2020

Hey Jazzsequence...
found your code as Marlin 2.0.3 has upset my Ender 5...
when I home, it goes to back right, as before, but previously when a print started it printed a line along the right side to the front and then the back... Now it comes to front left and prints the line to the back left and front again...
Worse than that, though, when it finishes, it comes to front left, bashing my (modded) direct extruder and part fan into the front rail...
So, I went looking for possible solutions...
if I do manual G1 X0 Y0 it comes to front left, but autohome sends it to back right, I have double checked the X&Y settings in Config.h and they appear to be the same with everyone elses...

So that's my problem...

All I meant to say was, on your end.gcode ln 9... your comment is "Move Heat Bed to the front for easy print removal", but the ender 5 doesn't have a bed that moves front to back, only up and down... what G1 X0 Y220 does is to send the nozzle to the back left.

Was that a copy paste error from Ender 3??

A

@jazzsequence
Copy link
Author

It may well have been a copy/paste error. Most of this was a hodgepodge of different things from a variety of sources that I was experimenting with. YMMV ¯_(ツ)_/¯

@Rogue2k0
Copy link

Rogue2k0 commented Oct 9, 2022

Will this code work with the Ender 5 plus?

Also, I have the Creality Silent board + Added the Microswiss Direct Drive extruder. Do any of the settings need to be adjusted?

@bojangles86
Copy link

Will this code work with the Ender 5 plus?

Also, I have the Creality Silent board + Added the Microswiss Direct Drive extruder. Do any of the settings need to be adjusted?

I actually use this on my ender 5 pro with microswiss DD and my ender 7.

@Nikif0r0s
Copy link

Will this code work with the Ender 5 plus?
Also, I have the Creality Silent board + Added the Microswiss Direct Drive extruder. Do any of the settings need to be adjusted?

I actually use this on my ender 5 pro with microswiss DD and my ender 7.

And? How was going? I have also new ender 5 pro and i would like to try this code.

@bojangles86
Copy link

Will this code work with the Ender 5 plus?
Also, I have the Creality Silent board + Added the Microswiss Direct Drive extruder. Do any of the settings need to be adjusted?

I actually use this on my ender 5 pro with microswiss DD and my ender 7.

And? How was going? I have also new ender 5 pro and i would like to try this code.

Works fine. No issues at all.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment