Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
ghcup build error
D:\ws\haskell\ghcup-hs>cabal build
Build profile: -w ghc-8.6.5 -O2
In order, the following will be built (use -v for more details):
- libarchive-3.0.3.1 (lib:libarchive) (requires build)
- yaml-streamly-0.12.0 (lib) (requires build)
- ghcup-0.1.17.3 (lib) (first run)
- ghcup-0.1.17.3 (test:ghcup-test) (first run)
- ghcup-0.1.17.3 (exe:ghcup) (first run)
[1 of 1] Compiling Main ( D:\ws\haskell\ghcup-hs\dist-newstyle\tmp\s
rc-13672\libarchive-3.0.3.1\dist\setup\setup.hs, D:\ws\haskell\ghcup-hs\dist-new
style\tmp\src-13672\libarchive-3.0.3.1\dist\setup\Main.o )
Linking D:\ws\haskell\ghcup-hs\dist-newstyle\tmp\src-13672\libarchive-3.0.3.1\di
st\setup\setup.exe ...
Configuring libarchive-3.0.3.1...
setup.exe: The program 'ghc' version >=7.0.1 is required but the version of
D:\ghcup\bin\ghc.exe could not be determined.
D:\ws\haskell\ghcup-hs>D:\ghcup\bin\ghc.exe --version
The Glorious Glasgow Haskell Compilation System, version 8.6.5
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment