Skip to content

Embed URL

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
savon 0.9.8 breaks rubygems 1.3.7 compatibility on 1.8.7
~/Code/playground (master *) $ rvm use 1.8.7
Using /Users/joerafaniello/.rvm/gems/ruby-1.8.7-p358
~/Code/playground (master *) $ rvm gemset create savon
'savon' gemset created (/Users/joerafaniello/.rvm/gems/ruby-1.8.7-p358@savon).
~/Code/playground (master *) $ rvm use 1.8.7@savon
Using /Users/joerafaniello/.rvm/gems/ruby-1.8.7-p358 with gemset savon
~/Code/playground (master) $ gem install rubygems-update -v 1.3.7
Fetching: rubygems-update-1.3.7.gem (100%)
Successfully installed rubygems-update-1.3.7
1 gem installed
~/Code/playground (master *) $ update_rubygems
RubyGems 1.3.7 installed
=== 1.3.7 / 2010-05-13
NOTE:
http://rubygems.org is now the default source for downloading gems.
You may have sources set via ~/.gemrc, so you should replace
http://gems.rubyforge.org with http://rubygems.org
http://gems.rubyforge.org will continue to work for the forseeable future.
New features:
* `gem` commands
* `gem install` and `gem fetch` now report alternate platforms when a
matching one couldn't be found.
* `gem contents` --prefix is now the default as specified in --help. Bug
#27211 by Mamoru Tasaka.
* `gem fetch` can fetch of old versions again. Bug #27960 by Eric Hankins.
* `gem query` and friends output now lists platforms. Bug #27856 by Greg
Hazel.
* `gem server` now allows specification of multiple gem dirs for
documentation. Bug #27573 by Yuki Sonoda.
* `gem unpack` can unpack gems again. Bug #27872 by Timothy Jones.
* `gem unpack` now unpacks remote gems.
* --user-install is no longer the default. If you really liked it, see
Gem::ConfigFile to learn how to set it by default. (This change was made
in 1.3.6)
* RubyGems now has platform support for IronRuby. Patch #27951 by Will Green.
Bug fixes:
* Require rubygems/custom_require if --disable-gem was set. Bug #27700 by
Roger Pack.
* RubyGems now protects against exceptions being raised by plugins.
* rubygems/builder now requires user_interaction. Ruby Bug #1040 by Phillip
Toland.
* Gem::Dependency support #version_requirements= with a warning. Fix for old
Rails versions. Bug #27868 by Wei Jen Lu.
* Gem::PackageTask depends on the package dir like the other rake package
tasks so dependencies can be hooked up correctly.
------------------------------------------------------------------------------
RubyGems installed the following executables:
/Users/joerafaniello/.rvm/rubies/ruby-1.8.7-p358/bin/gem
~/Code/playground (master *) $ gem --version
1.3.7
~/Code/playground (master *) $ gem list
*** LOCAL GEMS ***
~/Code/playground (master *) $ gem install savon -v0.9.8
Building native extensions. This could take a while...
Successfully installed builder-3.0.0
Successfully installed nori-1.1.0
Successfully installed rack-1.4.1
Successfully installed httpi-0.9.5
Successfully installed nokogiri-1.5.0
Successfully installed wasabi-2.1.0
Successfully installed gyoku-0.4.4
Successfully installed akami-1.0.0
Successfully installed savon-0.9.8
9 gems installed
~/Code/playground (master *) $ gem
WARNING: #<ArgumentError: Illformed requirement ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"]>
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{savon}
s.version = "0.9.8"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Daniel Harrington"]
s.date = %q{2012-02-15}
s.description = %q{Ruby's heavy metal SOAP client}
s.email = %q{me@rubiii.com}
s.files = [".gitignore", ".rspec", ".travis.yml", ".yardopts", "CHANGELOG.md", "Gemfile", "LICENSE", "README.md", "Rakefile", "lib/savon.rb", "lib/savon/client.rb", "lib/savon/config.rb", "lib/savon/core_ext/object.rb", "lib/savon/core_ext/string.rb", "lib/savon/error.rb", "lib/savon/hooks/group.rb", "lib/savon/hooks/hook.rb", "lib/savon/http/error.rb", "lib/savon/model.rb", "lib/savon/soap.rb", "lib/savon/soap/fault.rb", "lib/savon/soap/invalid_response_error.rb", "lib/savon/soap/request.rb", "lib/savon/soap/response.rb", "lib/savon/soap/xml.rb", "lib/savon/version.rb", "lib/savon/wasabi/document.rb", "savon.gemspec", "spec/fixtures/gzip/message.gz", "spec/fixtures/response/another_soap_fault.xml", "spec/fixtures/response/authentication.xml", "spec/fixtures/response/header.xml", "spec/fixtures/response/list.xml", "spec/fixtures/response/multi_ref.xml", "spec/fixtures/response/soap_fault.xml", "spec/fixtures/response/soap_fault12.xml", "spec/fixtures/response/taxcloud.xml", "spec/fixtures/wsdl/authentication.xml", "spec/fixtures/wsdl/lower_camel.xml", "spec/fixtures/wsdl/multiple_namespaces.xml", "spec/fixtures/wsdl/multiple_types.xml", "spec/fixtures/wsdl/taxcloud.xml", "spec/savon/client_spec.rb", "spec/savon/core_ext/object_spec.rb", "spec/savon/core_ext/string_spec.rb", "spec/savon/http/error_spec.rb", "spec/savon/model_spec.rb", "spec/savon/savon_spec.rb", "spec/savon/soap/fault_spec.rb", "spec/savon/soap/request_spec.rb", "spec/savon/soap/response_spec.rb", "spec/savon/soap/xml_spec.rb", "spec/savon/soap_spec.rb", "spec/savon/wasabi/document_spec.rb", "spec/spec_helper.rb", "spec/support/endpoint.rb", "spec/support/fixture.rb"]
s.homepage = %q{http://savonrb.com}
s.require_paths = ["lib"]
s.rubyforge_project = %q{savon}
s.rubygems_version = %q{1.3.7}
s.summary = %q{Heavy metal Ruby SOAP client}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<builder>, [">= 2.1.2"])
s.add_runtime_dependency(%q<nori>, ["~> 1.0"])
s.add_runtime_dependency(%q<httpi>, ["~> 0.9"])
s.add_runtime_dependency(%q<wasabi>, ["~> 2.0"])
s.add_runtime_dependency(%q<akami>, ["~> 1.0"])
s.add_runtime_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_runtime_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
s.add_development_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_development_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_development_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_development_dependency(%q<autotest>, [">= 0"])
s.add_development_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"])
else
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<nori>, ["~> 1.0"])
s.add_dependency(%q<httpi>, ["~> 0.9"])
s.add_dependency(%q<wasabi>, ["~> 2.0"])
s.add_dependency(%q<akami>, ["~> 1.0"])
s.add_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_dependency(%q<autotest>, [">= 0"])
s.add_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"])
end
else
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<nori>, ["~> 1.0"])
s.add_dependency(%q<httpi>, ["~> 0.9"])
s.add_dependency(%q<wasabi>, ["~> 2.0"])
s.add_dependency(%q<akami>, ["~> 1.0"])
s.add_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_dependency(%q<autotest>, [">= 0"])
s.add_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"])
end
end
WARNING: Invalid .gemspec format in '/Users/joerafaniello/.rvm/gems/ruby-1.8.7-p358@savon/specifications/savon-0.9.8.gemspec'
RubyGems is a sophisticated package manager for Ruby. This is a
basic help message containing pointers to more information.
Usage:
gem -h/--help
gem -v/--version
gem command [arguments...] [options...]
Examples:
gem install rake
gem list --local
gem build package.gemspec
gem help install
Further help:
gem help commands list all 'gem' commands
gem help examples show some examples of usage
gem help platforms show information about platforms
gem help <COMMAND> show help on COMMAND
(e.g. 'gem help install')
gem server present a web page at
http://localhost:8808/
with info about installed gems
Further information:
http://rubygems.rubyforge.org
~/Code/playground/test $ gem install bundler
WARNING: #<ArgumentError: Illformed requirement ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"]>
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{savon}
s.version = "0.9.8"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Daniel Harrington"]
s.date = %q{2012-02-15}
s.description = %q{Ruby's heavy metal SOAP client}
s.email = %q{me@rubiii.com}
s.files = [".gitignore", ".rspec", ".travis.yml", ".yardopts", "CHANGELOG.md", "Gemfile", "LICENSE", "README.md", "Rakefile", "lib/savon.rb", "lib/savon/client.rb", "lib/savon/config.rb", "lib/savon/core_ext/object.rb", "lib/savon/core_ext/string.rb", "lib/savon/error.rb", "lib/savon/hooks/group.rb", "lib/savon/hooks/hook.rb", "lib/savon/http/error.rb", "lib/savon/model.rb", "lib/savon/soap.rb", "lib/savon/soap/fault.rb", "lib/savon/soap/invalid_response_error.rb", "lib/savon/soap/request.rb", "lib/savon/soap/response.rb", "lib/savon/soap/xml.rb", "lib/savon/version.rb", "lib/savon/wasabi/document.rb", "savon.gemspec", "spec/fixtures/gzip/message.gz", "spec/fixtures/response/another_soap_fault.xml", "spec/fixtures/response/authentication.xml", "spec/fixtures/response/header.xml", "spec/fixtures/response/list.xml", "spec/fixtures/response/multi_ref.xml", "spec/fixtures/response/soap_fault.xml", "spec/fixtures/response/soap_fault12.xml", "spec/fixtures/response/taxcloud.xml", "spec/fixtures/wsdl/authentication.xml", "spec/fixtures/wsdl/lower_camel.xml", "spec/fixtures/wsdl/multiple_namespaces.xml", "spec/fixtures/wsdl/multiple_types.xml", "spec/fixtures/wsdl/taxcloud.xml", "spec/savon/client_spec.rb", "spec/savon/core_ext/object_spec.rb", "spec/savon/core_ext/string_spec.rb", "spec/savon/http/error_spec.rb", "spec/savon/model_spec.rb", "spec/savon/savon_spec.rb", "spec/savon/soap/fault_spec.rb", "spec/savon/soap/request_spec.rb", "spec/savon/soap/response_spec.rb", "spec/savon/soap/xml_spec.rb", "spec/savon/soap_spec.rb", "spec/savon/wasabi/document_spec.rb", "spec/spec_helper.rb", "spec/support/endpoint.rb", "spec/support/fixture.rb"]
s.homepage = %q{http://savonrb.com}
s.require_paths = ["lib"]
s.rubyforge_project = %q{savon}
s.rubygems_version = %q{1.3.7}
s.summary = %q{Heavy metal Ruby SOAP client}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<builder>, [">= 2.1.2"])
s.add_runtime_dependency(%q<nori>, ["~> 1.0"])
s.add_runtime_dependency(%q<httpi>, ["~> 0.9"])
s.add_runtime_dependency(%q<wasabi>, ["~> 2.0"])
s.add_runtime_dependency(%q<akami>, ["~> 1.0"])
s.add_runtime_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_runtime_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
s.add_development_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_development_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_development_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_development_dependency(%q<autotest>, [">= 0"])
s.add_development_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"])
else
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<nori>, ["~> 1.0"])
s.add_dependency(%q<httpi>, ["~> 0.9"])
s.add_dependency(%q<wasabi>, ["~> 2.0"])
s.add_dependency(%q<akami>, ["~> 1.0"])
s.add_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_dependency(%q<autotest>, [">= 0"])
s.add_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"])
end
else
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<nori>, ["~> 1.0"])
s.add_dependency(%q<httpi>, ["~> 0.9"])
s.add_dependency(%q<wasabi>, ["~> 2.0"])
s.add_dependency(%q<akami>, ["~> 1.0"])
s.add_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_dependency(%q<autotest>, [">= 0"])
s.add_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"])
end
end
WARNING: Invalid .gemspec format in '/Users/joerafaniello/.rvm/gems/ruby-1.8.7-p358@savon/specifications/savon-0.9.8.gemspec'
WARNING: #<ArgumentError: Illformed requirement ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"]>
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{savon}
s.version = "0.9.8"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Daniel Harrington"]
s.date = %q{2012-02-15}
s.description = %q{Ruby's heavy metal SOAP client}
s.email = %q{me@rubiii.com}
s.files = [".gitignore", ".rspec", ".travis.yml", ".yardopts", "CHANGELOG.md", "Gemfile", "LICENSE", "README.md", "Rakefile", "lib/savon.rb", "lib/savon/client.rb", "lib/savon/config.rb", "lib/savon/core_ext/object.rb", "lib/savon/core_ext/string.rb", "lib/savon/error.rb", "lib/savon/hooks/group.rb", "lib/savon/hooks/hook.rb", "lib/savon/http/error.rb", "lib/savon/model.rb", "lib/savon/soap.rb", "lib/savon/soap/fault.rb", "lib/savon/soap/invalid_response_error.rb", "lib/savon/soap/request.rb", "lib/savon/soap/response.rb", "lib/savon/soap/xml.rb", "lib/savon/version.rb", "lib/savon/wasabi/document.rb", "savon.gemspec", "spec/fixtures/gzip/message.gz", "spec/fixtures/response/another_soap_fault.xml", "spec/fixtures/response/authentication.xml", "spec/fixtures/response/header.xml", "spec/fixtures/response/list.xml", "spec/fixtures/response/multi_ref.xml", "spec/fixtures/response/soap_fault.xml", "spec/fixtures/response/soap_fault12.xml", "spec/fixtures/response/taxcloud.xml", "spec/fixtures/wsdl/authentication.xml", "spec/fixtures/wsdl/lower_camel.xml", "spec/fixtures/wsdl/multiple_namespaces.xml", "spec/fixtures/wsdl/multiple_types.xml", "spec/fixtures/wsdl/taxcloud.xml", "spec/savon/client_spec.rb", "spec/savon/core_ext/object_spec.rb", "spec/savon/core_ext/string_spec.rb", "spec/savon/http/error_spec.rb", "spec/savon/model_spec.rb", "spec/savon/savon_spec.rb", "spec/savon/soap/fault_spec.rb", "spec/savon/soap/request_spec.rb", "spec/savon/soap/response_spec.rb", "spec/savon/soap/xml_spec.rb", "spec/savon/soap_spec.rb", "spec/savon/wasabi/document_spec.rb", "spec/spec_helper.rb", "spec/support/endpoint.rb", "spec/support/fixture.rb"]
s.homepage = %q{http://savonrb.com}
s.require_paths = ["lib"]
s.rubyforge_project = %q{savon}
s.rubygems_version = %q{1.3.7}
s.summary = %q{Heavy metal Ruby SOAP client}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<builder>, [">= 2.1.2"])
s.add_runtime_dependency(%q<nori>, ["~> 1.0"])
s.add_runtime_dependency(%q<httpi>, ["~> 0.9"])
s.add_runtime_dependency(%q<wasabi>, ["~> 2.0"])
s.add_runtime_dependency(%q<akami>, ["~> 1.0"])
s.add_runtime_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_runtime_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
s.add_development_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_development_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_development_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_development_dependency(%q<autotest>, [">= 0"])
s.add_development_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"])
else
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<nori>, ["~> 1.0"])
s.add_dependency(%q<httpi>, ["~> 0.9"])
s.add_dependency(%q<wasabi>, ["~> 2.0"])
s.add_dependency(%q<akami>, ["~> 1.0"])
s.add_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_dependency(%q<autotest>, [">= 0"])
s.add_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"])
end
else
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<nori>, ["~> 1.0"])
s.add_dependency(%q<httpi>, ["~> 0.9"])
s.add_dependency(%q<wasabi>, ["~> 2.0"])
s.add_dependency(%q<akami>, ["~> 1.0"])
s.add_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_dependency(%q<autotest>, [">= 0"])
s.add_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x1055d0cb8> 4.5.0"])
end
end
WARNING: Invalid .gemspec format in '/Users/joerafaniello/.rvm/gems/ruby-1.8.7-p358@savon/specifications/savon-0.9.8.gemspec'
Successfully installed bundler-1.0.22
1 gem installed
~/Code/playground/test $ cat Gemfile
source 'http://rubygems.org'
gem "savon"
~/Code/playground/test $ bundle check
WARNING: #<ArgumentError: Illformed requirement ["#<YAML::Syck::DefaultKey:0x111f5d298> 4.5.0"]>
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{savon}
s.version = "0.9.8"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Daniel Harrington"]
s.date = %q{2012-02-15}
s.description = %q{Ruby's heavy metal SOAP client}
s.email = %q{me@rubiii.com}
s.files = [".gitignore", ".rspec", ".travis.yml", ".yardopts", "CHANGELOG.md", "Gemfile", "LICENSE", "README.md", "Rakefile", "lib/savon.rb", "lib/savon/client.rb", "lib/savon/config.rb", "lib/savon/core_ext/object.rb", "lib/savon/core_ext/string.rb", "lib/savon/error.rb", "lib/savon/hooks/group.rb", "lib/savon/hooks/hook.rb", "lib/savon/http/error.rb", "lib/savon/model.rb", "lib/savon/soap.rb", "lib/savon/soap/fault.rb", "lib/savon/soap/invalid_response_error.rb", "lib/savon/soap/request.rb", "lib/savon/soap/response.rb", "lib/savon/soap/xml.rb", "lib/savon/version.rb", "lib/savon/wasabi/document.rb", "savon.gemspec", "spec/fixtures/gzip/message.gz", "spec/fixtures/response/another_soap_fault.xml", "spec/fixtures/response/authentication.xml", "spec/fixtures/response/header.xml", "spec/fixtures/response/list.xml", "spec/fixtures/response/multi_ref.xml", "spec/fixtures/response/soap_fault.xml", "spec/fixtures/response/soap_fault12.xml", "spec/fixtures/response/taxcloud.xml", "spec/fixtures/wsdl/authentication.xml", "spec/fixtures/wsdl/lower_camel.xml", "spec/fixtures/wsdl/multiple_namespaces.xml", "spec/fixtures/wsdl/multiple_types.xml", "spec/fixtures/wsdl/taxcloud.xml", "spec/savon/client_spec.rb", "spec/savon/core_ext/object_spec.rb", "spec/savon/core_ext/string_spec.rb", "spec/savon/http/error_spec.rb", "spec/savon/model_spec.rb", "spec/savon/savon_spec.rb", "spec/savon/soap/fault_spec.rb", "spec/savon/soap/request_spec.rb", "spec/savon/soap/response_spec.rb", "spec/savon/soap/xml_spec.rb", "spec/savon/soap_spec.rb", "spec/savon/wasabi/document_spec.rb", "spec/spec_helper.rb", "spec/support/endpoint.rb", "spec/support/fixture.rb"]
s.homepage = %q{http://savonrb.com}
s.require_paths = ["lib"]
s.rubyforge_project = %q{savon}
s.rubygems_version = %q{1.3.7}
s.summary = %q{Heavy metal Ruby SOAP client}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<builder>, [">= 2.1.2"])
s.add_runtime_dependency(%q<nori>, ["~> 1.0"])
s.add_runtime_dependency(%q<httpi>, ["~> 0.9"])
s.add_runtime_dependency(%q<wasabi>, ["~> 2.0"])
s.add_runtime_dependency(%q<akami>, ["~> 1.0"])
s.add_runtime_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_runtime_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
s.add_development_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_development_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_development_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_development_dependency(%q<autotest>, [">= 0"])
s.add_development_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x111f5d298> 4.5.0"])
else
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<nori>, ["~> 1.0"])
s.add_dependency(%q<httpi>, ["~> 0.9"])
s.add_dependency(%q<wasabi>, ["~> 2.0"])
s.add_dependency(%q<akami>, ["~> 1.0"])
s.add_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_dependency(%q<autotest>, [">= 0"])
s.add_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x111f5d298> 4.5.0"])
end
else
s.add_dependency(%q<builder>, [">= 2.1.2"])
s.add_dependency(%q<nori>, ["~> 1.0"])
s.add_dependency(%q<httpi>, ["~> 0.9"])
s.add_dependency(%q<wasabi>, ["~> 2.0"])
s.add_dependency(%q<akami>, ["~> 1.0"])
s.add_dependency(%q<gyoku>, [">= 0.4.0"])
s.add_dependency(%q<nokogiri>, [">= 1.4.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<rspec>, ["~> 2.5.0"])
s.add_dependency(%q<mocha>, ["~> 0.9.8"])
s.add_dependency(%q<timecop>, ["~> 0.3.5"])
s.add_dependency(%q<autotest>, [">= 0"])
s.add_dependency(%q<ZenTest>, ["#<YAML::Syck::DefaultKey:0x111f5d298> 4.5.0"])
end
end
WARNING: Invalid .gemspec format in '/Users/joerafaniello/.rvm/gems/ruby-1.8.7-p358@savon/specifications/savon-0.9.8.gemspec'
The following gems are missing
* savon (0.9.8)
Install missing gems with `bundle install`
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.