Create a gist now

Instantly share code, notes, and snippets.

What would you like to do?
Travis CI config to build against Qt5.0 on Ubuntu 12.04. Requires installing a PPA and certain packages for qt5 support.
before_install:
- sudo add-apt-repository --yes ppa:ubuntu-sdk-team/ppa
- sudo apt-get update -qq
- sudo apt-get install -qq qt5-qmake qtbase5-dev qtdeclarative5-dev libqt5webkit5-dev libsqlite3-dev
script:
- qmake -qt=qt5 -v
- qmake -qt=qt5
- make

pcolby commented Sep 24, 2013

Very helpful, thanks! :)

just what i was needing , thx !

Thanks! I was trying to get my capybara-webkit tests to pass after we started using React, and here's the version that finally got it working for me after some trial and error:

before_install:
  - sudo add-apt-repository --yes ppa:ubuntu-sdk-team/ppa
  - sudo apt-get update -qq
  - sudo apt-get install -qq libqt5webkit5-dev qtdeclarative5-dev
  - export QMAKE=/usr/lib/x86_64-linux-gnu/qt5/bin/qmake

supamii commented Oct 29, 2016

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment