Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
17-03-03 22:09:01 ERROR (MainThread) [homeassistant.components.media_player] Error while setting up platform openhome
Traceback (most recent call last):
File "/usr/src/app/homeassistant/helpers/entity_component.py", line 151, in _async_setup_platform
entity_platform.add_entities, discovery_info
File "uvloop/future.pyx", line 230, in __iter__ (uvloop/loop.c:110600)
File "uvloop/future.pyx", line 432, in uvloop.loop.BaseTask._fast_wakeup (uvloop/loop.c:113980)
File "uvloop/future.pyx", line 101, in uvloop.loop.BaseFuture._result_impl (uvloop/loop.c:108900)
File "/usr/local/lib/python3.5/concurrent/futures/thread.py", line 55, in run
result = self.fn(*self.args, **self.kwargs)
File "/usr/src/app/homeassistant/components/media_player/openhome.py", line 44, in setup_platform
add_devices([device], True)
File "/usr/src/app/homeassistant/helpers/entity_component.py", line 305, in add_entities
entity.update()
File "/usr/src/app/homeassistant/components/media_player/openhome.py", line 77, in update
self._volume_level = self._device.VolumeLevel()
File "/usr/local/lib/python3.5/site-packages/openhomedevice/Device.py", line 148, in VolumeLevel
return int(volumeXml[0].find("{urn:av-openhome-org:service:Volume:2}VolumeResponse/Value").text)
AttributeError: 'NoneType' object has no attribute 'text'
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.