Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
addressable gem dependency not bundled
My bundle aliases:
b = bundle
be = b exec
bi = b install --path vendor
bu = b update
bil = bi --local
binit = bi && b package --all && echo "vendor/ruby" >> .gitignore
# Note: my comments are in [#square brackets like this]
$ bi
Using rake (0.9.2.2)
Using abstract (1.0.0)
Using activesupport (3.0.7)
Using builder (2.1.2)
Using i18n (0.5.0)
Using activemodel (3.0.7)
Using erubis (2.6.6)
Using rack (1.2.5)
Using rack-mount (0.6.14)
Using rack-test (0.5.7)
Using tzinfo (0.3.32)
Using actionpack (3.0.7)
Using mime-types (1.19)
Using polyglot (0.3.3)
Using treetop (1.4.10)
Using mail (2.2.19)
Using actionmailer (3.0.7)
Using arel (2.0.10)
Using activerecord (3.0.7)
Using activeresource (3.0.7)
Using highline (1.6.11)
Using net-ssh (2.3.0)
Using net-scp (1.0.4)
Using net-sftp (2.0.5)
Using net-ssh-gateway (1.1.0)
Using capistrano (2.6.0)
Using nokogiri (1.5.5)
Using ffi (1.1.5)
Using childprocess (0.3.5)
[# ]
[# Note the version of 'libwebsocket' here->]
Using libwebsocket (0.1.5)
[# ]
Using multi_json (1.3.6)
Using rubyzip (0.9.9)
Using selenium-webdriver (2.25.0)
Using xpath (0.1.4)
Using capybara (1.1.2)
Using net-http-digest_auth (1.2)
Using net-http-persistent (1.9)
Using webrobots (0.0.13)
Using mechanize (2.0.1)
Using capybara-mechanize (0.3.0.rc3)
Using diff-lcs (1.1.3)
Using json (1.7.5)
Using gherkin (2.11.2)
Using cucumber (1.2.1)
Using cucumber-rails (1.3.0)
Using escape_utils (0.2.4)
Using sexp_processor (3.1.0)
Using ruby_parser (2.3.1)
Using flog (2.5.1)
Using headless (0.2.2)
Using http_configuration (1.0.4)
Using jasmine-core (1.1.0)
Using rspec-core (2.8.0)
Using rspec-expectations (2.8.0)
Using rspec-mocks (2.8.0)
Using rspec (2.8.0)
Using jasmine (1.1.2)
Using thor (0.14.6)
Using railties (3.0.7)
Using jquery-rails (1.0.19)
Using jslint_on_rails (1.0.7)
Using kgio (2.7.2)
Using metaclass (0.0.1)
Using mocha (0.10.5)
Using newrelic_rpm (3.3.2)
Using bundler (1.2.2)
Using rails (3.0.7)
Using rcov (0.9.11)
Using rspec-rails (2.8.1)
Using sass (3.1.7)
Using simplecov-html (0.4.5)
Using simplecov (0.4.2)
Using simplecov-rcov (0.2.0)
Using tabs_on_rails (2.0.1)
Using unicorn (3.7.0)
Your bundle is complete! It was installed into ./vendor
[# ]
[# Note that 'addressable' was not included in any of the above.]
[# ]
$ more Gemfile
source 'http://rubygems.org'
gem 'rails', '3.0.7'
gem 'unicorn', '3.7.0' # Use unicorn as the web server
gem 'capistrano', '2.6.0' # Deploy with Capistrano
gem 'tabs_on_rails', '2.0.1'
gem 'escape_utils' #http://crimpycode.brennonbortz.com/?p=42
gem 'jquery-rails', '>= 1.0.12'
gem 'sass', '3.1.7'
gem 'newrelic_rpm'
group :development, :test do
gem 'jslint_on_rails'
gem 'cucumber-rails'
gem 'capybara-mechanize', '0.3.0.rc3'
gem 'rspec-rails'
gem 'jasmine'
gem 'headless'
gem 'http_configuration'
gem 'mocha'
end
group :test do
gem 'simplecov' , '0.4.2'
gem 'simplecov-rcov', '0.2.0'
gem 'rcov', '~>0.9.11'
gem 'flog', '2.5.1'
end
$ more Gemfile.lock
GEM
remote: http://rubygems.org/
specs:
abstract (1.0.0)
actionmailer (3.0.7)
actionpack (= 3.0.7)
mail (~> 2.2.15)
actionpack (3.0.7)
activemodel (= 3.0.7)
activesupport (= 3.0.7)
builder (~> 2.1.2)
erubis (~> 2.6.6)
i18n (~> 0.5.0)
rack (~> 1.2.1)
rack-mount (~> 0.6.14)
rack-test (~> 0.5.7)
tzinfo (~> 0.3.23)
activemodel (3.0.7)
activesupport (= 3.0.7)
builder (~> 2.1.2)
i18n (~> 0.5.0)
activerecord (3.0.7)
activemodel (= 3.0.7)
activesupport (= 3.0.7)
arel (~> 2.0.2)
tzinfo (~> 0.3.23)
activeresource (3.0.7)
activemodel (= 3.0.7)
activesupport (= 3.0.7)
activesupport (3.0.7)
[# ]
[# Note: No 'addressable' here-> ]
[# ]
arel (2.0.10)
builder (2.1.2)
capistrano (2.6.0)
highline
net-scp (>= 1.0.0)
net-sftp (>= 2.0.0)
net-ssh (>= 2.0.14)
net-ssh-gateway (>= 1.1.0)
capybara (1.1.2)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
capybara-mechanize (0.3.0.rc3)
capybara (~> 1.1.0)
mechanize (~> 2.0.0)
childprocess (0.3.5)
ffi (~> 1.0, >= 1.0.6)
cucumber (1.2.1)
builder (>= 2.1.2)
diff-lcs (>= 1.1.3)
gherkin (~> 2.11.0)
json (>= 1.4.6)
cucumber-rails (1.3.0)
capybara (>= 1.1.2)
cucumber (>= 1.1.8)
nokogiri (>= 1.5.0)
diff-lcs (1.1.3)
erubis (2.6.6)
abstract (>= 1.0.0)
escape_utils (0.2.4)
ffi (1.1.5)
flog (2.5.1)
ruby_parser (~> 2.0)
sexp_processor (~> 3.0)
gherkin (2.11.2)
json (>= 1.4.6)
headless (0.2.2)
highline (1.6.11)
http_configuration (1.0.4)
i18n (0.5.0)
jasmine (1.1.2)
jasmine-core (>= 1.1.0)
rack (>= 1.1)
rspec (>= 1.3.1)
selenium-webdriver (>= 0.1.3)
jasmine-core (1.1.0)
jquery-rails (1.0.19)
railties (~> 3.0)
thor (~> 0.14)
jslint_on_rails (1.0.7)
json (1.7.5)
kgio (2.7.2)
[# ]
[# Note: dependency of 'libwebsocket' on 'addressable'-> ]
libwebsocket (0.1.5)
addressable
[# ]
mail (2.2.19)
activesupport (>= 2.3.6)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mechanize (2.0.1)
net-http-digest_auth (~> 1.1, >= 1.1.1)
net-http-persistent (~> 1.8)
nokogiri (~> 1.4)
webrobots (~> 0.0, >= 0.0.9)
metaclass (0.0.1)
mime-types (1.19)
mocha (0.10.5)
metaclass (~> 0.0.1)
multi_json (1.3.6)
net-http-digest_auth (1.2)
net-http-persistent (1.9)
net-scp (1.0.4)
net-ssh (>= 1.99.1)
net-sftp (2.0.5)
net-ssh (>= 2.0.9)
net-ssh (2.3.0)
net-ssh-gateway (1.1.0)
net-ssh (>= 1.99.1)
newrelic_rpm (3.3.2)
nokogiri (1.5.5)
polyglot (0.3.3)
rack (1.2.5)
rack-mount (0.6.14)
rack (>= 1.0.0)
rack-test (0.5.7)
rack (>= 1.0)
rails (3.0.7)
actionmailer (= 3.0.7)
actionpack (= 3.0.7)
activerecord (= 3.0.7)
activeresource (= 3.0.7)
activesupport (= 3.0.7)
bundler (~> 1.0)
railties (= 3.0.7)
railties (3.0.7)
actionpack (= 3.0.7)
activesupport (= 3.0.7)
rake (>= 0.8.7)
thor (~> 0.14.4)
rake (0.9.2.2)
rcov (0.9.11)
rspec (2.8.0)
rspec-core (~> 2.8.0)
rspec-expectations (~> 2.8.0)
rspec-mocks (~> 2.8.0)
rspec-core (2.8.0)
rspec-expectations (2.8.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.8.0)
rspec-rails (2.8.1)
actionpack (>= 3.0)
activesupport (>= 3.0)
railties (>= 3.0)
rspec (~> 2.8.0)
ruby_parser (2.3.1)
sexp_processor (~> 3.0)
rubyzip (0.9.9)
sass (3.1.7)
selenium-webdriver (2.25.0)
childprocess (>= 0.2.5)
libwebsocket (~> 0.1.3)
multi_json (~> 1.0)
rubyzip
sexp_processor (3.1.0)
simplecov (0.4.2)
simplecov-html (~> 0.4.4)
simplecov-html (0.4.5)
simplecov-rcov (0.2.0)
tabs_on_rails (2.0.1)
thor (0.14.6)
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
tzinfo (0.3.32)
unicorn (3.7.0)
kgio (~> 2.3)
rack
webrobots (0.0.13)
xpath (0.1.4)
nokogiri (~> 1.3)
PLATFORMS
ruby
DEPENDENCIES
capistrano (= 2.6.0)
capybara-mechanize (= 0.3.0.rc3)
cucumber-rails
escape_utils
flog (= 2.5.1)
headless
http_configuration
jasmine
jquery-rails (>= 1.0.12)
jslint_on_rails
mocha
newrelic_rpm
rails (= 3.0.7)
rcov (~> 0.9.11)
rspec-rails
sass (= 3.1.7)
simplecov (= 0.4.2)
simplecov-rcov (= 0.2.0)
tabs_on_rails (= 2.0.1)
unicorn (= 3.7.0)
$ bundle config
Settings are listed in order of priority. The top value will be used.
path
Set for your local app (/Users/myname/git/myproj/.bundle/config): "vendor"
disable_shared_gems
Set for your local app (/Users/myname/git/myproj/.bundle/config): "1"
$ ruby -v
ruby 1.9.2p320 (2012-04-20 revision 35421) [x86_64-darwin11.4.2]
$ gem -v
1.8.24
$ rvm -v
rvm 1.16.20 (stable) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]
$ gem list rubygems-bundler
*** LOCAL GEMS ***
rubygems-bundler (1.1.0)
$ be gem list rubygems-bundler
*** LOCAL GEMS ***
$ bundle exec gem list rubygems-bundler
*** LOCAL GEMS ***
$ be gem list open_gem
*** LOCAL GEMS ***
$ gem list open_gem
*** LOCAL GEMS ***
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.