Skip to content

Instantly share code, notes, and snippets.

🚀
Going to the moon

Lane Rettig lrettig

🚀
Going to the moon
Block or report user

Report or block lrettig

Hide content and notifications from this user.

Learn more about blocking users

Contact Support about this user’s behavior.

Learn more about reporting abuse

Report abuse
View GitHub Profile
View gist:6c74f79217e02dd012cdb743f1a59c56
2017-05-09T20:59:16.484801+00:00 heroku[web.1]: Restarting
2017-05-09T20:59:16.485198+00:00 heroku[web.1]: State changed from up to starting
2017-05-09T20:59:17.314097+00:00 heroku[web.1]: Stopping all processes with SIGTERM
2017-05-09T20:59:17.357025+00:00 app[web.1]: [2017-05-09 20:59:17] FATAL SignalException: SIGTERM
2017-05-09T20:59:17.357034+00:00 app[web.1]: /app/vendor/ruby-2.3.1/lib/ruby/2.3.0/webrick/server.rb:177:in `select'
2017-05-09T20:59:17.357035+00:00 app[web.1]: /app/vendor/ruby-2.3.1/lib/ruby/2.3.0/webrick/server.rb:177:in `block in start'
2017-05-09T20:59:17.357036+00:00 app[web.1]: /app/vendor/ruby-2.3.1/lib/ruby/2.3.0/webrick/server.rb:33:in `start'
2017-05-09T20:59:17.357037+00:00 app[web.1]: /app/vendor/ruby-2.3.1/lib/ruby/2.3.0/webrick/server.rb:164:in `start'
2017-05-09T20:59:17.357038+00:00 app[web.1]: /app/vendor/bundle/ruby/2.3.0/gems/rack-1.6.5/lib/rack/handler/webrick.rb:34:in `run'
2017-05-09T20:59:17.357038+00:00 app[web.1]: /app/vendor/bundle/ruby/2.3.0/gems/rack-1.6.5/
View gist:82e0f81b30304ed3fffe40edd078a82d
remote: Compressing source files... done.
remote: Building source:
remote:
remote: -----> Ruby app detected
remote: -----> Compiling Ruby/Rack
remote: -----> Using Ruby version: ruby-2.3.1
remote: -----> Installing dependencies using bundler 1.13.7
remote: Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
remote: The git source `git://github.com/MaxPleaner/sinatra-assetpack.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.
remote: Warning: the running version of Bundler (1.13.7) is older than the version that created the lockfile (1.14.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.
@lrettig
lrettig / gist:b34d9b74fac88fe6324a08ddb2efb632
Created Jul 13, 2016
Add react-native-swiper to RNPlay
View gist:b34d9b74fac88fe6324a08ddb2efb632
/*
* Copyright (c) 2015-present, Facebook, Inc.
* All rights reserved.
*
* This source code is licensed under the BSD-style license found in the
* LICENSE file in the root directory of this source tree. An additional grant
* of patent rights can be found in the PATENTS file in the same directory.
*
*/
View auth.py
import facebook
from flask.ext.security.decorators import anonymous_user_required
from flask.ext.social.utils import get_provider_or_404
from flask.ext.social.views import _security, login_handler
@app.route('/login_social/<provider_id>', methods=['GET', 'POST'])
@anonymous_user_required
def login_social(provider_id=None):
"""
Login via credentials from a social network. For now only supports
You can’t perform that action at this time.