Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
troubles installing rustc (gcc, libc-dev) on Ubuntu 20.4
#
# part of https://askubuntu.com/questions/1402336/apt-trying-to-fetch-versions-not-available-in-archive-ubuntu-com-ubuntu-pool-mai?noredirect=1#comment2434286_1402336
#
(rio-viz) geoadmin@geonix:~$ sudo mv /var/lib/apt/lists/* apt-temp/
[sudo] password for geoadmin:
(rio-viz) geoadmin@geonix:~$ ls /var/lib/apt/lists
(rio-viz) geoadmin@geonix:~$ sudo apt update
Get:1 https://mirror.it.ubc.ca/ubuntu focal InRelease [265 kB]
Get:2 https://download.docker.com/linux/ubuntu focal InRelease [57.7 kB]
Get:3 http://archive.ubuntu.com/ubuntu focal InRelease [265 kB]
Get:4 https://download.docker.com/linux/ubuntu focal/stable amd64 Packages [15.5 kB]
Get:5 https://mirror.it.ubc.ca/ubuntu focal/main amd64 Packages [970 kB]
Get:6 https://mirror.it.ubc.ca/ubuntu focal/main Translation-en [506 kB]
Get:7 https://mirror.it.ubc.ca/ubuntu focal/main amd64 c-n-f Metadata [29.5 kB]
Get:8 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:9 http://archive.ubuntu.com/ubuntu focal-backports InRelease [108 kB]
Get:10 http://archive.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Get:11 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages [970 kB]
Get:12 http://archive.ubuntu.com/ubuntu focal/main Translation-en [506 kB]
Get:13 http://archive.ubuntu.com/ubuntu focal/main amd64 c-n-f Metadata [29.5 kB]
Get:14 http://archive.ubuntu.com/ubuntu focal/restricted amd64 Packages [22.0 kB]
Get:15 http://archive.ubuntu.com/ubuntu focal/restricted Translation-en [6,212 B]
Get:16 http://archive.ubuntu.com/ubuntu focal/restricted amd64 c-n-f Metadata [392 B]
Get:17 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages [8,628 kB]
Get:18 http://archive.ubuntu.com/ubuntu focal/universe Translation-en [5,124 kB]
Get:19 http://archive.ubuntu.com/ubuntu focal/universe amd64 c-n-f Metadata [265 kB]
Get:20 http://archive.ubuntu.com/ubuntu focal/multiverse amd64 Packages [144 kB]
Get:21 http://archive.ubuntu.com/ubuntu focal/multiverse Translation-en [104 kB]
Get:22 http://archive.ubuntu.com/ubuntu focal/multiverse amd64 c-n-f Metadata [9,136 B]
Reading package lists... Done
E: Release file for http://archive.ubuntu.com/ubuntu/dists/focal-updates/InRelease is not valid yet (invalid for another 6h 10min 7s). Updates for this repository will not be applied.
E: Release file for http://archive.ubuntu.com/ubuntu/dists/focal-backports/InRelease is not valid yet (invalid for another 5h 6min 56s). Updates for this repository will not be applied.
E: Release file for http://archive.ubuntu.com/ubuntu/dists/focal-security/InRelease is not valid yet (invalid for another 5h 5min 11s). Updates for this repository will not be applied.
(rio-viz) geoadmin@geonix:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
(rio-viz) geoadmin@geonix:~$ sudo apt install rustc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
rustc : Depends: gcc but it is not going to be installed
Depends: libc-dev
Recommends: cargo (>= 0.42.0~~) but it is not going to be installed
Recommends: cargo (< 0.43.0~~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
(rio-viz) geoadmin@geonix:~$ sudo apt install gcc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
gcc : Depends: gcc-9 (>= 9.3.0-3~) but it is not going to be installed
Recommends: libc6-dev but it is not going to be installed or
libc-dev
E: Unable to correct problems, you have held broken packages.
(rio-viz) geoadmin@geonix:~$ sudo apt install libc-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libc6-dev' instead of 'libc-dev'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libc6-dev : Depends: libc6 (= 2.31-0ubuntu9) but 2.31-0ubuntu9.2 is to be installed
E: Unable to correct problems, you have held broken packages.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment