Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
emerge --oneshot portage
* IMPORTANT: 17 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.
Calculating dependencies... done!
[ebuild N ] sys-apps/install-xattr-0.5
[ebuild NS ] dev-lang/python-3.4.3-r1 [2.7.9-r1, 3.3.5-r1] USE="gdbm ipv6 ncurses readline ssl threads xml -build -examples -hardened -sqlite -tk -wininst"
[ebuild N ] dev-python/packaging-15.3-r2 USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild U ] dev-python/setuptools-18.4 [7.0] PYTHON_TARGETS="python3_4* -python3_3* (-python3_5)"
[ebuild N ] dev-python/certifi-2015.11.20 PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild N ] dev-python/pyxattr-0.5.5 USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) -python3_3 (-python3_5)"
[ebuild U ] sys-apps/portage-2.2.28 [2.2.14] USE="xattr*" PYTHON_TARGETS="python3_4* -python3_3* (-python3_5)"
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
sys-apps/portage:0
(sys-apps/portage-2.2.28:0/0::gentoo, ebuild scheduled for merge) pulled in by
sys-apps/portage (Argument)
(sys-apps/portage-2.2.14:0/0::gentoo, installed) pulled in by
sys-apps/portage[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
dev-python/setuptools:0
(dev-python/setuptools-18.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/certifi-2015.11.20:0/0::gentoo, ebuild scheduled for merge)
dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)
(dev-python/setuptools-7.0:0/0::gentoo, installed) pulled in by
dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/pip-1.5.6:0/0::gentoo, installed)
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.