Skip to content

Instantly share code, notes, and snippets.

@mental32 mental32/foobar Secret
Created Sep 28, 2019

Embed
What would you like to do?
Compiling t/e/f.pyx because it changed.
Compiling t/e/__init__.pyx because it changed.
[1/2] Cythonizing t/e/__init__.pyx
[2/2] Cythonizing t/e/f.pyx
running install
running bdist_egg
running egg_info
creating foob.egg-info
writing foob.egg-info/PKG-INFO
writing dependency_links to foob.egg-info/dependency_links.txt
writing top-level names to foob.egg-info/top_level.txt
writing manifest file 'foob.egg-info/SOURCES.txt'
package init file 't/e/__init__.py' not found (or not a regular file)
reading manifest file 'foob.egg-info/SOURCES.txt'
writing manifest file 'foob.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build
creating build/lib.linux-x86_64-3.7
creating build/lib.linux-x86_64-3.7/t
copying t/__init__.py -> build/lib.linux-x86_64-3.7/t
warning: build_py: byte-compiling is disabled, skipping.
running build_ext
building 't.e.f' extension
creating build/temp.linux-x86_64-3.7
creating build/temp.linux-x86_64-3.7/t
creating build/temp.linux-x86_64-3.7/t/e
gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -fPIC -I/usr/include/python3.7m -c t/e/f.c -o build/temp.linux-x86_64-3.7/t/e/f.o
creating build/lib.linux-x86_64-3.7/t/e
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now build/temp.linux-x86_64-3.7/t/e/f.o -L/usr/lib -lpython3.7m -o build/lib.linux-x86_64-3.7/t/e/f.cpython-37m-x86_64-linux-gnu.so
building 't.e.__init__' extension
gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -fPIC -I/usr/include/python3.7m -c t/e/__init__.c -o build/temp.linux-x86_64-3.7/t/e/__init__.o
gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now build/temp.linux-x86_64-3.7/t/e/__init__.o -L/usr/lib -lpython3.7m -o build/lib.linux-x86_64-3.7/t/e/__init__.cpython-37m-x86_64-linux-gnu.so
creating build/bdist.linux-x86_64
creating build/bdist.linux-x86_64/egg
creating build/bdist.linux-x86_64/egg/t
creating build/bdist.linux-x86_64/egg/t/e
copying build/lib.linux-x86_64-3.7/t/e/f.cpython-37m-x86_64-linux-gnu.so -> build/bdist.linux-x86_64/egg/t/e
copying build/lib.linux-x86_64-3.7/t/e/__init__.cpython-37m-x86_64-linux-gnu.so -> build/bdist.linux-x86_64/egg/t/e
copying build/lib.linux-x86_64-3.7/t/__init__.py -> build/bdist.linux-x86_64/egg/t
warning: install_lib: byte-compiling is disabled, skipping.
creating stub loader for t/e/f.cpython-37m-x86_64-linux-gnu.so
creating stub loader for t/e/__init__.cpython-37m-x86_64-linux-gnu.so
warning: install_lib: byte-compiling is disabled, skipping.
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying foob.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying foob.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying foob.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying foob.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
writing build/bdist.linux-x86_64/egg/EGG-INFO/native_libs.txt
zip_safe flag not set; analyzing archive contents...
creating dist
creating 'dist/foob-0.0.1-py3.7-linux-x86_64.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing foob-0.0.1-py3.7-linux-x86_64.egg
Removing /home/mental/.local/lib/python3.7/site-packages/foob-0.0.1-py3.7-linux-x86_64.egg
Copying foob-0.0.1-py3.7-linux-x86_64.egg to /home/mental/.local/lib/python3.7/site-packages
foob 0.0.1 is already the active version in easy-install.pth
Installed /home/mental/.local/lib/python3.7/site-packages/foob-0.0.1-py3.7-linux-x86_64.egg
Processing dependencies for foob==0.0.1
Finished processing dependencies for foob==0.0.1
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.