public
Created

Upgrading from Grails 2.0 to 2.2.1

  • Download Gist
grails-2.0-to-2.2.diff
Diff
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55
diff --git a/application.properties b/application.properties
index 9a0696b..ddd7039 100644
--- a/application.properties
+++ b/application.properties
@@ -1,6 +1,6 @@
#Grails Metadata file
-#Tue Jun 12 11:35:19 MDT 2012
-app.grails.version=2.0.3
+#Wed Mar 13 20:19:13 MDT 2013
+app.grails.version=2.2.1
app.name=happytrails
app.servlet.version=2.5
app.version=0.1
@@ -11,7 +11,7 @@ plugins.famfamfam=1.0.1
plugins.feeds=1.5
plugins.geb=0.7.0
plugins.jquery-ui=1.8.15
-plugins.mail=1.0
+plugins.mail=1.0.1
plugins.quartz=1.0-RC2
plugins.rateable=0.7.1
plugins.searchable=0.6.3
diff --git a/grails-app/conf/BuildConfig.groovy b/grails-app/conf/BuildConfig.groovy
index 0b987fd..e1bbcfe 100644
--- a/grails-app/conf/BuildConfig.groovy
+++ b/grails-app/conf/BuildConfig.groovy
@@ -23,8 +23,8 @@ grails.project.dependency.resolution = {
mavenCentral()
}
- def gebVersion = "0.6.3"
- def seleniumVersion = "2.21.0"
+ def gebVersion = "0.9.0-RC-1"
+ def seleniumVersion = "2.27.0"
dependencies {
compile 'postgresql:postgresql:9.1-901-1.jdbc4'
@@ -39,11 +39,16 @@ grails.project.dependency.resolution = {
test('dumbster:dumbster:1.6') {
excludes 'mail', 'activation'
}
+
+ test "org.gebish:geb-spock:$gebVersion"
+ test "org.spockframework:spock-grails-support:0.7-groovy-2.0"
}
plugins {
test ":geb:$gebVersion"
- test ":spock:0.6"
+ test(":spock:0.7") {
+ exclude "spock-grails-support"
+ }
runtime ":hibernate:$grailsVersion"
runtime ":jquery:1.7.1"

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.