Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
YaST takes up 258 MiB on disk
YaST takes up 258 MiB on disk.
Starting with a 2020-09-01 openSUSE Tumbleweed that already has Cockpit installed,
these are the byte sizes of packages installed by "zypper install yast2"
218922718 glibc-locale
16627072 ruby2.7
9940016 ruby2.7-rubygem-nokogiri
3427518 hwinfo
3413184 libruby2_7-2_7
3310778 yast2-core
2589200 yast2
2279763 ruby2.7-rubygem-unf_ext
1378488 yast2-pkg-bindings
1179325 libyui-ncurses13
1095423 ruby2.7-rubygem-simpleidn
949088 libyui13
788911 libjemalloc2
721238 yast2-hardware-detection
686097 augeas-lenses
646032 yast2-ycp-ui-bindings
463280 yast2-ruby-bindings
360824 libxslt1
316728 yast2-perl-bindings
226562 augeas
167706 libx86emu3
129288 libyaml-0-2
129144 ruby2.7-rubygem-unf
115505 ruby2.7-rubygem-ruby-augeas
108310 ruby2.7-rubygem-fast_gettext
63522 ruby2.7-rubygem-cfa
62415 ruby2.7-rubygem-gem2rpm
51387 ruby2.7-rubygem-cheetah
47974 fdupes
38714 ruby-common
34725 perl-gettext
10762 ruby2.7-rubygem-abstract_method
3389 yast2-logs
84 ruby
@mvidner

This comment has been minimized.

Copy link
Owner Author

@mvidner mvidner commented Sep 18, 2020

glibc-locale is required by libyui-ncurses, based on this bug report: https://bugzilla.suse.com/show_bug.cgi?id=849255

@mvidner

This comment has been minimized.

Copy link
Owner Author

@mvidner mvidner commented Sep 21, 2020

nokogiri rpm has 9.5 MiB out of which 8.8 MiB is /usr/lib64/ruby/gems/2.7.0/cache/nokogiri-1.10.10.gem

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment