Skip to content

Instantly share code, notes, and snippets.

Embed
What would you like to do?
oberstet@intel-nuci7:~$ ~/cpy391/bin/python3 -m venv ~/cpy391_2
oberstet@intel-nuci7:~$ source ~/cpy391_2/bin/activate
(cpy391_2) oberstet@intel-nuci7:~$ python -V
Python 3.9.1
(cpy391_2) oberstet@intel-nuci7:~$ which python
/home/oberstet/cpy391_2/bin/python
(cpy391_2) oberstet@intel-nuci7:~$ pip install crossbar
Collecting crossbar
Using cached crossbar-21.2.1-py2.py3-none-any.whl (524 kB)
Collecting cryptography>=2.6.1
Using cached cryptography-3.4.6-cp36-abi3-manylinux2014_x86_64.whl (3.2 MB)
Collecting lmdb>=0.92
Using cached lmdb-1.1.1-cp39-cp39-manylinux2010_x86_64.whl (306 kB)
Collecting bcrypt>=3.1.6
Using cached bcrypt-3.2.0-cp36-abi3-manylinux2010_x86_64.whl (63 kB)
Collecting autobahn[asyncio,compress,encryption,scram,serialization,twisted]>=21.2.2
Using cached autobahn-21.2.2-py2.py3-none-any.whl (495 kB)
Collecting pyopenssl>=17.1.0
Using cached pyOpenSSL-20.0.1-py2.py3-none-any.whl (54 kB)
Collecting pyyaml>=4.2b4
Using cached PyYAML-5.4.1-cp39-cp39-manylinux1_x86_64.whl (630 kB)
Collecting netaddr>=0.7.19
Using cached netaddr-0.8.0-py2.py3-none-any.whl (1.9 MB)
Collecting pyasn1-modules>=0.2.4
Using cached pyasn1_modules-0.2.8-py2.py3-none-any.whl (155 kB)
Collecting mistune>=0.7.4
Using cached mistune-0.8.4-py2.py3-none-any.whl (16 kB)
Collecting jinja2>=2.10.1
Using cached Jinja2-2.11.3-py2.py3-none-any.whl (125 kB)
Collecting watchdog>=0.8.3
Using cached watchdog-2.0.2-py3-none-manylinux2014_x86_64.whl (74 kB)
Collecting werkzeug>=0.14.1
Using cached Werkzeug-1.0.1-py2.py3-none-any.whl (298 kB)
Collecting txaio>=21.2.1
Using cached txaio-21.2.1-py2.py3-none-any.whl (30 kB)
Collecting pynacl>=1.1.2
Using cached PyNaCl-1.4.0-cp35-abi3-manylinux1_x86_64.whl (961 kB)
Collecting setproctitle>=1.1.10
Using cached setproctitle-1.2.2-cp39-cp39-manylinux1_x86_64.whl (35 kB)
Collecting u-msgpack-python>=2.4.1
Using cached u_msgpack_python-2.7.1-py2.py3-none-any.whl (10.0 kB)
Collecting zope.interface>=4.4.2
Using cached zope.interface-5.2.0-cp39-cp39-manylinux2010_x86_64.whl (241 kB)
Requirement already satisfied: setuptools>=36.2.7 in ./cpy391_2/lib/python3.9/site-packages (from crossbar) (49.2.1)
Collecting attrs>=17.2.0
Using cached attrs-20.3.0-py2.py3-none-any.whl (49 kB)
Collecting passlib>=1.7.1
Using cached passlib-1.7.4-py2.py3-none-any.whl (525 kB)
Processing ./.cache/pip/wheels/8b/d8/bf/9ec5399e19d11203bd0da3641fdff44be81e5953a218755cb8/sdnotify-0.3.2-cp39-none-any.whl
Collecting txtorcon>=20.0.0
Using cached txtorcon-20.0.0-py2.py3-none-any.whl (260 kB)
Collecting importlib-resources>=4.1.1
Using cached importlib_resources-5.1.0-py3-none-any.whl (24 kB)
Processing ./.cache/pip/wheels/3d/8f/38/625705e37f4264d27cc1b6221cede35b64c391ad20c62fbe28/py_ubjson-0.16.1-cp39-cp39-linux_x86_64.whl
Collecting priority>=1.3.0
Using cached priority-1.3.0-py2.py3-none-any.whl (11 kB)
Collecting pygments>=2.2.0
Using cached Pygments-2.8.0-py3-none-any.whl (983 kB)
Collecting zlmdb>=21.2.1
Using cached zlmdb-21.2.1-py2.py3-none-any.whl (53 kB)
Collecting constantly>=15.1.0
Using cached constantly-15.1.0-py2.py3-none-any.whl (7.9 kB)
Processing ./.cache/pip/wheels/54/61/2f/a4f51b09473db5737db0f654ed10eb9a4ee01f83a7412de349/PyQRCode-1.2.1-cp39-none-any.whl
Collecting incremental>=17.5.0
Using cached incremental-17.5.0-py2.py3-none-any.whl (16 kB)
Collecting service-identity>=17.0.0
Using cached service_identity-18.1.0-py2.py3-none-any.whl (11 kB)
Collecting pyasn1>=0.4.5
Using cached pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)
Collecting h2>=3.2.0
Using cached h2-4.0.0-py3-none-any.whl (57 kB)
Processing ./.cache/pip/wheels/ef/2a/41/5870cad27097f3b3d7b3d96aa5897d502db08cafba9051bd62/PyTrie-0.4.0-cp39-none-any.whl
Collecting idna<2.6,>=2.5
Using cached idna-2.5-py2.py3-none-any.whl (55 kB)
Processing ./.cache/pip/wheels/40/5c/a5/e6d629446a6a687ba328c55f1589234c29b99ef35b1a65dbaa/cbor-1.0.0-cp39-cp39-linux_x86_64.whl
Processing ./.cache/pip/wheels/b8/27/f0/8373e26b7de57db03dc18aaaebdd8c26a99da882416f762979/bitstring-3.1.7-cp39-none-any.whl
Collecting treq>=20.4.1
Using cached treq-21.1.0-py2.py3-none-any.whl (64 kB)
Collecting psutil>=5.2.2
Using cached psutil-5.8.0-cp39-cp39-manylinux2010_x86_64.whl (293 kB)
Collecting urllib3<1.25,>=1.21.1
Using cached urllib3-1.24.3-py2.py3-none-any.whl (118 kB)
Collecting click>=6.7
Using cached click-7.1.2-py2.py3-none-any.whl (82 kB)
Collecting cffi>=1.12
Using cached cffi-1.14.5-cp39-cp39-manylinux1_x86_64.whl (406 kB)
Collecting six>=1.4.1
Using cached six-1.15.0-py2.py3-none-any.whl (10 kB)
Collecting hyperlink>=21.0.0
Using cached hyperlink-21.0.0-py2.py3-none-any.whl (74 kB)
Collecting python-snappy>=0.6.0; extra == "compress"
Using cached python_snappy-0.6.0-cp39-cp39-manylinux2010_x86_64.whl (54 kB)
Collecting argon2-cffi>=20.1.0; extra == "scram"
Using cached argon2_cffi-20.1.0-cp35-abi3-manylinux1_x86_64.whl (97 kB)
Processing ./.cache/pip/wheels/79/2f/49/db0452bf3ba70e944edfcca45221f758495f41000eb489a0d7/cbor2-5.2.0-cp39-cp39-linux_x86_64.whl
Collecting flatbuffers>=1.12; extra == "serialization"
Using cached flatbuffers-1.12-py2.py3-none-any.whl (15 kB)
Collecting msgpack>=1.0.2; extra == "serialization"
Using cached msgpack-1.0.2-cp39-cp39-manylinux1_x86_64.whl (294 kB)
Collecting ujson>=4.0.2; extra == "serialization"
Using cached ujson-4.0.2-cp39-cp39-manylinux1_x86_64.whl (179 kB)
Collecting twisted>=20.3.0; extra == "twisted"
Downloading Twisted-21.2.0-py3-none-any.whl (3.1 MB)
|████████████████████████████████| 3.1 MB 3.3 MB/s
Collecting MarkupSafe>=0.23
Using cached MarkupSafe-1.1.1-cp39-cp39-manylinux2010_x86_64.whl (32 kB)
Collecting automat
Using cached Automat-20.2.0-py2.py3-none-any.whl (31 kB)
Collecting numpy>=1.20.1
Using cached numpy-1.20.1-cp39-cp39-manylinux2010_x86_64.whl (15.4 MB)
Collecting hpack<5,>=4.0
Using cached hpack-4.0.0-py3-none-any.whl (32 kB)
Collecting hyperframe<7,>=6.0
Using cached hyperframe-6.0.0-py3-none-any.whl (11 kB)
Collecting sortedcontainers
Using cached sortedcontainers-2.3.0-py2.py3-none-any.whl (29 kB)
Collecting requests>=2.1.0
Using cached requests-2.25.1-py2.py3-none-any.whl (61 kB)
Collecting pycparser
Using cached pycparser-2.20-py2.py3-none-any.whl (112 kB)
Collecting certifi>=2017.4.17
Using cached certifi-2020.12.5-py2.py3-none-any.whl (147 kB)
Collecting chardet<5,>=3.0.2
Using cached chardet-4.0.0-py2.py3-none-any.whl (178 kB)
Installing collected packages: pycparser, cffi, cryptography, lmdb, six, bcrypt, txaio, idna, hyperlink, python-snappy, sortedcontainers, pytrie, pyasn1, pyasn1-modules, attrs, service-identity, pynacl, pyqrcode, pyopenssl, argon2-cffi, passlib, cbor2, flatbuffers, py-ubjson, msgpack, cbor, ujson, zope.interface, incremental, constantly, automat, twisted, autobahn, pyyaml, netaddr, mistune, MarkupSafe, jinja2, watchdog, werkzeug, setproctitle, u-msgpack-python, sdnotify, txtorcon, importlib-resources, priority, pygments, numpy, click, zlmdb, hpack, hyperframe, h2, bitstring, certifi, chardet, urllib3, requests, treq, psutil, crossbar
Successfully installed MarkupSafe-1.1.1 argon2-cffi-20.1.0 attrs-20.3.0 autobahn-21.2.2 automat-20.2.0 bcrypt-3.2.0 bitstring-3.1.7 cbor-1.0.0 cbor2-5.2.0 certifi-2020.12.5 cffi-1.14.5 chardet-4.0.0 click-7.1.2 constantly-15.1.0 crossbar-21.2.1 cryptography-3.4.6 flatbuffers-1.12 h2-4.0.0 hpack-4.0.0 hyperframe-6.0.0 hyperlink-21.0.0 idna-2.5 importlib-resources-5.1.0 incremental-17.5.0 jinja2-2.11.3 lmdb-1.1.1 mistune-0.8.4 msgpack-1.0.2 netaddr-0.8.0 numpy-1.20.1 passlib-1.7.4 priority-1.3.0 psutil-5.8.0 py-ubjson-0.16.1 pyasn1-0.4.8 pyasn1-modules-0.2.8 pycparser-2.20 pygments-2.8.0 pynacl-1.4.0 pyopenssl-20.0.1 pyqrcode-1.2.1 python-snappy-0.6.0 pytrie-0.4.0 pyyaml-5.4.1 requests-2.25.1 sdnotify-0.3.2 service-identity-18.1.0 setproctitle-1.2.2 six-1.15.0 sortedcontainers-2.3.0 treq-21.1.0 twisted-21.2.0 txaio-21.2.1 txtorcon-20.0.0 u-msgpack-python-2.7.1 ujson-4.0.2 urllib3-1.24.3 watchdog-2.0.2 werkzeug-1.0.1 zlmdb-21.2.1 zope.interface-5.2.0
WARNING: You are using pip version 20.2.3; however, version 21.0.1 is available.
You should consider upgrading via the '/home/oberstet/cpy391_2/bin/python3 -m pip install --upgrade pip' command.
(cpy391_2) oberstet@intel-nuci7:~$ which crossbar
/home/oberstet/cpy391_2/bin/crossbar
(cpy391_2) oberstet@intel-nuci7:~$ crossbar version
:::::::::::::::::
::::: _____ __
::::: : ::::: / ___/____ ___ ___ ___ / / ___ _ ____
::::::: ::::::: / /__ / __// _ \ (_-< (_-< / _ \/ _ `// __/
::::: : ::::: \___//_/ \___//___//___//_.__/\_,_//_/
:::::
::::::::::::::::: Crossbar v21.2.1
Copyright (c) 2013-2021 Crossbar.io Technologies GmbH, licensed under AGPL 3.0.
Crossbar.io : 21.2.1
txaio : 21.2.1
Autobahn : 21.2.2
UTF8 Validator : autobahn
XOR Masker : autobahn
JSON Codec : stdlib
MsgPack Codec : msgpack-1.0.2
CBOR Codec : cbor-1.0.0
UBJSON Codec : ubjson-0.16.1
FlatBuffers : flatbuffers-1.12
Twisted : 21.2.0-EPollReactor
LMDB : 1.1.1/lmdb-0.9.26
Python : 3.9.1/CPython
PIP : 20.2.3
Frozen executable : no
Operating system : Linux-4.15.0-136-generic-x86_64-with-glibc2.27
Host machine : x86_64
Release key : RWSPS2sNAXZ18kBoP19HNmkQL4O7eIhZIxpMrQ3WYpvHy9L5orbDzXGg
(cpy391_2) oberstet@intel-nuci7:~$
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment