Skip to content

Instantly share code, notes, and snippets.

@p-mongo

p-mongo/pasted.txt Secret

Created Jul 8, 2020
Embed
What would you like to do?
Tenex Paste
HEAD is now at 7504c39 SERVER-49142 Test unexpected values in command.$audit
HEAD is now at 4b96db9412 Import wiredtiger: 95e4b38eebbb4050b2144341c5f60e5a2f5c40b9 from branch mongodb-4.4
Ignoring pypiwin32: markers 'sys_platform == "win32" and python_version > "3"' don't match your environment
Ignoring pywin32: markers 'sys_platform == "win32" and python_version > "3"' don't match your environment
Requirement already satisfied: psutil in /home/build/.local/lib/python3.8/site-packages (from -r buildscripts/../etc/pip/components/core.req (line 2)) (5.7.0)
Requirement already satisfied: pymongo!=3.6.0,>=3.0 in /home/build/.local/lib/python3.8/site-packages (from -r buildscripts/../etc/pip/components/core.req (line 3)) (3.10.1)
Requirement already satisfied: PyYAML>=3.0.0 in /home/build/.local/lib/python3.8/site-packages (from -r buildscripts/../etc/pip/components/core.req (line 4)) (5.3.1)
Requirement already satisfied: requests>=2.0.0 in /usr/lib/python3/dist-packages (from -r buildscripts/../etc/pip/components/core.req (line 5)) (2.23.0)
Requirement already satisfied: Cheetah3 in /home/build/.local/lib/python3.8/site-packages (from -r buildscripts/../etc/pip/components/compile.req (line 2)) (3.2.5)
Requirement already satisfied: regex in /home/build/.local/lib/python3.8/site-packages (from -r buildscripts/../etc/pip/components/compile.req (line 4)) (2020.6.8)
Requirement already satisfied: GitPython~=2.1.11 in /home/build/.local/lib/python3.8/site-packages (from -r buildscripts/../etc/pip/components/lint.req (line 3)) (2.1.15)
Collecting mypy==0.580
Using cached mypy-0.580-py3-none-any.whl (1.2 MB)
Collecting pydocstyle==2.1.1
Using cached pydocstyle-2.1.1-py3-none-any.whl (31 kB)
Collecting pylint==2.3.1
Using cached pylint-2.3.1-py3-none-any.whl (765 kB)
Collecting structlog~=19.1.0
Using cached structlog-19.1.0-py2.py3-none-any.whl (31 kB)
Collecting typing
Using cached typing-3.7.4.1-py3-none-any.whl (25 kB)
Collecting yamllint==1.15.0
Using cached yamllint-1.15.0-py2.py3-none-any.whl (44 kB)
Collecting yapf==0.26.0
Using cached yapf-0.26.0-py2.py3-none-any.whl (176 kB)
Processing /home/build/.cache/pip/wheels/af/f3/71/792a8820e2f74d0ed964236ccb1ea610312f092288f3fa3395/PyKMIP-0.4.0-py3-none-any.whl
Collecting evergreen.py==1.3.0
Using cached evergreen.py-1.3.0-py3-none-any.whl (41 kB)
Requirement already satisfied: jinja2 in /usr/lib/python3/dist-packages (from -r buildscripts/../etc/pip/components/resmoke.req (line 3)) (2.11.2)
Collecting mock
Using cached mock-4.0.2-py3-none-any.whl (28 kB)
Collecting shrub.py==1.1.0
Using cached shrub.py-1.1.0-py3-none-any.whl (27 kB)
Collecting ocspresponder==0.5.0
Using cached ocspresponder-0.5.0-py3-none-any.whl (9.3 kB)
Collecting flask==1.1.1
Using cached Flask-1.1.1-py2.py3-none-any.whl (94 kB)
Collecting ocspbuilder==0.10.2
Using cached ocspbuilder-0.10.2-py2.py3-none-any.whl (8.8 kB)
Collecting passlib==1.7.1
Using cached passlib-1.7.1-py2.py3-none-any.whl (498 kB)
Collecting pyOpenSSL==19.0.0
Using cached pyOpenSSL-19.0.0-py2.py3-none-any.whl (53 kB)
Collecting pyparsing==2.4.0
Using cached pyparsing-2.4.0-py2.py3-none-any.whl (62 kB)
Collecting service_identity==18.1.0
Using cached service_identity-18.1.0-py2.py3-none-any.whl (11 kB)
Processing /home/build/.cache/pip/wheels/38/9b/1d/58406ccd3c2517a7d997beebca439ec5a4f261799c90478186/Twisted-19.2.1-cp38-cp38-linux_x86_64.whl
Processing /home/build/.cache/pip/wheels/7b/d8/f3/25f0ebe4f615c9ca185bd2908f7e78f5f001d6ee663afdd93a/zope.interface-4.6.0-cp38-cp38-linux_x86_64.whl
Collecting ldaptor==19.0.0
Using cached ldaptor-19.0.0-py2.py3-none-any.whl (178 kB)
Collecting click~=7.0
Using cached click-7.1.2-py2.py3-none-any.whl (82 kB)
Collecting jira
Using cached jira-2.0.0-py2.py3-none-any.whl (57 kB)
Processing /home/build/.cache/pip/wheels/50/8d/8a/c03994427e62ace597b9e499e92cecd0d3258975e9a1f12883/requests_oauth-0.4.1-py3-none-any.whl
Collecting PyJWT
Using cached PyJWT-1.7.1-py2.py3-none-any.whl (18 kB)
Collecting cryptography==2.3
Using cached cryptography-2.3-cp34-abi3-manylinux1_x86_64.whl (2.1 MB)
Requirement already satisfied: gitdb2<3,>=2 in /home/build/.local/lib/python3.8/site-packages (from GitPython~=2.1.11->-r buildscripts/../etc/pip/components/lint.req (line 3)) (2.0.6)
Collecting typed-ast<1.2.0,>=1.1.0
Using cached typed-ast-1.1.2.tar.gz (202 kB)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from pydocstyle==2.1.1->-r buildscripts/../etc/pip/components/lint.req (line 5)) (1.15.0)
Collecting snowballstemmer
Using cached snowballstemmer-2.0.0-py2.py3-none-any.whl (97 kB)
Collecting mccabe<0.7,>=0.6
Using cached mccabe-0.6.1-py2.py3-none-any.whl (8.6 kB)
Collecting isort<5,>=4.2.5
Using cached isort-4.3.21-py2.py3-none-any.whl (42 kB)
Collecting astroid<3,>=2.2.0
Using cached astroid-2.4.2-py3-none-any.whl (213 kB)
Collecting pathspec>=0.5.3
Using cached pathspec-0.8.0-py2.py3-none-any.whl (28 kB)
Collecting enum34
Using cached enum34-1.1.10-py3-none-any.whl (11 kB)
Collecting tenacity<6.0.0,>=5.0.4
Using cached tenacity-5.1.5-py2.py3-none-any.whl (34 kB)
Collecting python-dateutil<3.0.0,>=2.8.1
Using cached python_dateutil-2.8.1-py2.py3-none-any.whl (227 kB)
Collecting bottle<0.13,>=0.12.9
Using cached bottle-0.12.18-py3-none-any.whl (89 kB)
Collecting itsdangerous>=0.24
Using cached itsdangerous-1.1.0-py2.py3-none-any.whl (16 kB)
Collecting Werkzeug>=0.15
Using cached Werkzeug-1.0.1-py2.py3-none-any.whl (298 kB)
Collecting oscrypto>=0.16.1
Using cached oscrypto-1.2.0-py2.py3-none-any.whl (192 kB)
Collecting asn1crypto>=0.18.1
Using cached asn1crypto-1.3.0-py2.py3-none-any.whl (103 kB)
Collecting pyasn1
Using cached pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)
Collecting pyasn1-modules
Using cached pyasn1_modules-0.2.8-py2.py3-none-any.whl (155 kB)
Collecting attrs>=16.0.0
Using cached attrs-19.3.0-py2.py3-none-any.whl (39 kB)
Collecting hyperlink>=17.1.1
Using cached hyperlink-19.0.0-py2.py3-none-any.whl (38 kB)
Collecting Automat>=0.3.0
Using cached Automat-20.2.0-py2.py3-none-any.whl (31 kB)
Collecting constantly>=15.1
Using cached constantly-15.1.0-py2.py3-none-any.whl (7.9 kB)
Collecting PyHamcrest>=1.9.0
Using cached PyHamcrest-2.0.2-py3-none-any.whl (52 kB)
Collecting incremental>=16.10.1
Using cached incremental-17.5.0-py2.py3-none-any.whl (16 kB)
Requirement already satisfied: setuptools in /home/build/.local/lib/python3.8/site-packages (from zope.interface==4.6.0->-r buildscripts/../etc/pip/components/external_auth.req (line 7)) (45.0.0)
Collecting defusedxml
Using cached defusedxml-0.6.0-py2.py3-none-any.whl (23 kB)
Collecting oauthlib[signedtoken]>=1.0.0
Using cached oauthlib-3.1.0-py2.py3-none-any.whl (147 kB)
Collecting requests-toolbelt
Using cached requests_toolbelt-0.9.1-py2.py3-none-any.whl (54 kB)
Collecting requests-oauthlib>=0.6.1
Using cached requests_oauthlib-1.3.0-py2.py3-none-any.whl (23 kB)
Collecting pbr>=3.0.0
Using cached pbr-5.4.5-py2.py3-none-any.whl (110 kB)
Collecting cffi!=1.11.3,>=1.7
Using cached cffi-1.14.0-cp38-cp38-manylinux1_x86_64.whl (409 kB)
Requirement already satisfied: idna>=2.1 in /usr/lib/python3/dist-packages (from cryptography==2.3->-r buildscripts/../etc/pip/components/jiraclient.req (line 5)) (2.9)
Requirement already satisfied: smmap2>=2.0.0 in /home/build/.local/lib/python3.8/site-packages (from gitdb2<3,>=2->GitPython~=2.1.11->-r buildscripts/../etc/pip/components/lint.req (line 3)) (3.0.1)
Processing /home/build/.cache/pip/wheels/5f/fd/9e/b6cf5890494cb8ef0b5eaff72e5d55a70fb56316007d6dfe73/wrapt-1.12.1-cp38-cp38-linux_x86_64.whl
Collecting lazy-object-proxy==1.4.*
Using cached lazy_object_proxy-1.4.3-cp38-cp38-manylinux1_x86_64.whl (58 kB)
Collecting pycparser
Using cached pycparser-2.20-py2.py3-none-any.whl (112 kB)
Requirement already satisfied: smmap>=3.0.1 in /home/build/.local/lib/python3.8/site-packages (from smmap2>=2.0.0->gitdb2<3,>=2->GitPython~=2.1.11->-r buildscripts/../etc/pip/components/lint.req (line 3)) (3.0.4)
Building wheels for collected packages: typed-ast
Building wheel for typed-ast (setup.py): started
Building wheel for typed-ast (setup.py): finished with status 'error'
ERROR: Command errored out with exit status 1:
command: /usr/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-262v9yio/typed-ast/setup.py'"'"'; __file__='"'"'/tmp/pip-install-262v9yio/typed-ast/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d /tmp/pip-wheel-gxqfegnf
cwd: /tmp/pip-install-262v9yio/typed-ast/
Complete output (23 lines):
running bdist_wheel
running build
running build_py
creating build
creating build/lib.linux-x86_64-3.8
creating build/lib.linux-x86_64-3.8/typed_ast
copying typed_ast/conversions.py -> build/lib.linux-x86_64-3.8/typed_ast
copying typed_ast/ast3.py -> build/lib.linux-x86_64-3.8/typed_ast
copying typed_ast/__init__.py -> build/lib.linux-x86_64-3.8/typed_ast
copying typed_ast/ast27.py -> build/lib.linux-x86_64-3.8/typed_ast
running build_ext
building '_ast27' extension
creating build/temp.linux-x86_64-3.8
creating build/temp.linux-x86_64-3.8/ast27
creating build/temp.linux-x86_64-3.8/ast27/Parser
creating build/temp.linux-x86_64-3.8/ast27/Python
creating build/temp.linux-x86_64-3.8/ast27/Custom
x86_64-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -Iast27/Include -I/usr/include/python3.8 -c ast27/Parser/acceler.c -o build/temp.linux-x86_64-3.8/ast27/Parser/acceler.o
ast27/Parser/acceler.c:13:10: fatal error: pgenheaders.h: No such file or directory
13 | #include "pgenheaders.h"
| ^~~~~~~~~~~~~~~
compilation terminated.
error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
----------------------------------------
ERROR: Failed building wheel for typed-ast
Running setup.py clean for typed-ast
Failed to build typed-ast
Installing collected packages: typed-ast, mypy, snowballstemmer, pydocstyle, mccabe, isort, wrapt, lazy-object-proxy, astroid, pylint, structlog, typing, pathspec, yamllint, yapf, enum34, PyKMIP, click, tenacity, python-dateutil, evergreen.py, mock, shrub.py, asn1crypto, oscrypto, ocspbuilder, bottle, ocspresponder, itsdangerous, Werkzeug, flask, passlib, pycparser, cffi, cryptography, pyOpenSSL, pyparsing, pyasn1, pyasn1-modules, attrs, service-identity, hyperlink, Automat, constantly, zope.interface, PyHamcrest, incremental, twisted, ldaptor, defusedxml, PyJWT, oauthlib, requests-toolbelt, requests-oauthlib, pbr, jira, requests-oauth
Attempting uninstall: typed-ast
Found existing installation: typed-ast 1.4.0
Uninstalling typed-ast-1.4.0:
Successfully uninstalled typed-ast-1.4.0
Running setup.py install for typed-ast: started
Running setup.py install for typed-ast: finished with status 'error'
ERROR: Command errored out with exit status 1:
command: /usr/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-262v9yio/typed-ast/setup.py'"'"'; __file__='"'"'/tmp/pip-install-262v9yio/typed-ast/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-8z8zcirp/install-record.txt --single-version-externally-managed --user --prefix= --compile --install-headers /home/build/.local/include/python3.8/typed-ast
cwd: /tmp/pip-install-262v9yio/typed-ast/
Complete output (23 lines):
running install
running build
running build_py
creating build
creating build/lib.linux-x86_64-3.8
creating build/lib.linux-x86_64-3.8/typed_ast
copying typed_ast/conversions.py -> build/lib.linux-x86_64-3.8/typed_ast
copying typed_ast/ast3.py -> build/lib.linux-x86_64-3.8/typed_ast
copying typed_ast/__init__.py -> build/lib.linux-x86_64-3.8/typed_ast
copying typed_ast/ast27.py -> build/lib.linux-x86_64-3.8/typed_ast
running build_ext
building '_ast27' extension
creating build/temp.linux-x86_64-3.8
creating build/temp.linux-x86_64-3.8/ast27
creating build/temp.linux-x86_64-3.8/ast27/Parser
creating build/temp.linux-x86_64-3.8/ast27/Python
creating build/temp.linux-x86_64-3.8/ast27/Custom
x86_64-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2 -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -Iast27/Include -I/usr/include/python3.8 -c ast27/Parser/acceler.c -o build/temp.linux-x86_64-3.8/ast27/Parser/acceler.o
ast27/Parser/acceler.c:13:10: fatal error: pgenheaders.h: No such file or directory
13 | #include "pgenheaders.h"
| ^~~~~~~~~~~~~~~
compilation terminated.
error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
----------------------------------------
Rolling back uninstall of typed-ast
Moving to /home/build/.local/lib/python3.8/site-packages/typed_ast-1.4.0.dist-info/
from /home/build/.local/lib/python3.8/site-packages/~yped_ast-1.4.0.dist-info
Moving to /home/build/.local/lib/python3.8/site-packages/typed_ast/
from /home/build/.local/lib/python3.8/site-packages/~yped_ast
ERROR: Command errored out with exit status 1: /usr/bin/python3 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-262v9yio/typed-ast/setup.py'"'"'; __file__='"'"'/tmp/pip-install-262v9yio/typed-ast/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-8z8zcirp/install-record.txt --single-version-externally-managed --user --prefix= --compile --install-headers /home/build/.local/include/python3.8/typed-ast Check the logs for full command output.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment