Instantly share code, notes, and snippets.

Embed
What would you like to do?
`bundle install` won't install ffi as libnotify dependency but gem install will
(vm:sandbox) [rupert] 08:42 <1.9.3p194> ~/develop/rails_with_notification > gem uninstall ffi
You have requested to uninstall the gem:
ffi-1.0.11
libnotify-0.7.3 depends on [ffi (~> 1.0.0)]
If you remove this gems, one or more dependencies will not be met.
Continue with Uninstall? [Yn] y
Successfully uninstalled ffi-1.0.11
(vm:sandbox) [rupert] 08:42 <1.9.3p194> ~/develop/rails_with_notification > gem uninstall libnotify
Successfully uninstalled libnotify-0.7.3
(vm:sandbox) [rupert] 08:42 <1.9.3p194> ~/develop/rails_with_notification > gem list
*** LOCAL GEMS ***
aaronh-chronic (0.3.9)
abstract (1.0.0)
actionmailer (3.2.6, 3.1.0, 3.0.13, 3.0.1)
actionpack (3.2.6, 3.1.0, 3.0.13, 3.0.1)
activemodel (3.2.6, 3.1.0, 3.0.13, 3.0.1)
activerecord (3.2.6, 3.1.0, 3.0.13, 3.0.1)
activeresource (3.2.6, 3.1.0, 3.0.13, 3.0.1)
activesupport (3.2.6, 3.1.0, 3.0.13, 3.0.1)
archive-tar-minitar (0.5.2)
arel (3.0.2, 2.2.1, 2.0.10, 1.0.1)
awesome_print (0.3.1)
bcrypt-ruby (3.0.1, 2.1.2)
bigdecimal (1.1.0)
bond (0.3.3)
builder (3.0.0, 2.1.2)
bundler (1.1.4, 1.0.12)
capistrano (2.12.0)
celerity (0.8.4)
coffee-rails (3.2.2)
coffee-script (2.2.0)
coffee-script-source (1.3.3)
columnize (0.3.2)
compass (0.10.6)
configuration (1.1.0)
crack (0.1.8)
cucumber (1.0.2)
cucumber-rails (0.3.2)
culerity (0.2.12)
database_cleaner (0.6.7)
devise (1.1.3)
diff-lcs (1.1.2)
duration (0.1.0)
erubis (2.7.0, 2.6.6)
execjs (1.4.0)
factory_girl (1.3.2)
factory_girl_rails (1.0)
gherkin (2.4.5)
gravatarify (2.2.1)
haml (3.0.23)
hashie (0.4.0)
highline (1.6.12)
hike (1.2.1)
hirb (0.3.5)
hoe (2.6.2)
httparty (0.6.1)
i18n (0.6.0, 0.5.0, 0.4.2)
interactive_editor (0.0.5)
io-console (0.3)
irb_callbacks (0.1.0)
journey (1.0.4, 1.0.3)
jquery-rails (2.0.2)
json (1.7.3, 1.5.4, 1.5.3)
json_pure (1.4.6)
kgio (2.7.4)
launchy (0.3.7)
libv8 (3.3.10.4 x86_64-linux)
mail (2.4.4, 2.3.0, 2.2.19, 2.2.9)
mime-types (1.18, 1.16)
minitest (2.5.1)
multi_json (1.3.6, 1.0.3, 0.0.5)
mysql2 (0.2.6)
net-scp (1.0.4)
net-sftp (2.0.5)
net-ssh (2.5.2)
net-ssh-gateway (1.1.0)
nokogiri (1.4.3.1)
oauth (0.4.4)
paperclip (2.3.8)
polyglot (0.3.3, 0.3.2, 0.3.1)
rack (1.4.1, 1.3.3, 1.2.5, 1.2.1)
rack-cache (1.2, 1.0.3)
rack-mount (0.8.3, 0.6.14, 0.6.13)
rack-ssl (1.3.2)
rack-test (0.6.1, 0.5.7, 0.5.6)
rails (3.2.6, 3.1.0, 3.0.13)
rails_autolink (1.0.9)
railties (3.2.6, 3.1.0, 3.0.13)
raindrops (0.8.0)
rake (0.9.2.2, 0.9.2, 0.8.7)
rbx-require-relative (0.0.9)
rdoc (3.12, 3.9.4)
rspec (2.1.0)
rspec-core (2.1.0)
rspec-expectations (2.1.0)
rspec-mocks (2.1.0)
rspec-rails (2.1.0)
ruby_core_source (0.1.5)
rubyforge (2.0.4)
rvm (1.0.21)
sass (3.1.19)
sass-rails (3.2.5)
simple-rss (1.2.3)
spoon (0.0.1)
sprockets (2.1.3, 2.0.0)
sqlite3 (1.3.6, 1.3.5, 1.3.4)
term-ansicolor (1.0.5)
therubyracer (0.10.1)
thor (0.15.2, 0.14.6)
tilt (1.3.3)
treetop (1.4.10, 1.4.8)
twitter (0.9.12)
tzinfo (0.3.33, 0.3.29, 0.3.23)
uglifier (1.2.4)
unicorn (4.2.1)
warden (0.10.7)
what_methods (1.0.1)
whenever (0.6.2)
wirble (0.1.3)
(vm:sandbox) [rupert] 08:42 <1.9.3p194> ~/develop/rails_with_notification > gem list | grep ffi
(vm:sandbox) [rupert] 08:42 <1.9.3p194> ~/develop/rails_with_notification > cat Gemfile
source 'https://rubygems.org'
gem 'rails', '3.2.6'
gem 'sqlite3'
group :assets do
gem 'sass-rails', '~> 3.2.3'
gem 'coffee-rails', '~> 3.2.1'
gem 'therubyracer'
gem 'uglifier', '>= 1.0.3'
end
gem 'jquery-rails'
group :linux do
#gem 'ffi'
gem 'libnotify'
end
gem 'growl', :group => :darwin
(vm:sandbox) [rupert] 08:42 <1.9.3p194> ~/develop/rails_with_notification > bundle install
Fetching gem metadata from https://rubygems.org/.........
Using rake (0.9.2.2)
Using i18n (0.6.0)
Using multi_json (1.3.6)
Using activesupport (3.2.6)
Using builder (3.0.0)
Using activemodel (3.2.6)
Using erubis (2.7.0)
Using journey (1.0.4)
Using rack (1.4.1)
Using rack-cache (1.2)
Using rack-test (0.6.1)
Using hike (1.2.1)
Using tilt (1.3.3)
Using sprockets (2.1.3)
Using actionpack (3.2.6)
Using mime-types (1.18)
Using polyglot (0.3.3)
Using treetop (1.4.10)
Using mail (2.4.4)
Using actionmailer (3.2.6)
Using arel (3.0.2)
Using tzinfo (0.3.33)
Using activerecord (3.2.6)
Using activeresource (3.2.6)
Using bundler (1.1.4)
Using coffee-script-source (1.3.3)
Using execjs (1.4.0)
Using coffee-script (2.2.0)
Using rack-ssl (1.3.2)
Using json (1.7.3)
Using rdoc (3.12)
Using thor (0.15.2)
Using railties (3.2.6)
Using coffee-rails (3.2.2)
Using jquery-rails (2.0.2)
Installing libnotify (0.7.3)
Using libv8 (3.3.10.4)
Using rails (3.2.6)
Using sass (3.1.19)
Using sass-rails (3.2.5)
Using sqlite3 (1.3.6)
Using therubyracer (0.10.1)
Using uglifier (1.2.4)
Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.
(vm:sandbox) [rupert] 08:42 <1.9.3p194> ~/develop/rails_with_notification > gem list | grep ffi
(vm:sandbox) [rupert] 08:43 <1.9.3p194> ~/develop/rails_with_notification > rails s
=> Booting WEBrick
=> Rails 3.2.6 application starting in development on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
/home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require': cannot load such file -- ffi (LoadError)
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `block in require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:236:in `load_dependency'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/libnotify-0.7.3/lib/libnotify/ffi.rb:4:in `<module:FFI>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/libnotify-0.7.3/lib/libnotify/ffi.rb:3:in `<module:Libnotify>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/libnotify-0.7.3/lib/libnotify/ffi.rb:1:in `<top (required)>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `block in require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:236:in `load_dependency'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/libnotify-0.7.3/lib/libnotify/api.rb:1:in `<top (required)>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `block in require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:236:in `load_dependency'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/libnotify-0.7.3/lib/libnotify.rb:2:in `<top (required)>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler/runtime.rb:68:in `require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler/runtime.rb:68:in `block (2 levels) in require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler/runtime.rb:66:in `each'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler/runtime.rb:66:in `block in require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler/runtime.rb:55:in `each'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler/runtime.rb:55:in `require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler.rb:119:in `require'
from /home/rupert/develop/rails_with_notification/config/environments/development.rb:41:in `<top (required)>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `block in require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:236:in `load_dependency'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/engine.rb:571:in `block in <class:Engine>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/initializable.rb:30:in `instance_exec'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/initializable.rb:30:in `run'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/initializable.rb:55:in `block in run_initializers'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/initializable.rb:54:in `each'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/initializable.rb:54:in `run_initializers'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/application.rb:136:in `initialize!'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/railtie/configurable.rb:30:in `method_missing'
from /home/rupert/develop/rails_with_notification/config/environment.rb:5:in `<top (required)>'
from /home/rupert/develop/rails_with_notification/config.ru:4:in `require'
from /home/rupert/develop/rails_with_notification/config.ru:4:in `block in <main>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/builder.rb:51:in `instance_eval'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/builder.rb:51:in `initialize'
from /home/rupert/develop/rails_with_notification/config.ru:1:in `new'
from /home/rupert/develop/rails_with_notification/config.ru:1:in `<main>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/builder.rb:40:in `eval'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/builder.rb:40:in `parse_file'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/server.rb:200:in `app'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/commands/server.rb:46:in `app'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/server.rb:301:in `wrapped_app'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/server.rb:252:in `start'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/commands/server.rb:70:in `start'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/commands.rb:55:in `block in <top (required)>'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/commands.rb:50:in `tap'
from /home/rupert/binary/ruby-1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.6/lib/rails/commands.rb:50:in `<top (required)>'
from script/rails:6:in `require'
from script/rails:6:in `<main>'
(vm:sandbox) [rupert] 08:43 <1.9.3p194> ~/develop/rails_with_notification > gem uninstall libnotify
Successfully uninstalled libnotify-0.7.3
(vm:sandbox) [rupert] 08:44 <1.9.3p194> ~/develop/rails_with_notification > gem uninstall ffi
INFO: gem "ffi" is not installed
(vm:sandbox) [rupert] 08:44 <1.9.3p194> ~/develop/rails_with_notification > gem install libnotify
Fetching: ffi-1.0.11.gem (100%)
Building native extensions. This could take a while...
Fetching: libnotify-0.7.3.gem (100%)
Successfully installed ffi-1.0.11
Successfully installed libnotify-0.7.3
2 gems installed
Installing ri documentation for ffi-1.0.11...
Installing ri documentation for libnotify-0.7.3...
Installing RDoc documentation for ffi-1.0.11...
Installing RDoc documentation for libnotify-0.7.3...
(vm:sandbox) [rupert] 08:45 <1.9.3p194> ~/develop/rails_with_notification > vim Gemfile
(vm:sandbox) [rupert] 08:45 <1.9.3p194> ~/develop/rails_with_notification > cat Gemfile
source 'https://rubygems.org'
gem 'rails', '3.2.6'
gem 'sqlite3'
group :assets do
gem 'sass-rails', '~> 3.2.3'
gem 'coffee-rails', '~> 3.2.1'
gem 'therubyracer'
gem 'uglifier', '>= 1.0.3'
end
gem 'jquery-rails'
group :linux do
gem 'ffi' # Uncommented now
gem 'libnotify'
end
gem 'growl', :group => :darwin
(vm:sandbox) [rupert] 08:45 <1.9.3p194> ~/develop/rails_with_notification > rails s
=> Booting WEBrick
=> Rails 3.2.6 application starting in development on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2012-06-15 08:48:14] INFO WEBrick 1.3.1
[2012-06-15 08:48:14] INFO ruby 1.9.3 (2012-04-20) [x86_64-linux]
[2012-06-15 08:48:14] INFO WEBrick::HTTPServer#start: pid=9578 port=3000
^C[2012-06-15 08:48:17] INFO going to shutdown ...
[2012-06-15 08:48:17] INFO WEBrick::HTTPServer#start done.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment