public
Created

Baseline Tox config for supported versions of Python and Django.

  • Download Gist
tox.ini
INI
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86
# See http://tox.testrun.org/
#
# Supported Python 2.* environments: py{26,27,py}-dj{13,14,dev}
# Supported Python 3.* environments: py{31,32}-djdev
 
[tox]
minversion = 1.4
envlist = py27-dj14
# envlist =
# py26-dj13, py26-dj14, py26-djdev,
# py27-dj13, py27-dj14, py27-djdev,
# pypy-dj13, pypy-dj14, pypy-djdev,
# py31-djdev,
# py32-djdev,
 
[testenv]
deps =
...
changedir = {toxworkdir}
setenv =
...
commands =
...
 
# Python 2.6
[testenv:py26-dj13]
basepython = python2.6
deps =
{[testenv]deps}
Django>=1.3,<1.4
[testenv:py26-dj14]
basepython = python2.6
deps =
{[testenv]deps}
Django>=1.4,<1.5
[testenv:py26-djdev]
basepython = python2.6
deps =
{[testenv]deps}
https://github.com/django/django/tarball/master
 
# Python 2.7
[testenv:py27-dj13]
basepython = python2.7
deps =
{[testenv]deps}
Django>=1.3,<1.4
[testenv:py27-dj14]
basepython = python2.7
deps =
{[testenv]deps}
Django>=1.4,<1.5
[testenv:py27-djdev]
basepython = python2.7
deps =
{[testenv]deps}
https://github.com/django/django/tarball/master
 
# PyPy
[testenv:pypy-dj13]
basepython = pypy
deps =
{[testenv]deps}
Django>=1.3,<1.4
[testenv:pypy-dj14]
basepython = pypy
deps =
{[testenv]deps}
Django>=1.4,<1.5
[testenv:pypy-djdev]
basepython = pypy
deps =
{[testenv]deps}
https://github.com/django/django/tarball/master
 
# Python 3.*
[testenv:py31-djdev]
basepython = python3.1
deps =
{[testenv]deps}
https://github.com/django/django/tarball/master
[testenv:py32-djdev]
basepython = python3.2
deps =
{[testenv]deps}
https://github.com/django/django/tarball/master

Please sign in to comment on this gist.

Something went wrong with that request. Please try again.